aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-26 17:41:45 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-01-26 17:41:45 +0000
commit6bb5042363d1efc72aaaacf8d15a2be69db865a3 (patch)
tree52ec3cd0fb415301f2cec084ffcf56799eb88589 /sysutils
parent5920a5c3f1e461e3852f43de987a5f4b2ae3822f (diff)
This is a perl wrapper to "jexec" with more feature.
Script takes system jail id, rc.conf order id, full hostname of jail or rc.conf name of jail. If no command for jail is given - run default ('bash' or other). No additional software or tools like "jailer" are needed. WWW: http://legh.ru/jx/ - Dmiry Shulgachik legh@legh.ru PR: ports/ports/130148 Submitted by: Dmitry Shulgachik <legh at legh.ru>
Notes
Notes: svn path=/head/; revision=226897
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/jx/Makefile45
-rw-r--r--sysutils/jx/distinfo3
-rw-r--r--sysutils/jx/pkg-descr12
4 files changed, 61 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 041b0c7dbcf4..2a36f64462d5 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -355,6 +355,7 @@
SUBDIR += jps
SUBDIR += jtop
SUBDIR += jtopen
+ SUBDIR += jx
SUBDIR += k3b
SUBDIR += k8temp
SUBDIR += kcpuload
diff --git a/sysutils/jx/Makefile b/sysutils/jx/Makefile
new file mode 100644
index 000000000000..a590e41dc034
--- /dev/null
+++ b/sysutils/jx/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: jx
+# Date created: 15 December 2008
+# Whom: Dmitry Shulgachik <legh@legh.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jx
+PORTVERSION= 1.10
+CATEGORIES= sysutils
+MASTER_SITES= http://legh.ru/wp-content/uploads/jx/
+
+MAINTAINER= legh@legh.ru
+COMMENT= Wrapper to jexec with more feature in interpreting jail id
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+MAN1= jx.1
+MANCOMPRESSED= yes
+
+OPTIONS= CONFIG "Enable custom config (recuire Config::General)" Off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_CONFIG)
+RUN_DEPENDS= ${SITE_PERL}/Config/General.pm:${PORTSDIR}/devel/p5-Config-General
+PLIST_FILES+= etc/${PORTNAME}.cfg.sample
+.endif
+
+post-patch:
+.if !defined(WITHOUT_CONFIG)
+ ${REINPLACE_CMD} -e 's/use constant use_config => 0;/use constant use_config => 1;/' ${WRKSRC}/${PORTNAME}.pl
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1.gz ${PREFIX}/man/man1/${PORTNAME}.1.gz
+.if !defined(WITHOUT_CONFIG)
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.cfg.sample ${PREFIX}/etc/${PORTNAME}.cfg.sample
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/jx/distinfo b/sysutils/jx/distinfo
new file mode 100644
index 000000000000..9a67ab2d7da4
--- /dev/null
+++ b/sysutils/jx/distinfo
@@ -0,0 +1,3 @@
+MD5 (jx-1.10.tar.gz) = ce9f6fb47870cdd7795408180d07986b
+SHA256 (jx-1.10.tar.gz) = ded02230a5422bf8b9c01809edbf5002a6e2bca1760bedc00022ca620d244dbb
+SIZE (jx-1.10.tar.gz) = 3379
diff --git a/sysutils/jx/pkg-descr b/sysutils/jx/pkg-descr
new file mode 100644
index 000000000000..70b99033b266
--- /dev/null
+++ b/sysutils/jx/pkg-descr
@@ -0,0 +1,12 @@
+This is a perl wrapper to "jexec" with more feature.
+
+Script takes system jail id, rc.conf order id, full hostname of jail or
+rc.conf name of jail. If no command for jail is given - run default
+('bash' or other).
+
+No additional software or tools like "jailer" are needed.
+
+WWW: http://legh.ru/jx/
+
+- Dmiry Shulgachik
+legh@legh.ru