aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-11 23:49:52 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-11 23:49:52 +0000
commit6eca8a5c712945cc6b79a3509a6606ef2ecc66a7 (patch)
treeb9f2d22173b049598129170acf48402c2763fa80 /sysutils
parentaaa83d38a7d12c5338740501a58b5ff7ac5d5866 (diff)
- Fix auth.conf confusion
- Use ETCDIR - Fix minor typo Reported by: QAT Submitted by: ohauer Approved by: Russell Jackson <raj@csub.edu> (maintainer)
Notes
Notes: svn path=/head/; revision=266079
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/puppet/Makefile12
-rw-r--r--sysutils/puppet/files/pkg-message.in2
-rw-r--r--sysutils/puppet/pkg-plist5
3 files changed, 10 insertions, 9 deletions
diff --git a/sysutils/puppet/Makefile b/sysutils/puppet/Makefile
index 4a15a24cd5fb..ea1924f11667 100644
--- a/sysutils/puppet/Makefile
+++ b/sysutils/puppet/Makefile
@@ -50,7 +50,8 @@ RUN_DEPENDS+= rubygem-mongrel>=0:${PORTSDIR}/www/rubygem-mongrel
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e "s|/etc/puppet|${PREFIX}/etc/puppet|" \
+ @${REINPLACE_CMD} -e "s|/etc/puppet|${ETCDIR}|" \
+ ${WRKSRC}/install.rb \
${WRKSRC}/lib/puppet/reference/configuration.rb \
${WRKSRC}/lib/puppet/defaults.rb \
${WRKSRC}/lib/puppet/util/run_mode.rb
@@ -66,16 +67,16 @@ pre-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
- @cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} ${RUBY} ${WRKSRC}/install.rb
+ @cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} ${RUBY} ${WRKSRC}/install.rb --no-configs
post-install:
- ${INSTALL} -d ${PREFIX}/etc/${PORTNAME}
+ ${INSTALL} -d ${ETCDIR}
${RUBY} -I ${RUBY_SITELIBDIR} ${PREFIX}/sbin/puppetmasterd \
- --confdir=${PREFIX}/etc/${PORTNAME} \
+ --confdir=${ETCDIR} \
--rundir=${PUPPET_RUNDIR} \
--genconfig | \
${SED} -e 's/genconfig = true/# genconfig = false/' \
- > ${PREFIX}/etc/${PORTNAME}/puppet.conf-dist
+ > ${ETCDIR}/puppet.conf-dist
@${ECHO} ${RUBY_SITELIBDIR}/puppet.rb | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${RUBY_SITELIBDIR}/${PORTNAME} -type f | \
@@ -89,6 +90,7 @@ post-install:
.endif
.if !defined(NOPORTEXAMPLES)
cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+ ${INSTALL} ${WRKSRC}/conf/auth.conf ${EXAMPLESDIR}/etc
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/sysutils/puppet/files/pkg-message.in b/sysutils/puppet/files/pkg-message.in
index d4ced0f176a0..1ba663e6a5fe 100644
--- a/sysutils/puppet/files/pkg-message.in
+++ b/sysutils/puppet/files/pkg-message.in
@@ -8,7 +8,7 @@ To enable the puppetmaster, add the following to /etc/rc.conf:
puppetmaster_enable="YES"
Individual config files such as %%PREFIX%%/etc/puppetmasterd.conf are
-deprecated. Use a single file, %%PREFIX%%/etc/puppet/puppet.conf.
+deprecated. Use a single file, %%ETCDIR%%/puppet.conf.
The default PID directory is %%PUPPET_RUNDIR%%.
diff --git a/sysutils/puppet/pkg-plist b/sysutils/puppet/pkg-plist
index e4c5cbe5ab93..2d2d95fca43b 100644
--- a/sysutils/puppet/pkg-plist
+++ b/sysutils/puppet/pkg-plist
@@ -9,6 +9,5 @@ sbin/puppetd
sbin/puppetmasterd
sbin/puppetqd
sbin/puppetrun
-etc/puppet/puppet.conf-dist
-etc/puppet/auth.conf
-@dirrmtry etc/puppet
+%%ETCDIR%%/puppet.conf-dist
+@dirrmtry %%ETCDIR%%