aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2012-07-01 11:13:46 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2012-07-01 11:13:46 +0000
commitfcd38a521024e5c512fcf7ec0678356cad581680 (patch)
tree7d40121d94002d6f58724a7475552f0a458ff237 /sysutils
parent2f31b4d3b9fdab458a76e8a01779df51ec56567a (diff)
downloadports-fcd38a521024e5c512fcf7ec0678356cad581680.tar.gz
ports-fcd38a521024e5c512fcf7ec0678356cad581680.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/webmin/Makefile3
-rw-r--r--sysutils/webmin/distinfo4
-rw-r--r--sysutils/webmin/files/patch-quota_freebsd-lib.pl45
3 files changed, 3 insertions, 49 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index e3b66b0858e8..9420e7747a99 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= webmin
-PORTVERSION= 1.580
-PORTREVISION= 2
+PORTVERSION= 1.590
CATEGORIES= sysutils
MASTER_SITES= http://download.webmin.com/updates/:up \
SF/webadmin/${PORTNAME}/${PORTVERSION}:sf \
diff --git a/sysutils/webmin/distinfo b/sysutils/webmin/distinfo
index 9d477640aa31..b217f8bea9aa 100644
--- a/sysutils/webmin/distinfo
+++ b/sysutils/webmin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (webmin-1.580.tar.gz) = 4f767c7e66defb4d1f102692a70752c558c8bf289e4e9980d82b1af86bd764e4
-SIZE (webmin-1.580.tar.gz) = 16081299
+SHA256 (webmin-1.590.tar.gz) = 07b06612a8bc864388d86b55ec9a9adba0fa71ec60cc66d87c0e58280264182d
+SIZE (webmin-1.590.tar.gz) = 18976739
diff --git a/sysutils/webmin/files/patch-quota_freebsd-lib.pl b/sysutils/webmin/files/patch-quota_freebsd-lib.pl
deleted file mode 100644
index 559923c19bcd..000000000000
--- a/sysutils/webmin/files/patch-quota_freebsd-lib.pl
+++ /dev/null
@@ -1,45 +0,0 @@
-
-$FreeBSD$
-
---- quota/freebsd-lib.pl.orig
-+++ quota/freebsd-lib.pl
-@@ -152,7 +152,9 @@
- if (/^(\S+)$/) {
- # Bogus wrapped line
- $filesys{$n,'filesys'} = $1;
-- <QUOTA>=~/^.{15}(.{8}).(.{7})(.{8}).{8}(.{8}).(.{7})(.{8})/;
-+ local $nl = <QUOTA>;
-+ $nl =~ /^\s+(\S+)\s+(\S+)\s+(\S+)(.{8}\s+)(\S+)\s+(\S+)\s+(\S+)(.*)/ ||
-+ $nl =~ /^.{15}(.{8}).(.{7})(.{8}).{8}(.{8}).(.{7})(.{8})/;
- $filesys{$n,'ublocks'} = int($1);
- $filesys{$n,'sblocks'} = int($2);
- $filesys{$n,'hblocks'} = int($3);
-@@ -161,7 +163,8 @@
- $filesys{$n,'hfiles'} = int($6);
- $n++;
- }
-- elsif (/^(.{15})(.{8}).(.{7})(.{8}).{8}(.{8}).(.{7})(.{8})/) {
-+ elsif (/^\s*(\S+)\s+(\S+)\s+(\S+)\s+(\S+)(.{8}\s+)(\S+)\s+(\S+)\s+(\S+)(.*)/ ||
-+ /^(.{15})(.{8}).(.{7})(.{8}).{8}(.{8}).(.{7})(.{8})/) {
- $filesys{$n,'ublocks'} = int($2);
- $filesys{$n,'sblocks'} = int($3);
- $filesys{$n,'hblocks'} = int($4);
-@@ -240,11 +243,17 @@
- @line = split(/\n/, $_[0]);
- for($i=0; $i<@line; $i++) {
- if ($line[$i] =~ /^(\S+): (blocks|kbytes) in use: (\d+), limits \(soft = (\d+), hard = (\d+)\)$/ && $1 eq $_[1]) {
-- # found lines to change
-+ # found lines to change, old style
- $rv .= "$1: $2 in use: $3, limits (soft = $_[2], hard = $_[3])\n";
- $line[++$i] =~ /^\s*inodes in use: (\d+), limits \(soft = (\d+), hard = (\d+)\)$/;
- $rv .= "\tinodes in use: $1, limits (soft = $_[4], hard = $_[5])\n";
- }
-+ elsif ($line[$i] =~ /^(\S+): in use: (\d+)k, limits \(soft = (\d+)k, hard = (\d+)k\)$/ && $1 eq $_[1]) {
-+ # found lines to change, new style
-+ $rv .= "$1: in use: ${2}k, limits (soft = $_[2]k, hard = $_[3]k)\n";
-+ $line[++$i] =~ /^\s*inodes in use: (\d+), limits \(soft = (\d+), hard = (\d+)\)$/;
-+ $rv .= "\tinodes in use: $1, limits (soft = $_[4], hard = $_[5])\n";
-+ }
- else { $rv .= "$line[$i]\n"; }
- }
- return $rv;