aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-29 20:57:51 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-29 20:57:51 +0000
commit706b4ad0746e7fa7bf7b7f18ee21994db83c37d3 (patch)
treebb2b9c2a76a7efbe7e4d0af7c4909f0823f04398 /sysutils
parent75fd45d40b66ac552b9dbd9208d3902059f1f32c (diff)
downloadports-706b4ad0746e7fa7bf7b7f18ee21994db83c37d3.tar.gz
ports-706b4ad0746e7fa7bf7b7f18ee21994db83c37d3.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/prips/Makefile8
-rw-r--r--sysutils/prips/files/patch-ab12
-rw-r--r--sysutils/prips/files/patch-main.c52
-rw-r--r--sysutils/prips/pkg-plist4
4 files changed, 56 insertions, 20 deletions
diff --git a/sysutils/prips/Makefile b/sysutils/prips/Makefile
index ebdb7416c245..0cfab00d459b 100644
--- a/sysutils/prips/Makefile
+++ b/sysutils/prips/Makefile
@@ -18,17 +18,13 @@ WRKSRC= ${WRKDIR}/prips
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/prips ${PREFIX}/bin
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/prips
- @${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/prips/README
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
.else
@${SED} 's#share/doc/prips/README##' ${TMPPLIST} > ${WRKDIR}/PLIST.tmp
@${SED} 's#@dirrm share/doc/prips##' ${WRKDIR}/PLIST.tmp > ${TMPPLIST}
diff --git a/sysutils/prips/files/patch-ab b/sysutils/prips/files/patch-ab
deleted file mode 100644
index fb0c0440a046..000000000000
--- a/sysutils/prips/files/patch-ab
+++ /dev/null
@@ -1,12 +0,0 @@
---- prips.c.orig Tue Jan 11 20:26:36 2000
-+++ prips.c Tue Jan 11 20:26:38 2000
-@@ -1,8 +1,8 @@
-+#include "prips.h"
- #include <stdio.h>
- #include <stdlib.h>
- #include <math.h>
- #include <arpa/inet.h>
--#include "prips.h"
-
- #if !defined(INET_ADDRSTRLEN)
- #define INET_ADDRSTRLEN 16
diff --git a/sysutils/prips/files/patch-main.c b/sysutils/prips/files/patch-main.c
new file mode 100644
index 000000000000..78d8f7db81a6
--- /dev/null
+++ b/sysutils/prips/files/patch-main.c
@@ -0,0 +1,52 @@
+--- main.c.orig Mon Oct 20 17:59:26 2003
++++ main.c Mon Oct 20 18:02:56 2003
+@@ -1,9 +1,9 @@
+ /* program that prints IP address ranges */
++#include "prips.h"
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
+-#include "prips.h"
+ #include "except.h"
+
+ typedef enum {
+@@ -16,11 +16,11 @@
+
+ const char *MAINTAINER = "dan@vertekcorp.com";
+ const char *VERSION =
+- "\rprips 0.9.4
+- \rThis program comes with NO WARRANTY,
+- \rto the extent permitted by law.
+- \rYou may redistribute copies under
+- \rthe terms of the GNU General Public License.\n";
++ "\rprips 0.9.4\n"\
++" \rThis program comes with NO WARRANTY,\n"\
++" \rto the extent permitted by law.\n"\
++" \rYou may redistribute copies under\n"\
++" \rthe terms of the GNU General Public License.\n";
+
+ void usage(char *prog);
+ AddrFormat get_format(char *format);
+@@ -166,14 +166,13 @@
+
+ void usage(char *prog)
+ {
+- fprintf(stderr, "usage: %s [options] <start end | CIDR block>
+- -c print range in CIDR notation
+- -d <x> set the delimeter 'x' where 0 =< x =< 255
+- -f <x> set the format of addresses (hex, dec, or dot)
+- -i <x> set the increment to 'x'
+- -e <x.x.x,x.x> e.g. -e ..4. will not print 192.168.4.[0-255]
+-
+- \rReport bugs to %s\n",
++ fprintf(stderr, "usage: %s [options] <start end | CIDR block>\n"\
++" -c print range in CIDR notation\n"\
++" -d <x> set the delimeter 'x' where 0 =< x =< 255\n"\
++" -f <x> set the format of addresses (hex, dec, or dot)\n"\
++" -i <x> set the increment to 'x'\n"\
++" -e <x.x.x,x.x> e.g. -e ..4. will not print 192.168.4.[0-255]\n\n"\
++" \rReport bugs to %s\n",
+ prog, MAINTAINER);
+ }
+
diff --git a/sysutils/prips/pkg-plist b/sysutils/prips/pkg-plist
index 1e04f9300dcc..a163340ed5dc 100644
--- a/sysutils/prips/pkg-plist
+++ b/sysutils/prips/pkg-plist
@@ -1,3 +1,3 @@
bin/prips
-share/doc/prips/README
-@dirrm share/doc/prips
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%