aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-04-29 01:49:03 +0000
committerSteve Wills <swills@FreeBSD.org>2013-04-29 01:49:03 +0000
commitdee088823dff61a677b44665d6fd6ef2dee35892 (patch)
tree9f1856709db267d6de013e0517149614a00f93de /sysutils
parenteb3016e9e8f1a03371a1e3180dbae1873492da56 (diff)
downloadports-dee088823dff61a677b44665d6fd6ef2dee35892.tar.gz
ports-dee088823dff61a677b44665d6fd6ef2dee35892.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/puppet/Makefile14
-rw-r--r--sysutils/puppet/files/patch-service-freebsd.rb11
2 files changed, 19 insertions, 6 deletions
diff --git a/sysutils/puppet/Makefile b/sysutils/puppet/Makefile
index 65f366373e9e..2d3b2aeded1b 100644
--- a/sysutils/puppet/Makefile
+++ b/sysutils/puppet/Makefile
@@ -3,7 +3,7 @@
PORTNAME= puppet
PORTVERSION= 3.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://downloads.puppetlabs.com/puppet/
@@ -53,11 +53,6 @@ PACKAGE_ROOT_DESC= Use PACKAGEROOT insted of PACKAGESITE
RUN_DEPENDS+= rubygem-mongrel>=0:${PORTSDIR}/www/rubygem-mongrel
.endif
-.if ${PORT_OPTIONS:MPACKAGE_ORIGIN}
-EXTRA_PATCHES+= ${FILESDIR}/optpatch-package_origin
-RUN_DEPENDS+= rubygem-bzip2>=0:${PORTSDIR}/archivers/rubygem-bzip2
-.endif
-
.if ${PORT_OPTIONS:MPACKAGE_ROOT}
.if ! ${PORT_OPTIONS:MPACKAGE_ORIGIN}
EXTRA_PATCHES+= ${FILESDIR}/optpatch-package_root
@@ -68,6 +63,13 @@ BROKEN= PACKAGE_ROOT option patch is incompatable with PACKAGE_ORIGIN patch.
.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MPACKAGE_ORIGIN}
+EXTRA_PATCHES+= ${FILESDIR}/optpatch-package_origin
+.if ${RUBY_VER} == 1.8 || ${RUBY_VER} == 1.9
+RUN_DEPENDS+= rubygem-bzip2>=0:${PORTSDIR}/archivers/rubygem-bzip2
+.endif
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|/etc/puppet|${ETCDIR}|" \
${WRKSRC}/install.rb \
diff --git a/sysutils/puppet/files/patch-service-freebsd.rb b/sysutils/puppet/files/patch-service-freebsd.rb
new file mode 100644
index 000000000000..b0d6d867c86f
--- /dev/null
+++ b/sysutils/puppet/files/patch-service-freebsd.rb
@@ -0,0 +1,11 @@
+--- lib/puppet/provider/service/freebsd.rb.orig 2013-04-28 02:55:36.017584743 +0000
++++ lib/puppet/provider/service/freebsd.rb 2013-04-28 02:55:52.581583782 +0000
+@@ -41,7 +41,7 @@
+ def rcvar_name
+ name = self.rcvar[1]
+ self.error("No rcvar name found in rcvar") if name.nil?
+- name = name.gsub!(/(.*)(_enable)?=(.*)/, '\1')
++ name = name.gsub!(/(.*?)(_enable)?=(.*)/, '\1')
+ self.error("rcvar name is empty") if name.nil?
+ self.debug("rcvar name is #{name}")
+ name