aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2016-05-19 17:28:02 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2016-05-19 17:28:02 +0000
commite83920c238889552d1bdb2d5c3d158c2620fd2ee (patch)
treefbdd7f839dda68a8a5f53cadc241758a727ed5d5 /sysutils
parente430a29bd0b1ef345efd433987f459bc3d57eecb (diff)
downloadports-e83920c238889552d1bdb2d5c3d158c2620fd2ee.tar.gz
ports-e83920c238889552d1bdb2d5c3d158c2620fd2ee.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/DTraceToolkit/Makefile10
-rw-r--r--sysutils/DTraceToolkit/distinfo5
-rw-r--r--sysutils/DTraceToolkit/files/patch-Apps-shellsnoop35
-rw-r--r--sysutils/DTraceToolkit/files/patch-opensnoop29
-rw-r--r--sysutils/DTraceToolkit/pkg-descr4
-rw-r--r--sysutils/DTraceToolkit/pkg-plist5
6 files changed, 13 insertions, 75 deletions
diff --git a/sysutils/DTraceToolkit/Makefile b/sysutils/DTraceToolkit/Makefile
index ec1193f5487a..7b4295a499bf 100644
--- a/sysutils/DTraceToolkit/Makefile
+++ b/sysutils/DTraceToolkit/Makefile
@@ -1,11 +1,13 @@
# Created by: Steven Kreuzer <steven@exit2shell.com>
# $FreeBSD$
-PORTNAME= DTraceToolkit
-PORTVERSION= 0.99
-PORTREVISION= 2
+PORTNAME= dtrace-toolkit
+PORTVERSION= 1.0
CATEGORIES= sysutils
-MASTER_SITES= http://www.brendangregg.com/DTraceToolkit/
+USE_GITHUB= yes
+GH_ACCOUNT= opendtrace
+GH_PROJECT= toolkit
+GH_TAGNAME= f36d00b
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Collection of useful scripts for DTrace
diff --git a/sysutils/DTraceToolkit/distinfo b/sysutils/DTraceToolkit/distinfo
index c62a794170c1..9d0b7a535179 100644
--- a/sysutils/DTraceToolkit/distinfo
+++ b/sysutils/DTraceToolkit/distinfo
@@ -1,2 +1,3 @@
-SHA256 (DTraceToolkit-0.99.tar.gz) = f4f5df564b79103088731813cbc5c1bab0cb4dec98d2700b8583af190c695266
-SIZE (DTraceToolkit-0.99.tar.gz) = 474697
+TIMESTAMP = 1463628205
+SHA256 (opendtrace-toolkit-1.0-f36d00b_GH0.tar.gz) = 28d2ab2c846792286e30eac8e052313d2f1b1335242be85cfa4b6f52b18165c8
+SIZE (opendtrace-toolkit-1.0-f36d00b_GH0.tar.gz) = 438889
diff --git a/sysutils/DTraceToolkit/files/patch-Apps-shellsnoop b/sysutils/DTraceToolkit/files/patch-Apps-shellsnoop
deleted file mode 100644
index 0e586e285f10..000000000000
--- a/sysutils/DTraceToolkit/files/patch-Apps-shellsnoop
+++ /dev/null
@@ -1,35 +0,0 @@
---- Apps/shellsnoop.orig 2014-06-04 09:00:10.000000000 -0400
-+++ Apps/shellsnoop 2014-06-04 09:01:29.000000000 -0400
-@@ -140,7 +140,7 @@
- /*
- * Remember this PID is a shell child
- */
-- syscall::exec:entry, syscall::exece:entry
-+ syscall::exec:entry
- /execname == "sh" || execname == "ksh" || execname == "csh" ||
- execname == "tcsh" || execname == "zsh" || execname == "bash"/
- {
-@@ -151,7 +151,7 @@
- OPT_debug == 1 ? printf("PID %d CMD %s started. (%s)\n",
- pid, execname, stringof(this->parent)) : 1;
- }
-- syscall::exec:entry, syscall::exece:entry
-+ syscall::exec:entry
- /(OPT_pid == 1 && PID != ppid) || (OPT_uid == 1 && UID != uid)/
- {
- /* forget if filtered */
-@@ -256,12 +256,12 @@
- /*
- * Cleanup
- */
-- syscall::rexit:entry
-+ syscall::exit:entry
- {
- child[pid] = 0;
-
- /* debug */
-- this->parent = (char *)curthread->t_procp->p_parent->p_user.u_comm;
-+ this->parent = (char *)curthread->td_proc->p_pptr->p_comm;
- OPT_debug == 1 ? printf("PID %d CMD %s exited. (%s)\n",
- pid, execname, stringof(this->parent)) : 1;
- }
diff --git a/sysutils/DTraceToolkit/files/patch-opensnoop b/sysutils/DTraceToolkit/files/patch-opensnoop
deleted file mode 100644
index 9e09a7f45b45..000000000000
--- a/sysutils/DTraceToolkit/files/patch-opensnoop
+++ /dev/null
@@ -1,29 +0,0 @@
---- opensnoop.orig 2014-06-04 08:58:11.000000000 -0400
-+++ opensnoop 2014-06-04 08:58:42.000000000 -0400
-@@ -189,7 +189,7 @@
- /*
- * Print open event
- */
-- syscall::open:entry, syscall::open64:entry
-+ syscall::open:entry
- {
- /* save pathname */
- self->pathp = arg0;
-@@ -203,7 +203,7 @@
- /* OPT_file is checked on return to ensure pathp is mapped */
- }
-
-- syscall::open:return, syscall::open64:return
-+ syscall::open:return
- /self->ok && (! OPT_failonly || (int)arg0 < 0) &&
- ((OPT_file == 0) || (OPT_file == 1 && PATHNAME == copyinstr(self->pathp)))/
- {
-@@ -235,7 +235,7 @@
- /*
- * Cleanup
- */
-- syscall::open:return, syscall::open64:return
-+ syscall::open:return
- /self->ok/
- {
- self->pathp = 0;
diff --git a/sysutils/DTraceToolkit/pkg-descr b/sysutils/DTraceToolkit/pkg-descr
index a3dd3676086f..7ee821192133 100644
--- a/sysutils/DTraceToolkit/pkg-descr
+++ b/sysutils/DTraceToolkit/pkg-descr
@@ -1,4 +1,4 @@
The DTraceToolkit is a collection of useful documented scripts developed
-by the OpenSolaris DTrace community.
+by the DTrace community and maintained as part of Open DTrace.
-WWW: http://www.brendangregg.com/dtracetoolkit.html
+WWW: https://github.com/opendtrace/toolkit
diff --git a/sysutils/DTraceToolkit/pkg-plist b/sysutils/DTraceToolkit/pkg-plist
index 8c11e8e1b12d..4e2d3c4f5fda 100644
--- a/sysutils/DTraceToolkit/pkg-plist
+++ b/sysutils/DTraceToolkit/pkg-plist
@@ -579,7 +579,6 @@ bin/shellsnoop
%%DATADIR%%/Kernel/pridist.d
%%DATADIR%%/Kernel/putnexts.d
%%DATADIR%%/Kernel/whatexec.d
-%%DATADIR%%/License
%%DATADIR%%/Locks/lockbydist.d
%%DATADIR%%/Locks/lockbyproc.d
%%DATADIR%%/Man/Readme
@@ -930,7 +929,6 @@ bin/shellsnoop
%%DATADIR%%/Python/py_syscalls.d
%%DATADIR%%/Python/py_syscolors.d
%%DATADIR%%/Python/py_who.d
-%%DATADIR%%/README
%%DATADIR%%/Ruby/Readme
%%DATADIR%%/Ruby/rb_calldist.d
%%DATADIR%%/Ruby/rb_calls.d
@@ -1009,4 +1007,5 @@ bin/shellsnoop
%%DATADIR%%/rwsnoop
%%DATADIR%%/rwtop
%%DATADIR%%/statsnoop
-@dir %%DATADIR%%/Code/C
+%%DATADIR%%/CDDL
+%%DATADIR%%/README.md