aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-24 16:06:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-24 16:06:49 +0000
commitfa4586bc3a5ff5f8ec9b15771220caf67ca890c9 (patch)
tree21162a96bce8ea662fdf4b9980eb433fad7de912 /sysutils
parent0a29dc665dd98ec0c9d6d67c4489029c1e3d1889 (diff)
downloadports-fa4586bc3a5ff5f8ec9b15771220caf67ca890c9.tar.gz
ports-fa4586bc3a5ff5f8ec9b15771220caf67ca890c9.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/sysgather/Makefile23
-rw-r--r--sysutils/sysgather/distinfo4
-rw-r--r--sysutils/sysgather/pkg-plist8
3 files changed, 22 insertions, 13 deletions
diff --git a/sysutils/sysgather/Makefile b/sysutils/sysgather/Makefile
index 833e961e2c27..4a5012d31049 100644
--- a/sysutils/sysgather/Makefile
+++ b/sysutils/sysgather/Makefile
@@ -1,24 +1,33 @@
-# New ports collection makefile for: sysgather
-# Date created: 16 December 2005
-# Whom: roam@FreeBSD.org
-#
+# Created by: roam@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= sysgather
-PORTVERSION= 1.0.b9
+DISTVERSION= 1.0pre10
CATEGORIES= sysutils
MASTER_SITES= http://devel.ringlet.net/sysutils/sysgather/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/pre/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Keep configuration files under version control
+LICENSE= BSD
+
BUILD_DEPENDS= p5-Config-IniFiles>=0:${PORTSDIR}/devel/p5-Config-IniFiles
RUN_DEPENDS:= ${BUILD_DEPENDS}
+OPTIONS_DEFINE= EXAMPLES
+
USE_PERL5= yes
MAN1= sysgather.1
+.include <bsd.port.options.mk>
+
+.if empty(PORT_OPTIONS:MEXAMPLES)
+MAKE_ENV+= EXAMPLESDIR="${WRKDIR}"
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^#!.*/perl|#!${PERL}|' ${WRKSRC}/sysgather.pl
+
.include <bsd.port.mk>
diff --git a/sysutils/sysgather/distinfo b/sysutils/sysgather/distinfo
index 77af5d4e6192..3412f0c0c9ce 100644
--- a/sysutils/sysgather/distinfo
+++ b/sysutils/sysgather/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sysgather-1.0pre9.tar.gz) = 347151eeddc59e0d49ba55d58b910f5259063f342c0c715530f047a230df2009
-SIZE (sysgather-1.0pre9.tar.gz) = 15020
+SHA256 (sysgather-1.0pre10.tar.gz) = d767e78ae6612d0adeee837d4489112b155b664dd3f5bb94e77a967fcc067997
+SIZE (sysgather-1.0pre10.tar.gz) = 16084
diff --git a/sysutils/sysgather/pkg-plist b/sysutils/sysgather/pkg-plist
index 07dee12c9bab..c51c6bd4af44 100644
--- a/sysutils/sysgather/pkg-plist
+++ b/sysutils/sysgather/pkg-plist
@@ -2,7 +2,7 @@ bin/sysgather
@unexec if cmp -s %D/etc/sysgather.conf %D/etc/sysgather.conf.default; then rm -f %D/etc/sysgather.conf; fi
etc/sysgather.conf.default
@exec [ -f %B/sysgather.conf ] || cp %B/%f %B/sysgather.conf
-%%EXAMPLESDIR%%/debian.conf
-%%EXAMPLESDIR%%/freebsd.conf
-%%EXAMPLESDIR%%/slackware.conf
-@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/debian.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/freebsd.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/slackware.conf
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%