aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-09-14 06:14:42 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-09-14 06:14:42 +0000
commit2ce2c36df0547ad18478338db0d286f2a5c5c120 (patch)
tree4214e31619f64d4c421345c75b6d7cf1d82f039a /sysutils
parent4cbf9214764acdbcd946f945eb10a98173385110 (diff)
downloadports-2ce2c36df0547ad18478338db0d286f2a5c5c120.tar.gz
ports-2ce2c36df0547ad18478338db0d286f2a5c5c120.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/javaservicewrapper/Makefile37
-rw-r--r--sysutils/javaservicewrapper/distinfo3
-rw-r--r--sysutils/javaservicewrapper/pkg-descr12
-rw-r--r--sysutils/javaservicewrapper/pkg-plist191
5 files changed, 244 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index b6012deaf92e..a333c2c5fefe 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -316,6 +316,7 @@
SUBDIR += jailme
SUBDIR += jailuser
SUBDIR += jailutils
+ SUBDIR += javaservicewrapper
SUBDIR += jdiskreport
SUBDIR += jkill
SUBDIR += jps
diff --git a/sysutils/javaservicewrapper/Makefile b/sysutils/javaservicewrapper/Makefile
new file mode 100644
index 000000000000..0d4cea2eee5e
--- /dev/null
+++ b/sysutils/javaservicewrapper/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: javaservicewrapper
+# Date created: 2007-09-13
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= javaservicewrapper
+PORTVERSION= 3.2.3
+CATEGORIES= sysutils java
+MASTER_SITES= SF/wrapper
+DISTNAME= wrapper_${PORTVERSION}_src
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Application to solve problems common to many Java applications
+
+USE_JAVA= 1.3+
+
+DATADIR= ${PREFIX}/lib/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc|${CC} ${CFLAGS}|' \
+ ${WRKSRC}/src/c/Makefile-freebsd-x86-32
+
+do-build:
+ @cd ${WRKSRC} && ${SH} build32.sh
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${CP} -rp bin conf lib test ${DATADIR}
+ ${LN} -sf ${DATADIR}/bin/wrapper ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} -r ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/javaservicewrapper/distinfo b/sysutils/javaservicewrapper/distinfo
new file mode 100644
index 000000000000..e976c8523071
--- /dev/null
+++ b/sysutils/javaservicewrapper/distinfo
@@ -0,0 +1,3 @@
+MD5 (wrapper_3.2.3_src.tar.gz) = 1b5eb59f223a58d3b385d555e9cf33fa
+SHA256 (wrapper_3.2.3_src.tar.gz) = 7e57b0103959fe3566def64b1dd3fef6537032a7e4b2a7811594f1db7d9f5859
+SIZE (wrapper_3.2.3_src.tar.gz) = 3409483
diff --git a/sysutils/javaservicewrapper/pkg-descr b/sysutils/javaservicewrapper/pkg-descr
new file mode 100644
index 000000000000..22942acd1a6d
--- /dev/null
+++ b/sysutils/javaservicewrapper/pkg-descr
@@ -0,0 +1,12 @@
+The Java Service Wrapper is an application which has evolved out of a desire
+to solve a number of problems common to many Java applications:
+
+- Run as a Windows Service or Unix Daemon.
+- Application Reliability.
+- Standard, Out of the Box Scripting.
+- On Demand Restarts.
+- Flexible Configuration.
+- Ease Application Installations.
+- Logging.
+
+WWW: http://wrapper.tanukisoftware.org/
diff --git a/sysutils/javaservicewrapper/pkg-plist b/sysutils/javaservicewrapper/pkg-plist
new file mode 100644
index 000000000000..89efb325a559
--- /dev/null
+++ b/sysutils/javaservicewrapper/pkg-plist
@@ -0,0 +1,191 @@
+bin/javaservicewrapper
+%%DATADIR%%/bin/testwrapper
+%%DATADIR%%/bin/wrapper
+%%DATADIR%%/conf/wrapper.conf
+%%DATADIR%%/lib/libwrapper.so
+%%DATADIR%%/lib/wrapper.jar
+%%DATADIR%%/lib/wrappertest.jar
+%%DATADIR%%/test/action
+%%DATADIR%%/test/action.conf
+%%DATADIR%%/test/backgroundthreads
+%%DATADIR%%/test/backgroundthreads.conf
+%%DATADIR%%/test/daemonthreads
+%%DATADIR%%/test/daemonthreads.conf
+%%DATADIR%%/test/envvars
+%%DATADIR%%/test/envvars.conf
+%%DATADIR%%/test/filter
+%%DATADIR%%/test/filter.conf
+%%DATADIR%%/test/loadedwrapperlistener
+%%DATADIR%%/test/loadedwrapperlistener.conf
+%%DATADIR%%/test/logoutput
+%%DATADIR%%/test/logoutput.conf
+%%DATADIR%%/test/longrunningbackgroundthreads
+%%DATADIR%%/test/longrunningbackgroundthreads.conf
+%%DATADIR%%/test/memory
+%%DATADIR%%/test/memory.conf
+%%DATADIR%%/test/noreturn
+%%DATADIR%%/test/noreturn.conf
+%%DATADIR%%/test/onexit
+%%DATADIR%%/test/onexit.conf
+%%DATADIR%%/test/outputloader
+%%DATADIR%%/test/outputloader.conf
+%%DATADIR%%/test/percentoutput
+%%DATADIR%%/test/percentoutput.conf
+%%DATADIR%%/test/quickcomplete
+%%DATADIR%%/test/quickcomplete.conf
+%%DATADIR%%/test/restarter
+%%DATADIR%%/test/restarter.conf
+%%DATADIR%%/test/shutdownhook
+%%DATADIR%%/test/shutdownhook.conf
+%%DATADIR%%/test/systemproperty
+%%DATADIR%%/test/systemproperty.conf
+%%DATADIR%%/test/template.conf
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/english/authors.html
+%%PORTDOCS%%%%DOCSDIR%%/english/buttons.html
+%%PORTDOCS%%%%DOCSDIR%%/english/debugging.html
+%%PORTDOCS%%%%DOCSDIR%%/english/donate-thanks.html
+%%PORTDOCS%%%%DOCSDIR%%/english/donate.html
+%%PORTDOCS%%%%DOCSDIR%%/english/example.html
+%%PORTDOCS%%%%DOCSDIR%%/english/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/english/favicon.ico
+%%PORTDOCS%%%%DOCSDIR%%/english/history.html
+%%PORTDOCS%%%%DOCSDIR%%/english/images/BorderBottom.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/BorderLeft.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/BorderRight.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/BorderTop.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/DonationRequest.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/OfflineAd728x90.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/TestWrapper.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/UnderWrapper147x50.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/UnderWrapper85x30.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/UnderWrapperDuke144x50.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/UnderWrapperDuke85x30.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/WrapperLogo.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/WrapperTitle.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/nw_min.gif
+%%PORTDOCS%%%%DOCSDIR%%/english/images/spacer.gif
+%%PORTDOCS%%%%DOCSDIR%%/english/images/spacer.png
+%%PORTDOCS%%%%DOCSDIR%%/english/images/strich.gif
+%%PORTDOCS%%%%DOCSDIR%%/english/index.html
+%%PORTDOCS%%%%DOCSDIR%%/english/integrate-listener.html
+%%PORTDOCS%%%%DOCSDIR%%/english/integrate-simple-nix.html
+%%PORTDOCS%%%%DOCSDIR%%/english/integrate-simple-win.html
+%%PORTDOCS%%%%DOCSDIR%%/english/integrate-start-stop-nix.html
+%%PORTDOCS%%%%DOCSDIR%%/english/integrate-start-stop-win.html
+%%PORTDOCS%%%%DOCSDIR%%/english/integrate.html
+%%PORTDOCS%%%%DOCSDIR%%/english/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/english/javadocs.html
+%%PORTDOCS%%%%DOCSDIR%%/english/jmx.html
+%%PORTDOCS%%%%DOCSDIR%%/english/launch-nix-boot-debian.html
+%%PORTDOCS%%%%DOCSDIR%%/english/launch-nix-boot-solaris.html
+%%PORTDOCS%%%%DOCSDIR%%/english/launch-nix.html
+%%PORTDOCS%%%%DOCSDIR%%/english/launch-win.html
+%%PORTDOCS%%%%DOCSDIR%%/english/launch.html
+%%PORTDOCS%%%%DOCSDIR%%/english/license-silveregg.html
+%%PORTDOCS%%%%DOCSDIR%%/english/license.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-adviser.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-anchorfile.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-app-parameter-n.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-commandfile.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-console-flush.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-console-format.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-console-loglevel.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-console-title.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-cpu-timeout.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-daemonize.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-debug.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-disable-restarts.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-disable-shutdown-hook.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-filter-x-n.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ignore-signals.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-java-additional-n.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-java-classpath-n.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-java-command-loglevel.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-java-command.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-java-idfile.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-java-initmemory.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-java-library-path-append-system-path.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-java-library-path-n.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-java-mainclass.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-java-maxmemory.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-java-pidfile.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-java-statusfile.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-jvm-exit-timeout.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-jvm-port.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-lockfile.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-logfile-format.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-logfile-inactivity-timeout.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-logfile-loglevel.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-logfile-maxfiles.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-logfile-maxsize.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-logfile-rollmode.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-logfile.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-max-failed-invocations.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-monitor-thread-count.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-native-library.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-account.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-console.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-dependency-n.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-description.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-displayname.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-hide-console.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-interactive.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-load-order-group.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-name.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-password.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-pausable-stop-jvm.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-pausable.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-process-priority.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ntservice-starttype.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-on-exit-n.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-pidfile.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ping-interval.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-ping-timeout.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-port.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-request-thread-dump-on-failed-jvm-exit.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-restart-delay.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-restart-reload-configuration.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-shutdown-timeout.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-signal-mode-hup.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-single-invocation.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-startup-delay.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-startup-timeout.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-statusfile.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-successful-invocation-time.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-syslog-facility.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-syslog-ident.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-syslog-loglevel.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-thread-count-delay.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-umask.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-use-system-time.html
+%%PORTDOCS%%%%DOCSDIR%%/english/prop-working-dir.html
+%%PORTDOCS%%%%DOCSDIR%%/english/properties.html
+%%PORTDOCS%%%%DOCSDIR%%/english/props-advanced.html
+%%PORTDOCS%%%%DOCSDIR%%/english/props-cascading.html
+%%PORTDOCS%%%%DOCSDIR%%/english/props-command-line.html
+%%PORTDOCS%%%%DOCSDIR%%/english/props-envvars.html
+%%PORTDOCS%%%%DOCSDIR%%/english/props-example-config.html
+%%PORTDOCS%%%%DOCSDIR%%/english/props-jvm.html
+%%PORTDOCS%%%%DOCSDIR%%/english/props-logging.html
+%%PORTDOCS%%%%DOCSDIR%%/english/props-nt.html
+%%PORTDOCS%%%%DOCSDIR%%/english/props-paths.html
+%%PORTDOCS%%%%DOCSDIR%%/english/props-unix.html
+%%PORTDOCS%%%%DOCSDIR%%/english/release-notes.html
+%%PORTDOCS%%%%DOCSDIR%%/english/security-model.html
+%%PORTDOCS%%%%DOCSDIR%%/english/sponsors.html
+%%PORTDOCS%%%%DOCSDIR%%/english/style/wrapper.css
+%%PORTDOCS%%%%DOCSDIR%%/english/template.html
+%%PORTDOCS%%%%DOCSDIR%%/english/troubleshooting.html
+%%PORTDOCS%%%%DOCSDIR%%/license.txt
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%PORTDOCS%%%%DOCSDIR%%/revisions.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/english/style
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/english/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/english
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/test
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/conf
+@dirrm %%DATADIR%%/bin
+@dirrm %%DATADIR%%