aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-11-04 19:26:03 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-11-04 19:26:03 +0000
commit01d2e722252f8476e096c0480fcae078f21a2367 (patch)
treec7becf4caa49d31e7342d55288fe869e70453287 /sysutils
parent22c27d294688613abfd27c00a062fc142d8a10ea (diff)
downloadports-01d2e722252f8476e096c0480fcae078f21a2367.tar.gz
ports-01d2e722252f8476e096c0480fcae078f21a2367.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/xjobs/Makefile28
-rw-r--r--sysutils/xjobs/distinfo2
-rw-r--r--sysutils/xjobs/files/patch-Makefile.in14
-rw-r--r--sysutils/xjobs/pkg-descr16
5 files changed, 61 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 2af34fd1685a..f6af050437a3 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -972,6 +972,7 @@
SUBDIR += xfsm
SUBDIR += xfsprogs
SUBDIR += xin
+ SUBDIR += xjobs
SUBDIR += xloadface
SUBDIR += xlogmaster
SUBDIR += xmbmon
diff --git a/sysutils/xjobs/Makefile b/sysutils/xjobs/Makefile
new file mode 100644
index 000000000000..6d2ae0473eea
--- /dev/null
+++ b/sysutils/xjobs/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: xjobs
+# Date created: 28 October 2011
+# Whom: Jason Helfman <jhelfman@experts-exchange.com>
+#
+# $FreeBSD$
+#
+#
+
+PORTNAME= xjobs
+PORTVERSION= 20110730
+CATEGORIES= sysutils
+MASTER_SITES= http://www.maier-komor.de/xjobs/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jhelfman@experts-exchange.com
+COMMENT= Utility reads job descriptions line by line and executes in parallel
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/xjobs
+MAN1= xjobs.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/xjobs/distinfo b/sysutils/xjobs/distinfo
new file mode 100644
index 000000000000..7a664dd0f9f5
--- /dev/null
+++ b/sysutils/xjobs/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xjobs-20110730.tgz) = 11461a4e7efe6b911d97f4541b353018818b1ce477a0b582ac8a8059e2746d23
+SIZE (xjobs-20110730.tgz) = 95147
diff --git a/sysutils/xjobs/files/patch-Makefile.in b/sysutils/xjobs/files/patch-Makefile.in
new file mode 100644
index 000000000000..1ca71fd6035e
--- /dev/null
+++ b/sysutils/xjobs/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+--- ./Makefile.in.orig 2011-10-28 09:57:51.000000000 -0700
++++ ./Makefile.in 2011-10-28 09:57:58.000000000 -0700
+@@ -40,11 +40,5 @@
+ -$(RM) $(TARGET) config.h config.log \
+ config.status Makefile core
+
+-install: $(TARGET)
+- -$(INSTALL) -d $(DESTDIR)$(bindir)
+- $(INSTALL) $(TARGET) $(DESTDIR)$(bindir)
+- -$(INSTALL) -d $(DESTDIR)$(mandir)
+- $(INSTALL) xjobs.1 $(DESTDIR)$(mandir)
+-
+ lint:
+ lint $(CFLAGS) $(SOURCES)
diff --git a/sysutils/xjobs/pkg-descr b/sysutils/xjobs/pkg-descr
new file mode 100644
index 000000000000..23a96d56df12
--- /dev/null
+++ b/sysutils/xjobs/pkg-descr
@@ -0,0 +1,16 @@
+xjobs reads job descriptions line by line and executes them in parallel. It
+limits the number of parallel executing jobs and starts new jobs when jobs
+finish. Therefore, it combines the arguments from every input line with the
+utility and arguments given on the command line. If no utility is given as an
+argument to xjobs, then the first argument on every job line will be used as
+utility. To execute utility xjobs searches the directories given in the PATH
+environment variable and uses the first file found in these directories.
+
+xjobs is most useful on multi-processor/core machines when one needs to execute
+several time consuming command several that could possibly be run in parallel.
+With xjobs this can be achieved easily, and it is possible to limit the load of
+the machine to a useful value. It works similar to xargs, but starts several
+processes simultaneously and gives only one line of arguments to each utility
+call.
+
+WWW: http://www.maier-komor.de/xjobs.html