aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1997-04-24 08:04:53 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1997-04-24 08:04:53 +0000
commit07df187a7a5b4201801dc4ce4e86f775918fb389 (patch)
tree6482c16e8acc4739d20b4c253422ae377ae287c9 /sysutils
parent69ac7b4b06e3e9d7105029824b2ebf9c72158d41 (diff)
downloadports-07df187a7a5b4201801dc4ce4e86f775918fb389.tar.gz
ports-07df187a7a5b4201801dc4ce4e86f775918fb389.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/tcplist/Makefile26
-rw-r--r--sysutils/tcplist/distinfo1
-rw-r--r--sysutils/tcplist/files/patch-0149
-rw-r--r--sysutils/tcplist/files/patch-0228
-rw-r--r--sysutils/tcplist/pkg-comment1
-rw-r--r--sysutils/tcplist/pkg-descr7
-rw-r--r--sysutils/tcplist/pkg-plist2
7 files changed, 114 insertions, 0 deletions
diff --git a/sysutils/tcplist/Makefile b/sysutils/tcplist/Makefile
new file mode 100644
index 000000000000..ec346174c66f
--- /dev/null
+++ b/sysutils/tcplist/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: tcplist
+# Version required: 2.1
+# Date created: Mon Apr 14, 1997
+# Whom: David O'Brien (obrien@FreeBSD.org)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+DISTNAME= tcplist-2.1
+CATEGORIES= sysutils net
+MASTER_SITES= ftp://ftp.cdf.toronto.edu/pub/tcplist/
+EXTRACT_SUFX= .shar.gz
+
+MAINTAINER= obrien@NUXI.com
+
+RUN_DEPENDS= lsof:${PORTSDIR}/sysutils/lsof
+
+EXTRACT_CMD= zcat
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= |sh
+NO_WRKSUBDIR= yes
+INSTALL_TARGET= install install.man
+MAN1= tcplist.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/tcplist/distinfo b/sysutils/tcplist/distinfo
new file mode 100644
index 000000000000..578daea7f285
--- /dev/null
+++ b/sysutils/tcplist/distinfo
@@ -0,0 +1 @@
+MD5 (tcplist-2.1.shar.gz) = 1563b70141821d06bc17e5e3c2856b87
diff --git a/sysutils/tcplist/files/patch-01 b/sysutils/tcplist/files/patch-01
new file mode 100644
index 000000000000..1bc169c506e6
--- /dev/null
+++ b/sysutils/tcplist/files/patch-01
@@ -0,0 +1,49 @@
+--- Makefile.orig Mon Apr 14 18:06:02 1997
++++ Makefile Mon Apr 14 18:08:48 1997
+@@ -1,14 +1,16 @@
+ # Compiler: eg. cc or gcc
+ CC = cc
+
++#PREFIX= /local
++
+ # Directory to install tcplist executable
+-BINDIR = /local/bin
++BINDIR = $(PREFIX)/bin
+
+ # Directory to install tcplist man page
+-MANDIR = /local/man/man1
++MANDIR = $(PREFIX)/man/man1
+
+ # Location of NOIDENT file
+-NOIDENT = /etc/hosts.noident
++NOIDENT = $(PREFIX)/etc/hosts.noident
+
+ # Owner of tcplist executable
+ OWNER = root
+@@ -45,18 +47,18 @@
+ #
+ # Solaris 2.x (using LSOF):
+ #
+-LIBRARIES = -lsocket -lnsl
+-DEFS = -DLSOF
+-MODE = 755
+-GROUP = staff
++#LIBRARIES = -lsocket -lnsl
++#DEFS = -DLSOF
++#MODE = 755
++#GROUP = staff
+
+ #
+ # Generic LSOF:
+ #
+-# LIBRARIES =
+-# DEFS = -DLSOF
+-# MODE = 755
+-# GROUP = staff
++ LIBRARIES =
++ DEFS = -DLSOF
++ MODE = 755
++ GROUP = staff
+ #
+
+ # If you're using an old version of lsof, uncomment this:
diff --git a/sysutils/tcplist/files/patch-02 b/sysutils/tcplist/files/patch-02
new file mode 100644
index 000000000000..e5daecc457ce
--- /dev/null
+++ b/sysutils/tcplist/files/patch-02
@@ -0,0 +1,28 @@
+--- tcplist.c.orig Tue Apr 15 00:28:29 1997
++++ tcplist.c Tue Apr 15 00:31:40 1997
+@@ -37,6 +37,10 @@
+ #include <arpa/inet.h>
+ #include <netdb.h>
+
++#if ((defined(__unix__) || defined(unix)) && !defined(USG))
++#include <sys/param.h>
++#endif
++
+ #include "utils.h"
+ #include "tcplist.h"
+
+@@ -346,10 +350,14 @@
+
+ if(verbose) printf("Connecting to remote hosts.\n");
+
++#if (defined(BSD) && (BSD >= 199103))
++ maxfd=getdtablesize(); /* could also use getrlimit(2) here... */
++#else
+ if(0>(maxfd=ulimit(4,0l))){
+ perror("ulimit");
+ exit(2);
+ }
++#endif
+
+ /* waltz through the connections in the hostlist, setting idents */
+ /* to NULL */
diff --git a/sysutils/tcplist/pkg-comment b/sysutils/tcplist/pkg-comment
new file mode 100644
index 000000000000..47fe73e261d9
--- /dev/null
+++ b/sysutils/tcplist/pkg-comment
@@ -0,0 +1 @@
+lists tcp connections to/from the local machine (+username on both sides)
diff --git a/sysutils/tcplist/pkg-descr b/sysutils/tcplist/pkg-descr
new file mode 100644
index 000000000000..a15630a1840b
--- /dev/null
+++ b/sysutils/tcplist/pkg-descr
@@ -0,0 +1,7 @@
+Tcplist makes a list of tcp connections to and from the local machine,
+displaying the user name associated with the local end, and making use of
+Ident services if available to determine the "user" at the other end.
+
+Tcplist uses LSOF to do its low level work on 4.4BSD machines.
+
+-- David (obrien@FreeBSD.org)
diff --git a/sysutils/tcplist/pkg-plist b/sysutils/tcplist/pkg-plist
new file mode 100644
index 000000000000..62295c115b9c
--- /dev/null
+++ b/sysutils/tcplist/pkg-plist
@@ -0,0 +1,2 @@
+bin/tcplist
+man/man1/tcplist.1.gz