aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-03-24 22:02:35 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-03-24 22:02:35 +0000
commit23c27f61803e9c4848c688ed896943ddf72c7b97 (patch)
tree7aff71f9e779d161583eb1809d286db45569ce29 /sysutils
parent184c3bf72b7ba48f9e790dacbc74440bd07b0176 (diff)
downloadports-23c27f61803e9c4848c688ed896943ddf72c7b97.tar.gz
ports-23c27f61803e9c4848c688ed896943ddf72c7b97.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/salt/Makefile17
-rw-r--r--sysutils/salt/files/patch-kvm_hyper.py11
-rw-r--r--sysutils/salt/files/patch-setup.py16
3 files changed, 28 insertions, 16 deletions
diff --git a/sysutils/salt/Makefile b/sysutils/salt/Makefile
index 022239b1e279..a8e5095a4595 100644
--- a/sysutils/salt/Makefile
+++ b/sysutils/salt/Makefile
@@ -7,6 +7,7 @@
PORTNAME= salt
PORTVERSION= 0.9.8
+PORTREVISION= 1
CATEGORIES= sysutils python
MASTER_SITES= https://github.com/downloads/saltstack/salt/
@@ -16,6 +17,13 @@ COMMENT= Distributed, remote execution and configuration management system
LICENSE= AL2
LIB_DEPENDS= zmq.1:${PORTSDIR}/devel/zmq
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=0:${PORTSDIR}/devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}pyzmq>=2.1.9:${PORTSDIR}/devel/py-pyzmq \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>=0:${PORTSDIR}/security/py-pycrypto \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>=0:${PORTSDIR}/devel/py-Jinja2 \
+ ${PYTHON_PKGNAMEPREFIX}msgpack>=0.1.9:${PORTSDIR}/devel/py-msgpack \
+ ${PYTHON_PKGNAMEPREFIX}m2crypto>=0:${PORTSDIR}/security/py-m2crypto
+RUN_DEPENDS:= ${BUILD_DEPENDS}
FETCH_ARGS= -pRr
USE_PYTHON= 2.6-2.7
@@ -40,15 +48,6 @@ MAN1= salt-call.1 \
MAN7= salt.7
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}yaml>=0:${PORTSDIR}/devel/py-yaml \
- ${PYTHON_PKGNAMEPREFIX}pyzmq>=2.1.9:${PORTSDIR}/devel/py-pyzmq \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>=0:${PORTSDIR}/security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}Jinja2>=0:${PORTSDIR}/devel/py-Jinja2 \
- ${PYTHON_PKGNAMEPREFIX}msgpack>=0.1.9:${PORTSDIR}/devel/py-msgpack \
- ${PYTHON_PKGNAMEPREFIX}m2crypto>=0:${PORTSDIR}/security/py-m2crypto
-
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
post-patch:
.for file in conf/minion.template conf/master.template doc/man/salt-key.1 \
doc/man/salt-cp.1 doc/man/salt-minion.1 doc/man/salt-syndic.1 \
diff --git a/sysutils/salt/files/patch-kvm_hyper.py b/sysutils/salt/files/patch-kvm_hyper.py
new file mode 100644
index 000000000000..5401aa617fea
--- /dev/null
+++ b/sysutils/salt/files/patch-kvm_hyper.py
@@ -0,0 +1,11 @@
+--- salt-0.9.8/kvm_hyper.py 2012-03-22 10:57:13.019199302 -0600
++++ salt/modules/kvm_hyper.py 2012-03-22 10:57:45.441204588 -0600
+@@ -46,6 +46,8 @@
+ return False
+ if __grains__['virtual'] != 'physical':
+ return False
++ if __grains__['kernel'] != 'Linux':
++ return False
+ if 'kvm_' not in open('/proc/modules').read():
+ return False
+ if not has_libvirt:
diff --git a/sysutils/salt/files/patch-setup.py b/sysutils/salt/files/patch-setup.py
index bb1153213124..0610e0e5a3bd 100644
--- a/sysutils/salt/files/patch-setup.py
+++ b/sysutils/salt/files/patch-setup.py
@@ -1,15 +1,15 @@
---- salt-0.9.6/setup.py 2012-01-21 02:18:08.000000000 +0000
-+++ setup.py 2012-01-22 19:21:35.158004570 +0000
-@@ -44,7 +44,7 @@
+--- setup.py 2012-03-21 11:46:26.000000000 -0600
++++ setup.py 2012-03-24 14:01:33.965200298 -0600
+@@ -47,7 +47,7 @@
if 'SYSCONFDIR' in os.environ:
etc_path = os.environ['SYSCONFDIR']
else:
- etc_path = os.path.join(os.path.dirname(PREFIX), 'etc')
+ etc_path = os.path.join('%%PREFIX%%', 'etc')
-
+
libraries = ['ws2_32'] if sys.platform == 'win32' else []
-
-@@ -91,10 +91,10 @@
+
+@@ -98,10 +98,10 @@
'scripts/salt-run',
'scripts/salt'],
data_files=[(os.path.join(etc_path, 'salt'),
@@ -23,7 +23,7 @@
['doc/man/salt-master.1',
'doc/man/salt-key.1',
'doc/man/salt.1',
-@@ -104,7 +104,7 @@
+@@ -111,9 +111,8 @@
'doc/man/salt-run.1',
'doc/man/salt-minion.1',
]),
@@ -32,3 +32,5 @@
['doc/man/salt.7',
]),
],
+- install_requires=requirements,
+ )