aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-09-27 20:21:51 +0000
committerSteve Wills <swills@FreeBSD.org>2014-09-27 20:21:51 +0000
commit8985fe61066bd3bc9d9822739c843e27580cf9bf (patch)
treee73b69c3a99cf47be3976344f5a5b1ef814ced31 /sysutils
parent1c6b920a96a9306232da318f042a54c887426660 (diff)
downloadports-8985fe61066bd3bc9d9822739c843e27580cf9bf.tar.gz
ports-8985fe61066bd3bc9d9822739c843e27580cf9bf.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/rubygem-hammer_cli_foreman_bootdisk/Makefile27
-rw-r--r--sysutils/rubygem-hammer_cli_foreman_bootdisk/distinfo2
-rw-r--r--sysutils/rubygem-hammer_cli_foreman_bootdisk/files/foreman_bootdisk.yml.sample3
-rw-r--r--sysutils/rubygem-hammer_cli_foreman_bootdisk/pkg-descr4
-rw-r--r--sysutils/rubygem-hammer_cli_foreman_bootdisk/pkg-plist1
6 files changed, 38 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index d94986f4f161..e8bd4c37ff23 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -803,6 +803,7 @@
SUBDIR += rubygem-guard-rspec
SUBDIR += rubygem-hammer_cli
SUBDIR += rubygem-hammer_cli_foreman
+ SUBDIR += rubygem-hammer_cli_foreman_bootdisk
SUBDIR += rubygem-hiera
SUBDIR += rubygem-hiera-json
SUBDIR += rubygem-hiera-puppet
diff --git a/sysutils/rubygem-hammer_cli_foreman_bootdisk/Makefile b/sysutils/rubygem-hammer_cli_foreman_bootdisk/Makefile
new file mode 100644
index 000000000000..63463b29aed0
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman_bootdisk/Makefile
@@ -0,0 +1,27 @@
+# Created by: Michael Moll <kvedulv@kvedulv.de>
+# $FreeBSD$
+
+PORTNAME= hammer_cli_foreman_bootdisk
+PORTVERSION= 0.1.2
+CATEGORIES= sysutils ruby
+MASTER_SITES= RG
+
+MAINTAINER= kvedulv@kvedulv.de
+COMMENT= Foreman bootdisk commands for Hammer CLI
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= rubygem-hammer_cli_foreman>=0.1.2:${PORTSDIR}/sysutils/rubygem-hammer_cli_foreman
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.pre.mk>
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/hammer
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/hammer/cli.modules.d
+ ${INSTALL_DATA} ${FILESDIR}/foreman_bootdisk.yml.sample ${STAGEDIR}${PREFIX}/etc/hammer/cli.modules.d/foreman_bootdisk.yml.sample
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/rubygem-hammer_cli_foreman_bootdisk/distinfo b/sysutils/rubygem-hammer_cli_foreman_bootdisk/distinfo
new file mode 100644
index 000000000000..5ee09ca441b4
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman_bootdisk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/hammer_cli_foreman_bootdisk-0.1.2.gem) = 8926ddbee847599dc19134384ade852dcee2f0c3e7f600f0930925941069a37d
+SIZE (rubygem/hammer_cli_foreman_bootdisk-0.1.2.gem) = 8192
diff --git a/sysutils/rubygem-hammer_cli_foreman_bootdisk/files/foreman_bootdisk.yml.sample b/sysutils/rubygem-hammer_cli_foreman_bootdisk/files/foreman_bootdisk.yml.sample
new file mode 100644
index 000000000000..014d7fce2aec
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman_bootdisk/files/foreman_bootdisk.yml.sample
@@ -0,0 +1,3 @@
+:foreman_bootdisk:
+ # Enable/disable foreman_bootdisk commands
+ :enable_module: true
diff --git a/sysutils/rubygem-hammer_cli_foreman_bootdisk/pkg-descr b/sysutils/rubygem-hammer_cli_foreman_bootdisk/pkg-descr
new file mode 100644
index 000000000000..d10e0a743156
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman_bootdisk/pkg-descr
@@ -0,0 +1,4 @@
+This Hammer CLI plugin contains set of commands for foreman_bootdisk,
+a plugin to Foreman for ISO/USB booting support
+
+WWW: https://github.com/theforeman/hammer_cli_foreman_bootdisk
diff --git a/sysutils/rubygem-hammer_cli_foreman_bootdisk/pkg-plist b/sysutils/rubygem-hammer_cli_foreman_bootdisk/pkg-plist
new file mode 100644
index 000000000000..4696da2c60db
--- /dev/null
+++ b/sysutils/rubygem-hammer_cli_foreman_bootdisk/pkg-plist
@@ -0,0 +1 @@
+@sample etc/hammer/cli.modules.d/foreman_bootdisk.yml.sample