aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2011-08-29 00:08:00 +0000
committerMatthias Andree <mandree@FreeBSD.org>2011-08-29 00:08:00 +0000
commitba565fd276ee590fe1eddda5e535af8044665d02 (patch)
tree70138ada3e7f0d2fa13f588f772ca70faf2d9cb6 /sysutils
parentec8d91021271ea09b64664b5462ee365629d2624 (diff)
downloadports-ba565fd276ee590fe1eddda5e535af8044665d02.tar.gz
ports-ba565fd276ee590fe1eddda5e535af8044665d02.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/busybox/Makefile1
-rw-r--r--sysutils/busybox/files/patch-freebsd-upstream85
2 files changed, 85 insertions, 1 deletions
diff --git a/sysutils/busybox/Makefile b/sysutils/busybox/Makefile
index bf5c7b48080c..63bc0d7e13db 100644
--- a/sysutils/busybox/Makefile
+++ b/sysutils/busybox/Makefile
@@ -14,7 +14,6 @@ MASTER_SITES= http://www.busybox.net/downloads/
PATCH_SITES= http://www.busybox.net/downloads/fixes-${PORTVERSION}/
PATCHFILES= busybox-1.19.0-cttyhack.patch \
busybox-1.19.0-find.patch \
- busybox-1.19.0-freebsd.patch \
busybox-1.19.0-less.patch \
busybox-1.19.0-sed.patch \
busybox-1.19.0-swap.patch \
diff --git a/sysutils/busybox/files/patch-freebsd-upstream b/sysutils/busybox/files/patch-freebsd-upstream
new file mode 100644
index 000000000000..9a2673a5e952
--- /dev/null
+++ b/sysutils/busybox/files/patch-freebsd-upstream
@@ -0,0 +1,85 @@
+--- ./include/platform.h
++++ ./include/platform.h
+@@ -417,6 +417,8 @@ typedef unsigned smalluint;
+ # undef HAVE_STRVERSCMP
+ # undef HAVE_XTABS
+ # undef HAVE_DPRINTF
++# undef HAVE_UNLOCKED_STDIO
++# undef HAVE_UNLOCKED_LINE_OPS
+ #endif
+
+ #if defined(__FreeBSD__)
+--- ./libbb/getpty.c
++++ ./libbb/getpty.c
+@@ -19,20 +19,22 @@ int FAST_FUNC xgetpty(char *line)
+ if (p > 0) {
+ grantpt(p); /* chmod+chown corresponding slave pty */
+ unlockpt(p); /* (what does this do?) */
+-#ifndef HAVE_PTSNAME_R
+- const char *name;
+- name = ptsname(p); /* find out the name of slave pty */
+- if (!name) {
+- bb_perror_msg_and_die("ptsname error (is /dev/pts mounted?)");
++# ifndef HAVE_PTSNAME_R
++ {
++ const char *name;
++ name = ptsname(p); /* find out the name of slave pty */
++ if (!name) {
++ bb_perror_msg_and_die("ptsname error (is /dev/pts mounted?)");
++ }
++ safe_strncpy(line, name, GETPTY_BUFSIZE);
+ }
+- safe_strncpy(line, name, GETPTY_BUFSIZE);
+-#else
++# else
+ /* find out the name of slave pty */
+ if (ptsname_r(p, line, GETPTY_BUFSIZE-1) != 0) {
+ bb_perror_msg_and_die("ptsname error (is /dev/pts mounted?)");
+ }
+ line[GETPTY_BUFSIZE-1] = '\0';
+-#endif
++# endif
+ return p;
+ }
+ #else
+--- ./libbb/match_fstype.c
++++ ./libbb/match_fstype.c
+@@ -10,6 +10,8 @@
+ * Licensed under GPLv2 or later, see file LICENSE in this source tree.
+ */
+
+ #include "libbb.h"
+
++#ifdef HAVE_MNTENT_H
++
+ int FAST_FUNC match_fstype(const struct mntent *mt, const char *t_fstype)
+@@ -40,3 +42,5 @@ int FAST_FUNC match_fstype(const struct
+
+ return !match;
+ }
++
++#endif /* HAVE_MNTENT_H */
+--- ./libbb/udp_io.c
++++ ./libbb/udp_io.c
+@@ -13,7 +13,7 @@
+ * We don't check for errors here. Not supported == won't be used
+ */
+ void FAST_FUNC
+-socket_want_pktinfo(int fd)
++socket_want_pktinfo(int fd UNUSED_PARAM)
+ {
+ #ifdef IP_PKTINFO
+ setsockopt(fd, IPPROTO_IP, IP_PKTINFO, &const_int_1, sizeof(int));
+--- ./miscutils/less.c
++++ ./miscutils/less.c
+@@ -721,8 +721,8 @@ static void print_found(const char *line
+ while (match_status == 0) {
+ char *new = xasprintf("%s%.*s"HIGHLIGHT"%.*s"NORMAL,
+ growline ? growline : "",
+- match_structs.rm_so, str,
+- match_structs.rm_eo - match_structs.rm_so,
++ (int)match_structs.rm_so, str,
++ (int)(match_structs.rm_eo - match_structs.rm_so),
+ str + match_structs.rm_so);
+ free(growline);
+ growline = new;