aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2012-08-24 09:14:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2012-08-24 09:14:01 +0000
commitd345eb88ad2af452194e5bd289d3bd5d39fe6e04 (patch)
tree546dbd966bb2bdc280611bedfd825fa1650aa28c /sysutils
parentea1212ff0702929bfb05f8e1e4157ecfa4d3c60d (diff)
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cdrkit/Makefile3
-rw-r--r--sysutils/cdrkit/distinfo4
-rw-r--r--sysutils/cdrkit/files/patch-genisomage87
3 files changed, 90 insertions, 4 deletions
diff --git a/sysutils/cdrkit/Makefile b/sysutils/cdrkit/Makefile
index 8ff67cfa9caf..c0f5d6879696 100644
--- a/sysutils/cdrkit/Makefile
+++ b/sysutils/cdrkit/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cdrkit
-PORTVERSION= 1.1.9
-PORTREVISION= 1
+PORTVERSION= 1.1.11
CATEGORIES= sysutils
MASTER_SITES= http://cdrkit.org/releases/ \
http://debburn.alioth.debian.org/
diff --git a/sysutils/cdrkit/distinfo b/sysutils/cdrkit/distinfo
index 383f9dd81e0e..151f17849b8e 100644
--- a/sysutils/cdrkit/distinfo
+++ b/sysutils/cdrkit/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cdrkit-1.1.9.tar.gz) = d5d58ab4c7bef036a53ef9742b4e57621f61310cd0cd28f558ba0b88c354efa2
-SIZE (cdrkit-1.1.9.tar.gz) = 1430065
+SHA256 (cdrkit-1.1.11.tar.gz) = d1c030756ecc182defee9fe885638c1785d35a2c2a297b4604c0e0dcc78e47da
+SIZE (cdrkit-1.1.11.tar.gz) = 1445133
diff --git a/sysutils/cdrkit/files/patch-genisomage b/sysutils/cdrkit/files/patch-genisomage
new file mode 100644
index 000000000000..3cd56228c66b
--- /dev/null
+++ b/sysutils/cdrkit/files/patch-genisomage
@@ -0,0 +1,87 @@
+$FreeBSD$
+
+Use <sys/endian.h> instead of the linux-ish <endian.h>
+
+Use __attribute__ ((__nothrow__)) instead of the linux-ish __THROW (from the
+linux sys/cdefs.h) macro - should work with clang and gcc on FreeBSD.
+
+--- genisoimage/sha256.c.orig 2009-10-11 12:27:59.000000000 -0600
++++ genisoimage/sha256.c 2011-10-27 14:55:25.000000000 -0600
+@@ -24,9 +24,9 @@
+
+ /* Written by Ulrich Drepper <drepper@redhat.com>, 2007. */
+
+-#include <endian.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <sys/endian.h>
+ #include <sys/types.h>
+
+ #include "sha256.h"
+--- genisoimage/sha256.h.orig 2009-05-10 15:49:54.000000000 -0600
++++ genisoimage/sha256.h 2011-10-27 14:58:30.000000000 -0600
+@@ -42,14 +42,14 @@
+
+ /* Initialize structure containing state of computation.
+ (FIPS 180-2: 5.3.2) */
+-extern void sha256_init_ctx (struct sha256_ctx *ctx) __THROW;
++extern void sha256_init_ctx (struct sha256_ctx *ctx) __attribute__ ((__nothrow__));
+
+ /* Starting with the result of former calls of this function (or the
+ initialization function update the context for the next LEN bytes
+ starting at BUFFER.
+ It is NOT required that LEN is a multiple of 64. */
+ extern void sha256_process_bytes (const void *buffer, size_t len,
+- struct sha256_ctx *ctx) __THROW;
++ struct sha256_ctx *ctx) __attribute__ ((__nothrow__));
+
+ /* Process the remaining bytes in the buffer and put result from CTX
+ in first 32 bytes following RESBUF.
+@@ -57,6 +57,6 @@
+ IMPORTANT: On some systems it is required that RESBUF is correctly
+ aligned for a 32 bits value. */
+ extern void *sha256_finish_ctx (struct sha256_ctx *ctx, void *resbuf)
+- __THROW;
++ __attribute__ ((__nothrow__));
+
+ #endif /* sha256.h */
+--- genisoimage/sha512.h.orig 2009-05-10 15:49:54.000000000 -0600
++++ genisoimage/sha512.h 2011-10-27 14:58:35.000000000 -0600
+@@ -42,14 +42,14 @@
+
+ /* Initialize structure containing state of computation.
+ (FIPS 180-2: 5.3.3) */
+-extern void sha512_init_ctx (struct sha512_ctx *ctx) __THROW;
++extern void sha512_init_ctx (struct sha512_ctx *ctx) __attribute__ ((__nothrow__));
+
+ /* Starting with the result of former calls of this function (or the
+ initialization function update the context for the next LEN bytes
+ starting at BUFFER.
+ It is NOT required that LEN is a multiple of 128. */
+ extern void sha512_process_bytes (const void *buffer, size_t len,
+- struct sha512_ctx *ctx) __THROW;
++ struct sha512_ctx *ctx) __attribute__ ((__nothrow__));
+
+ /* Process the remaining bytes in the buffer and put result from CTX
+ in first 64 bytes following RESBUF.
+@@ -57,6 +57,6 @@
+ IMPORTANT: On some systems it is required that RESBUF is correctly
+ aligned for a 64 bits value. */
+ extern void *sha512_finish_ctx (struct sha512_ctx *ctx, void *resbuf)
+- __THROW;
++ __attribute__ ((__nothrow__));
+
+ #endif /* sha512.h */
+--- genisoimage/sha512.c.orig 2009-10-11 12:27:59.000000000 -0600
++++ genisoimage/sha512.c 2011-10-27 14:59:01.000000000 -0600
+@@ -24,9 +24,9 @@
+
+ /* Written by Ulrich Drepper <drepper@redhat.com>, 2007. */
+
+-#include <endian.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <sys/endian.h>
+ #include <sys/types.h>
+
+ #include "sha512.h"