aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2017-04-05 02:16:34 +0000
committerLarry Rosenman <ler@FreeBSD.org>2017-04-05 02:16:34 +0000
commitf4db6bb03b9d12a6322b67e531118ea90038107f (patch)
tree1184957d8e3e8b982fb74400059904d50141e736 /sysutils
parent67cab83a77d48a6f073e86ecda90bd5a58a5d184 (diff)
downloadports-f4db6bb03b9d12a6322b67e531118ea90038107f.tar.gz
ports-f4db6bb03b9d12a6322b67e531118ea90038107f.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/p5-Giovanni/Makefile33
-rw-r--r--sysutils/p5-Giovanni/distinfo3
-rw-r--r--sysutils/p5-Giovanni/pkg-descr5
-rw-r--r--sysutils/p5-Giovanni/pkg-plist10
4 files changed, 51 insertions, 0 deletions
diff --git a/sysutils/p5-Giovanni/Makefile b/sysutils/p5-Giovanni/Makefile
new file mode 100644
index 000000000000..81954cf0fbf5
--- /dev/null
+++ b/sysutils/p5-Giovanni/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= Giovanni
+PORTVERSION= 1.12
+CATEGORIES= sysutils perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:NORBU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dch@skunkwerks.at
+COMMENT= PERL-based software deployment tool inspired by capistrano
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+LICENSE_FILE_ART10= ${WRKSRC}/Artistic
+LICENSE_FILE_GPLv1= ${WRKSRC}/Copying
+
+BUILD_DEPENDS= \
+ p5-Config-GitLike>=0:devel/p5-Config-GitLike \
+ p5-Expect>=0:lang/p5-Expect \
+ p5-Git-Repository>=0:devel/p5-Git-Repository \
+ p5-LWP-Protocol-https>=0:www/p5-LWP-Protocol-https \
+ p5-libwww>=0:www/p5-libwww \
+ p5-Mouse>=0:devel/p5-Mouse \
+ p5-Net-OpenSSH>=0:net/p5-Net-OpenSSH
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+NO_ARCH= yes
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-Giovanni/distinfo b/sysutils/p5-Giovanni/distinfo
new file mode 100644
index 000000000000..1ca86a326087
--- /dev/null
+++ b/sysutils/p5-Giovanni/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1491312863
+SHA256 (Giovanni-1.12.tar.gz) = 2bbea32a94d6bb182ccd003b9602658c31ed82e1c0f314bca16969c8eb449633
+SIZE (Giovanni-1.12.tar.gz) = 15897
diff --git a/sysutils/p5-Giovanni/pkg-descr b/sysutils/p5-Giovanni/pkg-descr
new file mode 100644
index 000000000000..47f0aa5782d2
--- /dev/null
+++ b/sysutils/p5-Giovanni/pkg-descr
@@ -0,0 +1,5 @@
+Giovanni is a Perl replacement for the idea behind Capistrano.
+It is a deployment system that can be used comfortably from the
+commandline to check out code, restart systems and notify.
+
+WWW: http://search.cpan.org/dist/Giovanni/
diff --git a/sysutils/p5-Giovanni/pkg-plist b/sysutils/p5-Giovanni/pkg-plist
new file mode 100644
index 000000000000..aab48cde7d68
--- /dev/null
+++ b/sysutils/p5-Giovanni/pkg-plist
@@ -0,0 +1,10 @@
+bin/gio
+%%SITE_PERL%%/Giovanni.pm
+%%SITE_PERL%%/Giovanni/Plugins/Git.pm
+%%SITE_PERL%%/Giovanni/Plugins/Hipchat.pm
+%%SITE_PERL%%/Giovanni/Stages.pm
+%%PERL5_MAN1%%/gio.1.gz
+%%PERL5_MAN3%%/Giovanni.3.gz
+%%PERL5_MAN3%%/Giovanni::Plugins::Git.3.gz
+%%PERL5_MAN3%%/Giovanni::Plugins::Hipchat.3.gz
+%%PERL5_MAN3%%/Giovanni::Stages.3.gz