aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorBrad Davis <brd@FreeBSD.org>2016-07-12 19:57:47 +0000
committerBrad Davis <brd@FreeBSD.org>2016-07-12 19:57:47 +0000
commit62f7ccb4e7f04f767a0e8a0996f866bff784a230 (patch)
tree34021bf795856e6f051300bd8fb433c85b264d7e /sysutils
parenta0f90776f48ef0e77a1646f132bfa903769d064f (diff)
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/u-boot-olimex-a20-som-evb/Makefile6
-rw-r--r--sysutils/u-boot-olimex-a20-som-evb/distinfo6
-rw-r--r--sysutils/u-boot-olimex-a20-som-evb/files/patch-api_api.c18
-rw-r--r--sysutils/u-boot-olimex-a20-som-evb/files/patch-api_api__net.c2
-rw-r--r--sysutils/u-boot-olimex-a20-som-evb/files/patch-cmd_elf.c2
-rw-r--r--sysutils/u-boot-olimex-a20-som-evb/files/patch-cmd_test.c2
-rw-r--r--sysutils/u-boot-olimex-a20-som-evb/files/patch-include_configs_sunxi-common.h4
-rw-r--r--sysutils/u-boot-olimex-a20-som-evb/pkg-descr6
8 files changed, 25 insertions, 21 deletions
diff --git a/sysutils/u-boot-olimex-a20-som-evb/Makefile b/sysutils/u-boot-olimex-a20-som-evb/Makefile
index dd233a9136d1..681d63bd546f 100644
--- a/sysutils/u-boot-olimex-a20-som-evb/Makefile
+++ b/sysutils/u-boot-olimex-a20-som-evb/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= arm-none-eabi-gcc:devel/arm-none-eabi-gcc
-UBOOT_VERSION?= 2016.05
+UBOOT_VERSION?= 2016.07
BOARD_CONFIG?= A20-Olimex-SOM-EVB_defconfig
MODEL?= olimex-a20-som-evb
@@ -34,8 +34,8 @@ MAKE_ARGS+= ARCH=arm \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 1100000
-IGNORE= requires FreeBSD 11 or later
+.if ${OSVERSION} < 1000000
+IGNORE= requires FreeBSD 10 or later
.endif
post-patch:
diff --git a/sysutils/u-boot-olimex-a20-som-evb/distinfo b/sysutils/u-boot-olimex-a20-som-evb/distinfo
index 77d92eca7981..956ccb60cf54 100644
--- a/sysutils/u-boot-olimex-a20-som-evb/distinfo
+++ b/sysutils/u-boot-olimex-a20-som-evb/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1466239765
-SHA256 (u-boot-2016.05.tar.bz2) = 87d02275615aaf0cd007b54cbe9fbadceef2bee7c79e6c323ea1ae8956dcb171
-SIZE (u-boot-2016.05.tar.bz2) = 11325053
+TIMESTAMP = 1468333360
+SHA256 (u-boot-2016.07.tar.bz2) = 974fb7225c0af6a721307631f66b81e20dbda82a4d7cc32aba2a625727231253
+SIZE (u-boot-2016.07.tar.bz2) = 11506848
diff --git a/sysutils/u-boot-olimex-a20-som-evb/files/patch-api_api.c b/sysutils/u-boot-olimex-a20-som-evb/files/patch-api_api.c
index fa75b514c76f..51ed454e2931 100644
--- a/sysutils/u-boot-olimex-a20-som-evb/files/patch-api_api.c
+++ b/sysutils/u-boot-olimex-a20-som-evb/files/patch-api_api.c
@@ -1,4 +1,4 @@
---- api/api.c.orig 2016-05-16 14:40:32 UTC
+--- api/api.c.orig 2016-07-11 19:01:01 UTC
+++ api/api.c
@@ -290,6 +290,14 @@ static int API_dev_close(va_list ap)
if (!err)
@@ -26,9 +26,9 @@
+ ENTRY *match, search;
+ static char *buf;
- last = (char *)va_arg(ap, u_int32_t);
+ last = (char *)va_arg(ap, unsigned long);
- if ((next = (char **)va_arg(ap, u_int32_t)) == NULL)
+ if ((next = (char **)va_arg(ap, uintptr_t)) == NULL)
return API_EINVAL;
- if (last == NULL)
@@ -58,6 +58,10 @@
-
- *next = ((char *)env_get_addr(i));
- return 0;
+- }
+- }
+-
+- return 0;
+ /*
+ * This leverages realloc's behavior of growing but never shrinking the
+ * existing buffer.
@@ -74,9 +78,9 @@
+ if ((i = hsearch_r(search, FIND, &match, &env_htab, 0)) == 0) {
+ i = API_EINVAL;
+ goto done;
- }
- }
-
++ }
++ }
++
+ /* hmatch on empty string is effectively "get next entry after i". */
+ if ((i = hmatch_r("", i, &match, &env_htab)) == 0)
+ goto done;
@@ -84,7 +88,7 @@
+ buf = realloc(buf, buflen);
+ snprintf(buf, buflen, "%s=%s", match->key, match->data);
+ *next = buf;
- return 0;
++ return 0;
+done:
+ free(buf);
+ buf = NULL;
diff --git a/sysutils/u-boot-olimex-a20-som-evb/files/patch-api_api__net.c b/sysutils/u-boot-olimex-a20-som-evb/files/patch-api_api__net.c
index b2f7fd615f86..2c9e4bd3bb11 100644
--- a/sysutils/u-boot-olimex-a20-som-evb/files/patch-api_api__net.c
+++ b/sysutils/u-boot-olimex-a20-som-evb/files/patch-api_api__net.c
@@ -1,4 +1,4 @@
---- api/api_net.c.orig 2016-05-16 14:40:32 UTC
+--- api/api_net.c.orig 2016-07-11 19:01:01 UTC
+++ api/api_net.c
@@ -25,7 +25,7 @@ DECLARE_GLOBAL_DATA_PTR;
diff --git a/sysutils/u-boot-olimex-a20-som-evb/files/patch-cmd_elf.c b/sysutils/u-boot-olimex-a20-som-evb/files/patch-cmd_elf.c
index da6f5fdc1053..ebe98f228bb7 100644
--- a/sysutils/u-boot-olimex-a20-som-evb/files/patch-cmd_elf.c
+++ b/sysutils/u-boot-olimex-a20-som-evb/files/patch-cmd_elf.c
@@ -1,4 +1,4 @@
---- cmd/elf.c.orig 2016-05-16 14:40:32 UTC
+--- cmd/elf.c.orig 2016-07-11 19:01:01 UTC
+++ cmd/elf.c
@@ -110,22 +110,12 @@ static unsigned long do_bootelf_exec(ulo
unsigned long ret;
diff --git a/sysutils/u-boot-olimex-a20-som-evb/files/patch-cmd_test.c b/sysutils/u-boot-olimex-a20-som-evb/files/patch-cmd_test.c
index d7f8c8bc58d4..a16105857d85 100644
--- a/sysutils/u-boot-olimex-a20-som-evb/files/patch-cmd_test.c
+++ b/sysutils/u-boot-olimex-a20-som-evb/files/patch-cmd_test.c
@@ -1,4 +1,4 @@
---- cmd/test.c.orig 2016-05-16 14:40:32 UTC
+--- cmd/test.c.orig 2016-07-11 19:01:01 UTC
+++ cmd/test.c
@@ -56,9 +56,14 @@ static int do_test(cmd_tbl_t *cmdtp, int
char * const *ap;
diff --git a/sysutils/u-boot-olimex-a20-som-evb/files/patch-include_configs_sunxi-common.h b/sysutils/u-boot-olimex-a20-som-evb/files/patch-include_configs_sunxi-common.h
index 638f9258a44d..315c80b09f11 100644
--- a/sysutils/u-boot-olimex-a20-som-evb/files/patch-include_configs_sunxi-common.h
+++ b/sysutils/u-boot-olimex-a20-som-evb/files/patch-include_configs_sunxi-common.h
@@ -1,6 +1,6 @@
---- include/configs/sunxi-common.h.orig 2016-05-16 14:40:32 UTC
+--- include/configs/sunxi-common.h.orig 2016-07-11 19:01:01 UTC
+++ include/configs/sunxi-common.h
-@@ -513,4 +513,69 @@ extern int soft_i2c_gpio_scl;
+@@ -530,4 +530,69 @@ extern int soft_i2c_gpio_scl;
#define CONFIG_EXTRA_ENV_SETTINGS
#endif
diff --git a/sysutils/u-boot-olimex-a20-som-evb/pkg-descr b/sysutils/u-boot-olimex-a20-som-evb/pkg-descr
index bfcd0f27eb11..216bc58fd5b0 100644
--- a/sysutils/u-boot-olimex-a20-som-evb/pkg-descr
+++ b/sysutils/u-boot-olimex-a20-som-evb/pkg-descr
@@ -1,7 +1,7 @@
U-Boot loader for Olimex A20 SOM EVB.
-To install this bootloader, follow the instructions in
- http://linux-sunxi.org/Bootable_SD_card#Bootloader
+To install this bootloader on an sdcard just do :
+dd if=/usr/local/share/u-boot/u-boot-boardname/u-boot-sunxi-with-spl.bin of=/path/to/sdcarddevice bs=1k seek=8 conv=notrunc,sync
This version is patched so that:
* ELF and API features are enabled.
@@ -13,7 +13,7 @@ This version is patched so that:
* By default, it loads PIE ubldr.bin from file ubldr.bin on the FAT partition
to address 0x42000000, and launches it.
-For information about running FreeBSD on Cubieboard, see
+For information about running FreeBSD on Allwinner boards, see
https://wiki.freebsd.org/FreeBSD/arm/Allwinner
For general information about U-Boot see WWW: http://www.denx.de/wiki/U-Boot