aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2010-03-10 17:55:09 +0000
committerAndrej Zverev <az@FreeBSD.org>2010-03-10 17:55:09 +0000
commitcc36258c9f85090b80197b0e220a9a3c703bae40 (patch)
tree123707c05056351b789f640dc93f0cda924dbb20 /sysutils
parent81c9c181d986634ff4a36c75629416da2287bb3f (diff)
downloadports-cc36258c9f85090b80197b0e220a9a3c703bae40.tar.gz
ports-cc36258c9f85090b80197b0e220a9a3c703bae40.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/pdsh/Makefile24
-rw-r--r--sysutils/pdsh/distinfo3
-rw-r--r--sysutils/pdsh/pkg-descr6
-rw-r--r--sysutils/pdsh/pkg-plist12
5 files changed, 46 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index b4d0515d5440..5f8cd850d2fc 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -588,6 +588,7 @@
SUBDIR += pcfclock
SUBDIR += pciutils
SUBDIR += pdixtract
+ SUBDIR += pdsh
SUBDIR += pdumpfs
SUBDIR += pdumpfs-clean
SUBDIR += pdumpfs-rsync
diff --git a/sysutils/pdsh/Makefile b/sysutils/pdsh/Makefile
new file mode 100644
index 000000000000..674cb5a43680
--- /dev/null
+++ b/sysutils/pdsh/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: sysutils/pdsh
+# Date created: 2010-03-09
+# Whom: Mykola Dzham <i@levsha.me>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdsh
+PORTVERSION= 2.18
+CATEGORIES= sysutils
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= i@levsha.me
+COMMENT= Parallel Distributed Shell
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_PERL5_BUILD= yes
+
+MAN1= dshbak.1 pdcp.1 pdsh.1
+MLINKS= pdcp.1 rpdcp.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/pdsh/distinfo b/sysutils/pdsh/distinfo
new file mode 100644
index 000000000000..17284c92764c
--- /dev/null
+++ b/sysutils/pdsh/distinfo
@@ -0,0 +1,3 @@
+MD5 (pdsh-2.18.tar.bz2) = ff5dc11f25ce9c7474e71aafb5d293e8
+SHA256 (pdsh-2.18.tar.bz2) = 8c94acb17b4af8a9f553db180b4d5745c9c98844a5dc070e2ce80590e8e8a539
+SIZE (pdsh-2.18.tar.bz2) = 453729
diff --git a/sysutils/pdsh/pkg-descr b/sysutils/pdsh/pkg-descr
new file mode 100644
index 000000000000..2ead1d9ece6d
--- /dev/null
+++ b/sysutils/pdsh/pkg-descr
@@ -0,0 +1,6 @@
+Pdsh is a an efficient, multithreaded remote shell client which executes
+commands on multiple remote hosts in parallel. Pdsh implements dynamically
+loadable modules for extended functionality such as new remote shell services
+and remote host selection.
+
+WWW: http://pdsh.sourceforge.net
diff --git a/sysutils/pdsh/pkg-plist b/sysutils/pdsh/pkg-plist
new file mode 100644
index 000000000000..51b4576d000c
--- /dev/null
+++ b/sysutils/pdsh/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+bin/dshbak
+bin/pdcp
+bin/pdsh
+bin/rpdcp
+lib/pdsh/execcmd.a
+lib/pdsh/execcmd.la
+lib/pdsh/execcmd.so
+lib/pdsh/xrcmd.a
+lib/pdsh/xrcmd.la
+lib/pdsh/xrcmd.so
+@dirrm lib/pdsh