aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-01-02 22:02:21 +0000
committerStefan Eßer <se@FreeBSD.org>2022-01-14 20:32:23 +0000
commit677f2a7b833e101623186c8ccfb9d812f0cd8ac4 (patch)
tree6c1d221b08e2f0cd7d8d1919bd8b9911f7d630a9 /sysutils
parentf69609a997ea1284b6c5eea0ad6a9d75f3e3e94b (diff)
downloadports-677f2a7b833e101623186c8ccfb9d812f0cd8ac4.tar.gz
ports-677f2a7b833e101623186c8ccfb9d812f0cd8ac4.zip
Make multiple ports build with new CPU_* macros
Merge commits from main branch to 2022Q1 to allow the affected ports to build on 13-STABLE as of today, which has received the CPU_AND, CPU_ANDNOT, CPU_OR, and CPU_XOR macros from -CURRENT. sysutils/slurm-wlm: fix build on -CURRENT The CPU_OR macro has been made compatible with GLIBC on -CURRENT, the FreeBSD specific alternative is therefore no longer required. While here pass --disable-slurmrestd to prevent the auto-configure script from attempting to build slurmrestd if glib is found by auto-configure (it does not build on FreeBSD due to Linux specific headers and shell features provided by Bash but by the /bin/sh in FreeBSD). This port has numerous build issues when not building in a clean jail (i.e. on a system with a previous version installed or with other software that is detected by auto-configure). The port revision is not bumped since these changes do not modify the package that is generated. (cherry picked from commit addda1277abed746f93ad76aecc2a2e9bc97d033) net/dpdk-20.11: fix build on -CURRENT The CPU_SET macros in -CURRENT have been made compatible with GLIBC. A simple test for the new signature of CPU_AND, CPU_OR, ... is the existence of a CPU_ALLOC macro. (cherry picked from commit 1b13427e48ed448f68a7d67a694da31b2d57104d) net/dpdk: fix build on -CURRENT The CPU_SET macros in -CURRENT have been made compatible with GLIBC. A simple test for the new signature of CPU_AND, CPU_OR, ... is the existence of a CPU_ALLOC macro. (cherry picked from commit c3e19584524281d37fe92868e5c3582fcd7d7d28) benchmarks/stress-ng: fix build on -CURRENT The CPU_SET macros in -CURRENT have been made compatible with GLIBC. A simple test for the new signature of CPU_AND, CPU_OR, ... is the existence of a CPU_ALLOC macro. (cherry picked from commit 7dc5416497a6d04bb85c5ded6b4983fb46b199b4) net/haproxy: fix build on -CURRENT The CPU_SET macros in -CURRENT have been made compatible with GLIBC. A simple test for the new signature of CPU_AND, CPU_OR, ... is the existence of a CPU_ALLOC macro. (cherry picked from commit 2913605c79b25b88a4a21b3d93ec2ab11949eaaa) net/haproxy-devel: fix build on -CURRENT The CPU_SET macros in -CURRENT have been made compatible with GLIBC. A simple test for the new signature of CPU_AND, CPU_OR, ... is the existence of a CPU_ALLOC macro. (cherry picked from commit 91efb4d016bcb7953f00a022f6bfe49a84dc61ac) sysutils/turbostat: use CPU_* macros defined in -CURRENT (cherry picked from commit 6cc600ed7040ae0270d22f580c4778266d9bdbe4) Approved by: portmgr (implicit)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/slurm-wlm/Makefile3
-rw-r--r--sysutils/slurm-wlm/files/patch-src_plugins_task_affinity_affinity.c11
2 files changed, 13 insertions, 1 deletions
diff --git a/sysutils/slurm-wlm/Makefile b/sysutils/slurm-wlm/Makefile
index 517b38320bd3..f3dd6e9c9b11 100644
--- a/sysutils/slurm-wlm/Makefile
+++ b/sysutils/slurm-wlm/Makefile
@@ -77,7 +77,8 @@ RRD_CONFIGURE_WITH= rrdtool
# --docdir is non-functional
# CONFIGURE_ARGS= --docdir=${DOCSDIR}
# FreeBSD Infiniband support is still experimental
-CONFIGURE_ARGS= --without-ofed
+# slurmrestd does not build on FreeBSD
+CONFIGURE_ARGS= --without-ofed --disable-slurmrestd
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${DISTVERSION}
CFLAGS+= -I${WRKSRC}/slurm -I${LOCALBASE}/include -fcommon
diff --git a/sysutils/slurm-wlm/files/patch-src_plugins_task_affinity_affinity.c b/sysutils/slurm-wlm/files/patch-src_plugins_task_affinity_affinity.c
new file mode 100644
index 000000000000..cf09d539002c
--- /dev/null
+++ b/sysutils/slurm-wlm/files/patch-src_plugins_task_affinity_affinity.c
@@ -0,0 +1,11 @@
+--- src/plugins/task/affinity/affinity.c.orig 2021-05-12 20:23:20 UTC
++++ src/plugins/task/affinity/affinity.c
+@@ -297,7 +297,7 @@ void reset_cpuset(cpu_set_t *new_mask, cpu_set_t *cur_
+ if (slurm_getaffinity(1, sizeof(full_mask), &full_mask)) {
+ /* Try to get full CPU mask from process init */
+ CPU_ZERO(&full_mask);
+-#ifdef __FreeBSD__
++#if defined(__FreeBSD__) && !defined(CPU_ALLOC)
+ CPU_OR(&full_mask, cur_mask);
+ #else
+ CPU_OR(&full_mask, &full_mask, cur_mask);