aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorRoger Pau Monné <royger@FreeBSD.org>2022-03-29 13:55:42 +0000
committerRoger Pau Monné <royger@FreeBSD.org>2022-03-30 10:30:55 +0000
commitb717e6878059d9ca5dee77cbfa6d8f6db38b0f87 (patch)
treeccf519d2cfe7f7fe3a3d32879b284509c54c4a00 /sysutils
parentc3f7c9567b5305f1c5a3c946799dd7214052f548 (diff)
downloadports-b717e6878059d9ca5dee77cbfa6d8f6db38b0f87.tar.gz
ports-b717e6878059d9ca5dee77cbfa6d8f6db38b0f87.zip
{emulators,sysutils}/xen-{kernel,tools}: update to 4.16.0
Add fixes for XSA-{395,398} and backport clang retpoline support from unstable. Sponsored by: Citrix Systems R&D Approved by: bapt (implicit)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/xen-tools/Makefile21
-rw-r--r--sysutils/xen-tools/distinfo6
-rw-r--r--sysutils/xen-tools/files/0001-efi-fix-alignment-of-function-parameters-in-compat-m.patch105
-rw-r--r--sysutils/xen-tools/pkg-plist49
4 files changed, 36 insertions, 145 deletions
diff --git a/sysutils/xen-tools/Makefile b/sysutils/xen-tools/Makefile
index f2b030e49bba..96896455f28d 100644
--- a/sysutils/xen-tools/Makefile
+++ b/sysutils/xen-tools/Makefile
@@ -1,7 +1,7 @@
PORTNAME= xen
PKGNAMESUFFIX= -tools
-PORTVERSION= 4.15.0
-PORTREVISION= 4
+PORTVERSION= 4.16.0
+PORTREVISION= 0
CATEGORIES= sysutils emulators
MASTER_SITES= http://downloads.xenproject.org/release/xen/${PORTVERSION}/
@@ -17,7 +17,8 @@ LIB_DEPENDS= libyajl.so:devel/yajl \
libargp.so:devel/argp-standalone \
libxml2.so:textproc/libxml2
BUILD_DEPENDS= seabios>0:misc/seabios \
- ${LOCALBASE}/share/edk2-xen/XEN_X64_EFI.fd:sysutils/edk2@xen_x64
+ ${LOCALBASE}/share/edk2-xen/XEN_X64_EFI.fd:sysutils/edk2@xen_x64 \
+ bash>0:shells/bash
RUN_DEPENDS= seabios>0:misc/seabios \
${LOCALBASE}/share/edk2-xen/XEN_X64_EFI.fd:sysutils/edk2@xen_x64
@@ -34,7 +35,7 @@ ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= not yet ported to anything other than amd64
USES= cpe gettext gmake gnome libtool localbase:ldflags perl5 \
- pkgconfig python:3.6+ shebangfix iconv bison
+ pkgconfig python:3.6+ shebangfix iconv bison ninja:build
USE_GNOME= glib20
USE_LDCONFIG= yes
USE_PYTHON= py3kplist
@@ -59,9 +60,6 @@ DOCS_ALL_TARGET= docs
INSTALL_TARGET= install-tools
DOCS_INSTALL_TARGET= install-docs
-# Fix pv shim build with clang 13.0.0
-EXTRA_PATCHES+= ${PATCHDIR}/0001-efi-fix-alignment-of-function-parameters-in-compat-m.patch:-p1
-
.include <bsd.port.options.mk>
.if ${OPSYS} != FreeBSD
@@ -72,13 +70,6 @@ IGNORE= only supported on FreeBSD
BROKEN= SPICE support requires FreeBSD version 13.0 or higher
.endif
-# ivshmem requires eventfd
-.if ${OSVERSION} >= 1300000
-PLIST_SUB+= IVSHMEM=""
-.else
-PLIST_SUB+= IVSHMEM="@comment "
-.endif
-
post-patch:
@for p in `ls ${FILESDIR}/*qemuu*.patch 2>/dev/null`; do \
${ECHO_CMD} "====> Applying $${p##*/}" ; \
@@ -96,7 +87,5 @@ do-install:
post-install:
${MKDIR} ${STAGEDIR}/var/run/xen
- # Empty dir, purge it.
- ${RMDIR} ${STAGEDIR}/${PREFIX}/lib/xen/include
.include <bsd.port.mk>
diff --git a/sysutils/xen-tools/distinfo b/sysutils/xen-tools/distinfo
index 740fd456bc18..d197e536add4 100644
--- a/sysutils/xen-tools/distinfo
+++ b/sysutils/xen-tools/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620647879
-SHA256 (xen-4.15.0.tar.gz) = 6cf41394726c9f2913edcd6707457d9b7a910a4d75d95e9ecdebf02b00f1adad
-SIZE (xen-4.15.0.tar.gz) = 40785399
+TIMESTAMP = 1648563575
+SHA256 (xen-4.16.0.tar.gz) = adc87a90e614d090a2014b9aebae8d815a7348bf329d169b3cb655256d0ee995
+SIZE (xen-4.16.0.tar.gz) = 44982322
diff --git a/sysutils/xen-tools/files/0001-efi-fix-alignment-of-function-parameters-in-compat-m.patch b/sysutils/xen-tools/files/0001-efi-fix-alignment-of-function-parameters-in-compat-m.patch
deleted file mode 100644
index 1612c5a113a1..000000000000
--- a/sysutils/xen-tools/files/0001-efi-fix-alignment-of-function-parameters-in-compat-m.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-From be12fcca8b784e456df3adedbffe657d753c5ff9 Mon Sep 17 00:00:00 2001
-From: Roger Pau Monne <roger.pau@citrix.com>
-Date: Thu, 18 Nov 2021 09:28:06 +0100
-Subject: [PATCH] efi: fix alignment of function parameters in compat mode
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Currently the max_store_size, remain_store_size and max_size in
-compat_pf_efi_runtime_call are 4 byte aligned, which makes clang
-13.0.0 complain with:
-
-In file included from compat.c:30:
-./runtime.c:646:13: error: passing 4-byte aligned argument to 8-byte aligned parameter 2 of 'QueryVariableInfo' may result in an unaligned pointer access [-Werror,-Walign-mismatch]
- &op->u.query_variable_info.max_store_size,
- ^
-./runtime.c:647:13: error: passing 4-byte aligned argument to 8-byte aligned parameter 3 of 'QueryVariableInfo' may result in an unaligned pointer access [-Werror,-Walign-mismatch]
- &op->u.query_variable_info.remain_store_size,
- ^
-./runtime.c:648:13: error: passing 4-byte aligned argument to 8-byte aligned parameter 4 of 'QueryVariableInfo' may result in an unaligned pointer access [-Werror,-Walign-mismatch]
- &op->u.query_variable_info.max_size);
- ^
-Fix this by bouncing the variables on the stack in order for them to
-be 8 byte aligned.
-
-Note this could be done in a more selective manner to only apply to
-compat code calls, but given the overhead of making an EFI call doing
-an extra copy of 3 variables doesn't seem to warrant the special
-casing.
-
-Signed-off-by: Roger Pau Monné <roger.pau@citrix.com>
-Release-Acked-by: Ian Jackson <iwj@xenproject.org>
-Reviewed-by: Ian Jackson <iwj@xenproject.org>
-Signed-off-by: Ian Jackson <iwj@xenproject.org>
-Reviewed-by: Jan Beulich <jbeulich@suse.com>
-
----
-Changes since v3:
- - Remove hard tabs. Apply Jan's r-b as authorised in email.
-Changes since v2:
- - Adjust the commentary as per discussion.
-Changes since v1:
- - Copy back the results.
----
- xen/common/efi/runtime.c | 31 +++++++++++++++++++++++++++----
- 1 file changed, 27 insertions(+), 4 deletions(-)
-
-diff --git a/xen/common/efi/runtime.c b/xen/common/efi/runtime.c
-index 375b94229e..d2fdc28df3 100644
---- a/xen/common/efi/runtime.c
-+++ b/xen/common/efi/runtime.c
-@@ -607,6 +607,9 @@ int efi_runtime_call(struct xenpf_efi_runtime_call *op)
- break;
-
- case XEN_EFI_query_variable_info:
-+ {
-+ uint64_t max_store_size, remain_store_size, max_size;
-+
- if ( op->misc & ~XEN_EFI_VARINFO_BOOT_SNAPSHOT )
- return -EINVAL;
-
-@@ -638,16 +641,36 @@ int efi_runtime_call(struct xenpf_efi_runtime_call *op)
-
- if ( !efi_enabled(EFI_RS) || (efi_rs->Hdr.Revision >> 16) < 2 )
- return -EOPNOTSUPP;
-+
-+ /*
-+ * Bounce the variables onto the stack to make them 8 byte aligned when
-+ * called from the compat handler, as their placement in
-+ * compat_pf_efi_runtime_call will make them 4 byte aligned instead and
-+ * and compilers may validly complain.
-+ *
-+ * Note that while the function parameters are OUT only, copy the
-+ * values here anyway just in case. This is done regardless of whether
-+ * called from the compat handler or not, as it's not worth the extra
-+ * logic to differentiate.
-+ */
-+ max_store_size = op->u.query_variable_info.max_store_size;
-+ remain_store_size = op->u.query_variable_info.remain_store_size;
-+ max_size = op->u.query_variable_info.max_size;
-+
- state = efi_rs_enter();
- if ( !state.cr3 )
- return -EOPNOTSUPP;
- status = efi_rs->QueryVariableInfo(
-- op->u.query_variable_info.attr,
-- &op->u.query_variable_info.max_store_size,
-- &op->u.query_variable_info.remain_store_size,
-- &op->u.query_variable_info.max_size);
-+ op->u.query_variable_info.attr, &max_store_size, &remain_store_size,
-+ &max_size);
- efi_rs_leave(&state);
-+
-+ op->u.query_variable_info.max_store_size = max_store_size;
-+ op->u.query_variable_info.remain_store_size = remain_store_size;
-+ op->u.query_variable_info.max_size = max_size;
-+
- break;
-+ }
-
- case XEN_EFI_query_capsule_capabilities:
- case XEN_EFI_update_capsule:
---
-2.33.0
-
diff --git a/sysutils/xen-tools/pkg-plist b/sysutils/xen-tools/pkg-plist
index 2288a58ae2fc..c9ffe5b4645b 100644
--- a/sysutils/xen-tools/pkg-plist
+++ b/sysutils/xen-tools/pkg-plist
@@ -143,11 +143,11 @@ lib/debug/usr/local/lib/xen/boot/xen-shim-syms
lib/libxencall.a
lib/libxencall.so
lib/libxencall.so.1
-lib/libxencall.so.1.2
+lib/libxencall.so.1.3
lib/libxenctrl.a
lib/libxenctrl.so
-lib/libxenctrl.so.4.15
-lib/libxenctrl.so.4.15.0
+lib/libxenctrl.so.4.16
+lib/libxenctrl.so.4.16.0
lib/libxendevicemodel.a
lib/libxendevicemodel.so
lib/libxendevicemodel.so.1
@@ -161,32 +161,32 @@ lib/libxenforeignmemory.so
lib/libxenforeignmemory.so.1
lib/libxenforeignmemory.so.1.4
lib/libxenfsimage.so
-lib/libxenfsimage.so.4.15
-lib/libxenfsimage.so.4.15.0
+lib/libxenfsimage.so.4.16
+lib/libxenfsimage.so.4.16.0
lib/libxengnttab.a
lib/libxengnttab.so
lib/libxengnttab.so.1
lib/libxengnttab.so.1.2
lib/libxenguest.a
lib/libxenguest.so
-lib/libxenguest.so.4.15
-lib/libxenguest.so.4.15.0
+lib/libxenguest.so.4.16
+lib/libxenguest.so.4.16.0
lib/libxenhypfs.a
lib/libxenhypfs.so
lib/libxenhypfs.so.1
lib/libxenhypfs.so.1.0
lib/libxenlight.a
lib/libxenlight.so
-lib/libxenlight.so.4.15
-lib/libxenlight.so.4.15.0
+lib/libxenlight.so.4.16
+lib/libxenlight.so.4.16.0
lib/libxenstat.a
lib/libxenstat.so
-lib/libxenstat.so.4.15
-lib/libxenstat.so.4.15.0
+lib/libxenstat.so.4.16
+lib/libxenstat.so.4.16.0
lib/libxenstore.a
lib/libxenstore.so
-lib/libxenstore.so.3.0
-lib/libxenstore.so.3.0.3
+lib/libxenstore.so.4
+lib/libxenstore.so.4.0
lib/libxentoolcore.a
lib/libxentoolcore.so
lib/libxentoolcore.so.1
@@ -197,8 +197,8 @@ lib/libxentoollog.so.1
lib/libxentoollog.so.1.0
lib/libxlutil.a
lib/libxlutil.so
-lib/libxlutil.so.4.15
-lib/libxlutil.so.4.15.0
+lib/libxlutil.so.4.16
+lib/libxlutil.so.4.16.0
%%PYTHON_SITELIBDIR%%/grub/ExtLinuxConf.py
%%PYTHON_SITELIBDIR%%/grub/ExtLinuxConf.pyc
%%PYTHON_SITELIBDIR%%/grub/GrubConf.py
@@ -236,8 +236,6 @@ lib/libxlutil.so.4.15.0
%%PYTHON_SITELIBDIR%%/xenfsimage%%PYTHON_EXT_SUFFIX%%.so
lib/xen/bin/convert-legacy-stream
lib/xen/bin/depriv-fd-checker
-%%IVSHMEM%%lib/xen/bin/ivshmem-client
-%%IVSHMEM%%lib/xen/bin/ivshmem-server
lib/xen/bin/libxl-save-helper
lib/xen/bin/lsevtchn
lib/xen/bin/pygrub
@@ -248,6 +246,10 @@ lib/xen/bin/qemu-nbd
lib/xen/bin/qemu-storage-daemon
lib/xen/bin/qemu-system-i386
lib/xen/bin/readnotes
+lib/xen/bin/test-cpu-policy
+lib/xen/bin/test-resource
+lib/xen/bin/test-tsx
+lib/xen/bin/test-xenstore
lib/xen/bin/verify-stream-v2
lib/xen/bin/xen-init-dom0
lib/xen/bin/xenconsole
@@ -256,6 +258,7 @@ lib/xen/bin/xenpaging
lib/xen/bin/xenpvnetboot
lib/xen/boot/hvmloader
lib/xen/boot/xen-shim
+lib/xen/include/qemu-plugin.h
lib/xenfsimage/ext2fs/fsimage.so
lib/xenfsimage/fat/fsimage.so
lib/xenfsimage/iso9660/fsimage.so
@@ -314,9 +317,11 @@ sbin/xen-hvmctx
sbin/xen-kdd
sbin/xen-livepatch
sbin/xen-lowmemd
+sbin/xen-mceinj
sbin/xen-memshare
sbin/xen-mfndump
sbin/xen-ucode
+sbin/xen-vmtrace
sbin/xenbaked
sbin/xenconsoled
sbin/xencov
@@ -652,10 +657,14 @@ share/qemu-xen/qemu/kvmvapic.bin
share/qemu-xen/qemu/linuxboot.bin
share/qemu-xen/qemu/linuxboot_dma.bin
share/qemu-xen/qemu/multiboot.bin
-share/qemu-xen/qemu/opensbi-riscv32-sifive_u-fw_jump.bin
+share/qemu-xen/qemu/npcm7xx_bootrom.bin
share/qemu-xen/qemu/openbios-ppc
share/qemu-xen/qemu/openbios-sparc32
share/qemu-xen/qemu/openbios-sparc64
+share/qemu-xen/qemu/opensbi-riscv32-generic-fw_dynamic.bin
+share/qemu-xen/qemu/opensbi-riscv32-generic-fw_dynamic.elf
+share/qemu-xen/qemu/opensbi-riscv64-generic-fw_dynamic.bin
+share/qemu-xen/qemu/opensbi-riscv64-generic-fw_dynamic.elf
share/qemu-xen/qemu/palcode-clipper
share/qemu-xen/qemu/petalogix-ml605.dtb
share/qemu-xen/qemu/petalogix-s3adsp1800.dtb
@@ -665,6 +674,7 @@ share/qemu-xen/qemu/pxe-ne2k_pci.rom
share/qemu-xen/qemu/pxe-pcnet.rom
share/qemu-xen/qemu/pxe-rtl8139.rom
share/qemu-xen/qemu/pxe-virtio.rom
+share/qemu-xen/qemu/qboot.rom
share/qemu-xen/qemu/qemu_vga.ndrv
share/qemu-xen/qemu/s390-ccw.img
share/qemu-xen/qemu/s390-netboot.img
@@ -706,9 +716,6 @@ share/qemu-xen/qemu/firmware/60-edk2-aarch64.json
share/qemu-xen/qemu/firmware/60-edk2-arm.json
share/qemu-xen/qemu/firmware/60-edk2-i386.json
share/qemu-xen/qemu/firmware/60-edk2-x86_64.json
-share/qemu-xen/qemu/opensbi-riscv32-virt-fw_jump.bin
-share/qemu-xen/qemu/opensbi-riscv64-sifive_u-fw_jump.bin
-share/qemu-xen/qemu/opensbi-riscv64-virt-fw_jump.bin
share/qemu-xen/qemu/pvh.bin
share/qemu-xen/qemu/qemu-nsis.bmp
share/qemu-xen/qemu/vgabios-ati.bin