aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-07-31 07:52:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-07-31 07:52:46 +0000
commitc4bc6925fbdf7eb07c47498bdf8f0117eeb4a008 (patch)
treedd74ad559c3bea9fc8af7df8f04cc1d9fae32700 /sysutils
parentcc98183b55355239bcfb26121873fab796fd62c1 (diff)
downloadports-c4bc6925fbdf7eb07c47498bdf8f0117eeb4a008.tar.gz
ports-c4bc6925fbdf7eb07c47498bdf8f0117eeb4a008.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/lavaps/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/sysutils/lavaps/Makefile b/sysutils/lavaps/Makefile
index 8da9224a764b..6d004cf60312 100644
--- a/sysutils/lavaps/Makefile
+++ b/sysutils/lavaps/Makefile
@@ -16,26 +16,22 @@ COMMENT= A lava lamp of currently running processes
GNU_CONFIGURE= yes
USE_GNOME= gnometarget
-CONFIGURE_ENV= CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= -x-includes="${X11BASE}/include" -x-libraries="${X11BASE}/lib"
USE_PERL5_BUILD= yes
+USE_XORG= x11 xext sm ice
MAN1= lavaps.1
-TCL_VER?= 8.4
+OPTIONS= GTK "Build with GTK frontend instead of the default TK" off
-CPPFLAGS+= -I${LOCALBASE}/include/tcl${TCL_VER} \
- -I${LOCALBASE}/include/tk${TCL_VER} \
- -I${LOCALBASE}/include
-CFLAGS+= -I${LOCALBASE}/include/tcl${TCL_VER} \
- -I${LOCALBASE}/include/tk${TCL_VER} \
- -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= GTK "Build with GTK frontend instead of the default TK" off
-
.include <bsd.port.pre.mk>
+CONFIGURE_ARGS+= -x-includes="${X11BASE}/include" \
+ -x-libraries="${X11BASE}/lib"
+
.if defined(WITH_GTK)
PKGNAMESUFFIX= -gtk2
USE_GNOME+= gtk20 libgnomeui
@@ -43,10 +39,15 @@ USE_GETTEXT= yes
CONFIGURE_ARGS+= --with-gtk
PLIST_SUB+= NLS=""
.else
-LIB_DEPENDS+= tk${TCL_VER:S/.//}:${PORTSDIR}/x11-toolkits/tk${TCL_VER:S/.//}
+USE_TK= 84+
+.include "${PORTSDIR}/Mk/bsd.tcl.mk"
+CPPFLAGS+= -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}
+CFLAGS+= -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}
CONFIGURE_ARGS+= --with-tcltk --disable-nls \
--with-tcl-ver=${TCL_VER} --with-tk-ver=${TCL_VER}
PLIST_SUB+= NLS="@comment "
.endif
+CONFIGURE_ENV+= CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
.include <bsd.port.post.mk>