aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2016-08-08 03:17:24 +0000
committerCy Schubert <cy@FreeBSD.org>2016-08-08 03:17:24 +0000
commiteb4a17deb502716426dddbeb8471a231381b66b9 (patch)
tree1c24a1fba8b26e3ab7bbce5b1c037942462a9f07 /sysutils
parentc509dc3273aeef921d238e4f61fb25d2cffe9beb (diff)
downloadports-eb4a17deb502716426dddbeb8471a231381b66b9.tar.gz
ports-eb4a17deb502716426dddbeb8471a231381b66b9.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cfengine36/Makefile11
-rw-r--r--sysutils/cfengine37/Makefile8
-rw-r--r--sysutils/cfengine38/Makefile8
-rw-r--r--sysutils/cfengine39/Makefile6
4 files changed, 14 insertions, 19 deletions
diff --git a/sysutils/cfengine36/Makefile b/sysutils/cfengine36/Makefile
index 57485f479d1b..a8bb495b3e5a 100644
--- a/sysutils/cfengine36/Makefile
+++ b/sysutils/cfengine36/Makefile
@@ -28,9 +28,8 @@ USE_RC_SUBR= cf-execd cf-serverd cf-monitord
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USES= autoreconf cpe gmake libtool shebangfix
+USES= autoreconf cpe gmake libtool shebangfix ssl
SHEBANG_FILES= examples/remake_outputs.pl
CFLAGS+= -Wno-return-type
CPPFLAGS+= -I${LOCALBASE}/include
@@ -54,14 +53,14 @@ LIB_DEPENDS+= libpcre.so:devel/pcre \
OPTIONS_DEFINE= PGSQL MYSQL LIBVIRT
PGSQL_USES= pgsql
-PGSQL_CONFIGURE_ON= --with-postgresql=${LOCALBASE}
+PGSQL_CONFIGURE_WITH= --with-postgresql=${LOCALBASE}
-MYSQL_USE= MYSQL=yes
-MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}
+MYSQL_USES= mysql
+MYSQL_CONFIGURE_WITH= --with-mysql=${LOCALBASE}
MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
-LIBVIRT_CONFIGURE_ON= --with-libvirt=${LOCALBASE}
+LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
.include <bsd.port.mk>
diff --git a/sysutils/cfengine37/Makefile b/sysutils/cfengine37/Makefile
index 792db57d22d2..838a2c696731 100644
--- a/sysutils/cfengine37/Makefile
+++ b/sysutils/cfengine37/Makefile
@@ -54,16 +54,14 @@ LIB_DEPENDS+= libpcre.so:devel/pcre \
OPTIONS_DEFINE= PGSQL MYSQL LIBVIRT
PGSQL_USES= pgsql
-PGSQL_CONFIGURE_ON= --with-postgresql=${LOCALBASE}
-PGSQL_CONFIGURE_OFF= --without-postgresql
+PGSQL_CONFIGURE_WITH= --with-postgresql=${LOCALBASE}
MYSQL_USE= MYSQL=yes
-MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}
+MYSQL_CONFIGURE_WITH= --with-mysql=${LOCALBASE}
MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
-LIBVIRT_CONFIGURE_ON= --with-libvirt=${LOCALBASE}
-LIBVIRT_CONFIGURE_OFF= --without-libvirt
+LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS= libvirt.so:devel/libvirt
.include <bsd.port.mk>
diff --git a/sysutils/cfengine38/Makefile b/sysutils/cfengine38/Makefile
index 5715ee571ad1..4917261bf8a7 100644
--- a/sysutils/cfengine38/Makefile
+++ b/sysutils/cfengine38/Makefile
@@ -56,16 +56,14 @@ LIB_DEPENDS+= libpcre.so:devel/pcre \
OPTIONS_DEFINE= PGSQL MYSQL LIBVIRT
PGSQL_USES= pgsql
-PGSQL_CONFIGURE_ON= --with-postgresql=${LOCALBASE}
-PGSQL_CONFIGURE_OFF= --without-postgresql
+PGSQL_CONFIGURE_WITH= --with-postgresql=${LOCALBASE}
MYSQL_USE= MYSQL=yes
-MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}
+MYSQL_CONFIGURE_WITH= --with-mysql=${LOCALBASE}
MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
-LIBVIRT_CONFIGURE_ON= --with-libvirt=${LOCALBASE}
-LIBVIRT_CONFIGURE_OFF= --without-libvirt
+LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS= libvirt.so:devel/libvirt
.include <bsd.port.mk>
diff --git a/sysutils/cfengine39/Makefile b/sysutils/cfengine39/Makefile
index 2c2aff55bf5b..5f8a0e8b744c 100644
--- a/sysutils/cfengine39/Makefile
+++ b/sysutils/cfengine39/Makefile
@@ -59,14 +59,14 @@ LIB_DEPENDS+= libpcre.so:devel/pcre \
OPTIONS_DEFINE= PGSQL MYSQL LIBVIRT
PGSQL_USES= pgsql
-PGSQL_CONFIGURE_ON= --with-postgresql=${LOCALBASE}
+PGSQL_CONFIGURE_WITH= --with-postgresql=${LOCALBASE}
MYSQL_USES= mysql
-MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}
+MYSQL_CONFIGURE_WITH= --with-mysql=${LOCALBASE}
MYSQL_LIB_DEPENDS= libmysqlclient.so:${_MYSQL_CLIENT}
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
-LIBVIRT_CONFIGURE_ON= --with-libvirt=${LOCALBASE}
+LIBVIRT_CONFIGURE_WITH= --with-libvirt=${LOCALBASE}
LIBVIRT_LIB_DEPENDS+= libvirt.so:devel/libvirt
.include <bsd.port.mk>