aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-01-25 13:09:25 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-01-25 13:09:25 +0000
commit2522c6a2dffdabeedbac603cd94e8b419e8e5d2d (patch)
treeba5a2aab5577aff22d7e4a5597aeb1492b77071b /sysutils
parent821642e85d084e1829fb18613fb5e372545ad5df (diff)
downloadports-2522c6a2dffdabeedbac603cd94e8b419e8e5d2d.tar.gz
ports-2522c6a2dffdabeedbac603cd94e8b419e8e5d2d.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/sysupdate/Makefile30
-rw-r--r--sysutils/sysupdate/distinfo3
-rw-r--r--sysutils/sysupdate/pkg-descr6
4 files changed, 40 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 3c487cf3b3bf..a42588a41c5a 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -515,6 +515,7 @@
SUBDIR += synergy
SUBDIR += syslog-ng
SUBDIR += system-tools-backends
+ SUBDIR += sysupdate
SUBDIR += tcplist
SUBDIR += tct
SUBDIR += tdir
diff --git a/sysutils/sysupdate/Makefile b/sysutils/sysupdate/Makefile
new file mode 100644
index 000000000000..3521c3234792
--- /dev/null
+++ b/sysutils/sysupdate/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: sysupdate
+# Date created: 17 Jan 2006
+# Whom: Tig <tig@lvlworld.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sysupdate
+PORTVERSION= 0.3
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= lvl
+DISTFILES= ${PORTNAME}.sh-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= tig@lvlworld.com
+COMMENT= System and ports update script
+
+MAN1= sysupdate.sh.1
+MANCOMPRESSED= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+NO_BUILD= yes
+PLIST_FILES= bin/sysupdate.sh
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/sysutils/sysupdate/distinfo b/sysutils/sysupdate/distinfo
new file mode 100644
index 000000000000..ab96490a69b3
--- /dev/null
+++ b/sysutils/sysupdate/distinfo
@@ -0,0 +1,3 @@
+MD5 (sysupdate.sh-0.3.tar.gz) = 980b083e37ed502acc209f2c04d02bb6
+SHA256 (sysupdate.sh-0.3.tar.gz) = bfee5eba4119aec6a26b8a1bd77dc2ba7b67c2394321f9e1ace7d5e41614781b
+SIZE (sysupdate.sh-0.3.tar.gz) = 14530
diff --git a/sysutils/sysupdate/pkg-descr b/sysutils/sysupdate/pkg-descr
new file mode 100644
index 000000000000..3039360f672d
--- /dev/null
+++ b/sysutils/sysupdate/pkg-descr
@@ -0,0 +1,6 @@
+sysupdate.sh will update your system and/or port collection files in part or in
+full to the latest cvs version. sysupdate.sh can be set to only download the
+latest system files or can be set to compile and install a complete system
+update.
+
+WWW: http://lvl.sourceforge.net/