aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorNeil Blakey-Milner <nbm@FreeBSD.org>2000-04-27 21:25:36 +0000
committerNeil Blakey-Milner <nbm@FreeBSD.org>2000-04-27 21:25:36 +0000
commit437ec95cc23df5e1b32f376b7f1cbf66f48e083d (patch)
treea12bdc11993e5187abab5fbf29cf3c7b44546840 /sysutils
parentd039013822d05d295d48b808143c95de543dac42 (diff)
downloadports-437ec95cc23df5e1b32f376b7f1cbf66f48e083d.tar.gz
ports-437ec95cc23df5e1b32f376b7f1cbf66f48e083d.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/daemontools53/Makefile26
-rw-r--r--sysutils/daemontools53/distinfo1
-rw-r--r--sysutils/daemontools53/pkg-comment1
-rw-r--r--sysutils/daemontools53/pkg-descr7
-rw-r--r--sysutils/daemontools53/pkg-plist11
-rw-r--r--sysutils/daemontools53/scripts/configure56
6 files changed, 102 insertions, 0 deletions
diff --git a/sysutils/daemontools53/Makefile b/sysutils/daemontools53/Makefile
new file mode 100644
index 000000000000..21e1d4d6502c
--- /dev/null
+++ b/sysutils/daemontools53/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: daemontools
+# Date created: 09 June 1998
+# Whom: Dom Mitchell <dom@myrddin.demon.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= daemontools
+PORTVERSION= 0.53
+CATEGORIES= sysutils
+MASTER_SITES= ftp://koobera.math.uic.edu/www/software/
+
+MAINTAINER= dom@myrddin.demon.co.uk
+
+NO_PACKAGE= Unsure of djb's license
+
+ALL_TARGET= it man
+INSTALL_TARGET= setup
+
+SCRIPTS_ENV= BINOWN="${BINOWN}" BINGRP="${BINGRP}" BINMODE="${BINMODE}" \
+ MANMODE="${MANMODE}" CFLAGS="${CFLAGS}"
+
+MAN1= accustamp.1 cyclog.1 errorsto.1 fifo.1 setuser.1 supervise.1 \
+ svc.1 svstat.1 tailocal.1 testfilelock.1 usually.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/daemontools53/distinfo b/sysutils/daemontools53/distinfo
new file mode 100644
index 000000000000..ef5761b95143
--- /dev/null
+++ b/sysutils/daemontools53/distinfo
@@ -0,0 +1 @@
+MD5 (daemontools-0.53.tar.gz) = e9c5817525ea138e8a143392b3ea8f6a
diff --git a/sysutils/daemontools53/pkg-comment b/sysutils/daemontools53/pkg-comment
new file mode 100644
index 000000000000..9f1c8ff6bbec
--- /dev/null
+++ b/sysutils/daemontools53/pkg-comment
@@ -0,0 +1 @@
+Service monitoring and logging utilities by djb
diff --git a/sysutils/daemontools53/pkg-descr b/sysutils/daemontools53/pkg-descr
new file mode 100644
index 000000000000..a9575e474077
--- /dev/null
+++ b/sysutils/daemontools53/pkg-descr
@@ -0,0 +1,7 @@
+Daemontools is a small set of /very/ useful utilities, from Dan
+Bernstein. They are mainly used for controlling processes, and
+maintaining logfiles.
+
+WWW: http://pobox.com/~djb/daemontools.html
+
+-Dom <dom@myrddin.demon.co.uk>
diff --git a/sysutils/daemontools53/pkg-plist b/sysutils/daemontools53/pkg-plist
new file mode 100644
index 000000000000..a297cebde8e2
--- /dev/null
+++ b/sysutils/daemontools53/pkg-plist
@@ -0,0 +1,11 @@
+bin/supervise
+bin/svc
+bin/svstat
+bin/testfilelock
+bin/fifo
+bin/cyclog
+bin/errorsto
+bin/usually
+bin/accustamp
+bin/tailocal
+bin/setuser
diff --git a/sysutils/daemontools53/scripts/configure b/sysutils/daemontools53/scripts/configure
new file mode 100644
index 000000000000..7a1467fd9dc0
--- /dev/null
+++ b/sysutils/daemontools53/scripts/configure
@@ -0,0 +1,56 @@
+#!/bin/sh
+#
+# Set up daemontools for the *BSD environment...
+#
+# @(#) $FreeBSD: /tmp/pcvs/ports/sysutils/daemontools53/scripts/configure,v 1.1.1.1 2000-04-27 21:25:36 nbm Exp $
+#
+
+# Tune the options we're given.
+echo ${PREFIX}/bin > ${WRKSRC}/conf-bin
+echo ${PREFIX}/man > ${WRKSRC}/conf-man
+echo cc ${CFLAGS} > ${WRKSRC}/conf-cc
+
+# Set up binaries correctly.
+awk 'BEGIN {
+ FS=":"
+ OFS=":"
+}
+$1 == "c" {
+ if ($6 == "setuser") {
+ $2 = "0"
+ $3 = "0"
+ } else {
+ $2 = bu
+ $3 = bg
+ $4 = bm
+ }
+ print
+ next
+}
+{
+ print
+}' bu=`id -u ${BINOWN}` bg=`id -g ${BINGRP}` bm=${BINMODE} \
+ ${WRKSRC}/BIN > ${WRKSRC}/BIN.tmp
+mv ${WRKSRC}/BIN.tmp ${WRKSRC}/BIN
+
+# Set up man pages correctly.
+awk 'BEGIN {
+ FS=":"
+ OFS=":"
+}
+# Dispose of preformatted man pages.
+$5 ~ "cat" {
+ next
+}
+$1 == "c" {
+ $2 = bu
+ $3 = bg
+ $4 = mm
+ print
+ next
+}
+{
+ print
+}' bu=`id -u ${BINOWN}` bg=`id -g ${BINGRP}` mm=${MANMODE} \
+ ${WRKSRC}/MAN > ${WRKSRC}/MAN.tmp
+mv ${WRKSRC}/MAN.tmp ${WRKSRC}/MAN