aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 09:39:46 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-27 09:39:46 +0000
commit9b530a6799544a3905447f53d0f2a87aaed811fe (patch)
tree711d0ab31b17b6339c29fe04030306df5829accc /sysutils
parentb47a1e6d5e271476164f9f86bb504d02581f26c3 (diff)
downloadports-9b530a6799544a3905447f53d0f2a87aaed811fe.tar.gz
ports-9b530a6799544a3905447f53d0f2a87aaed811fe.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/jx/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/sysutils/jx/Makefile b/sysutils/jx/Makefile
index c79736c5b939..02c0276d460e 100644
--- a/sysutils/jx/Makefile
+++ b/sysutils/jx/Makefile
@@ -13,15 +13,11 @@ USES= perl5
NO_BUILD= yes
USE_PERL5= run
-PLIST_FILES= bin/${PORTNAME}
-
-MAN1= jx.1
-MANCOMPRESSED= yes
+PLIST_FILES= bin/jx man/man1/jx.1.gz
OPTIONS_DEFINE= CONFIG
CONFIG_DESC= Enable custom config (recuire Config::General)
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCONFIG}
@@ -35,10 +31,12 @@ post-patch:
.endif
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1.gz ${PREFIX}/man/man1/${PORTNAME}.1.gz
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1.gz ${STAGEDIR}${PREFIX}/man/man1
.if ${PORT_OPTIONS:MCONFIG}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.cfg.sample ${PREFIX}/etc/${PORTNAME}.cfg.sample
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.cfg.sample \
+ ${STAGEDIR}${PREFIX}/etc/${PORTNAME}.cfg.sample
.endif
.include <bsd.port.mk>