aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-06-06 11:48:57 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-06-06 11:48:57 +0000
commitbb1e1d09c661eaffcb15664729d08e78eef7af27 (patch)
tree431ad1ae5a06a446391c38be8eea200ab3973000 /sysutils
parent0709bce52743c10a464874e97f48a7e01cd85ae3 (diff)
downloadports-bb1e1d09c661eaffcb15664729d08e78eef7af27.tar.gz
ports-bb1e1d09c661eaffcb15664729d08e78eef7af27.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/webmin/Makefile39
-rw-r--r--sysutils/webmin/distinfo13
-rw-r--r--sysutils/webmin/pkg-message5
-rw-r--r--sysutils/webmin/pkg-plist8
4 files changed, 35 insertions, 30 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index b91c3786e39a..fe523d426fb5 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= webmin
-PORTVERSION= 0.85
-PORTREVISION= 8
+PORTVERSION= 0.86
CATEGORIES= sysutils
MASTER_SITES= http://webadmin.sourceforge.net/webmin/updates/ \
http://webadmin.sourceforge.net/webmin/download/
@@ -22,12 +21,7 @@ NO_BUILD= yes
USE_PERL5= yes
SCRIPTS_ENV+= WRKDIR="${WRKDIR}"
-WEBMIN_MODULES= postgresql-0.85-1.wbm.gz squid-0.85-1.wbm.gz \
- useradmin-0.85-1.wbm.gz net-0.85-1.wbm.gz \
- apache-0.85-2.wbm.gz quota-0.85-1.wbm.gz \
- bind8-0.85-1.wbm.gz mysql-0.85-1.wbm.gz \
- shell-0.85-1.wbm.gz man-0.85-1.wbm.gz
-WEBMIN_SERVER= miniserv.pl
+WEBMIN_MODULES=
post-extract:
@if [ "${WEBMIN_MODULES}" != "" ]; then \
@@ -36,7 +30,6 @@ post-extract:
${TAR} xfz ${DISTDIR}/$${webmin_module} -C ${WRKSRC}; \
done; \
fi
- @${CP} ${DISTDIR}/${WEBMIN_SERVER} ${WRKSRC}
@find ${WRKSRC} -name "*.bak" | xargs ${RM}
post-patch:
@@ -79,15 +72,33 @@ do-install:
@${CP} -r ${WRKSRC}/* ${PREFIX}/lib/webmin
@cd ${PREFIX}/lib/webmin && find . -name "*.orig" -print \
| xargs ${RM}
+# we may have 2 levels of empty directories which cause the plist generation
+# system to fail
+ @cd ${PREFIX}/lib/webmin && find . -type d -empty -print \
+ | xargs ${RMDIR}
+ @cd ${PREFIX}/lib/webmin && find . -type d -empty -print \
+ | xargs ${RMDIR}
@${CP} ${WRKDIR}/webmin.sh ${PREFIX}/etc/rc.d/webmin.sh
@${CHMOD} 554 ${PREFIX}/etc/rc.d/webmin.sh
post-install:
- @${CP} ${PLIST} ${TMPPLIST}
- @find ${PREFIX}/lib/webmin -type f | ${SED} -e "s@${PREFIX}/@@" | sort >> ${TMPPLIST}
- @find ${PREFIX}/lib/webmin -type l | ${SED} -e "s@${PREFIX}/@@" | sort >> ${TMPPLIST}
- @find ${PREFIX}/lib/webmin -type d | ${SED} -e "s@${PREFIX}/@@" | ${PERL} -e 'print (join ("\n", reverse map ("\@dirrm " . substr ($$_, 0, -1), <STDIN>)) . "\n");' >> ${TMPPLIST}
- @if [ -d ${PREFIX}/etc/webmin ]; then echo | ${PREFIX}/lib/webmin/setup.sh ; fi
+ @cd ${PREFIX} ; find lib/webmin -type f -o -type l | sort \
+ > ${WRKDIR}/PLIST.lib-webmin
+ @cd ${PREFIX} ; find lib/webmin -type d | sort -r \
+ | ${SED} -e 's/^/@dirrm /g' \
+ >> ${WRKDIR}/PLIST.lib-webmin
+
+ @${ECHO} "r ${TMPPLIST}" > ${WRKDIR}/ex.script
+ @${ECHO} "/Insert PLIST.lib-webmin" >> ${WRKDIR}/ex.script
+ @${ECHO} "d" >> ${WRKDIR}/ex.script
+ @${ECHO} "r ${WRKDIR}/PLIST.lib-webmin" >> ${WRKDIR}/ex.script
+ @${ECHO} "x!" >> ${WRKDIR}/ex.script
+ @${CP} -p ${TMPPLIST} ${TMPPLIST}.pre-lib-webmin
+ @cd ${WRKDIR} ; ex < ex.script
+# upgrade configuration if etc/webmin exists
+ @[ ! -d ${PREFIX}/etc/webmin ] || echo | nostart=Y ${PREFIX}/lib/webmin/setup.sh
+# run interactive setup if not in BATCH mode and no configuration exists
+ @[ -n "$BATCH" ] || ([ -d ${PREFIX}/etc/webmin ] || nostart=Y ${PREFIX}/lib/webmin/setup.sh)
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/sysutils/webmin/distinfo b/sysutils/webmin/distinfo
index 48091d88ffa1..e1059388ef31 100644
--- a/sysutils/webmin/distinfo
+++ b/sysutils/webmin/distinfo
@@ -1,12 +1 @@
-MD5 (webmin-0.85.tar.gz) = c8ae7172cc00fdb6d1ffc627402c5d70
-MD5 (postgresql-0.85-1.wbm.gz) = 99d56d314e8eb04de3202fa577bd925e
-MD5 (squid-0.85-1.wbm.gz) = d26f3a7830f52c9eb81f2572f1578214
-MD5 (useradmin-0.85-1.wbm.gz) = 09ae3cf9384173c95425c7d8720ba4cf
-MD5 (net-0.85-1.wbm.gz) = 1f2f5887c66ee016c0f92be83b32f53d
-MD5 (apache-0.85-2.wbm.gz) = 32d3dae073c150212c17ad4a69310ae5
-MD5 (quota-0.85-1.wbm.gz) = c05fc28340b522f4f0502e554f354934
-MD5 (bind8-0.85-1.wbm.gz) = 0324060cfb648a365851f485148be4df
-MD5 (mysql-0.85-1.wbm.gz) = 97545385363dc9fc705935d7cbd27644
-MD5 (shell-0.85-1.wbm.gz) = ae6d9d26802befc2a28c7ca1555809bd
-MD5 (man-0.85-1.wbm.gz) = 0ac4149a8c6336668f443a73902c6cc5
-MD5 (miniserv.pl) = 2e79c5e4cc24e50395f905e78a0dae88
+MD5 (webmin-0.86.tar.gz) = 809ff153f6c93a30df31b8e12c98fd7c
diff --git a/sysutils/webmin/pkg-message b/sysutils/webmin/pkg-message
index 77066cbc7131..ddcfdbc65dfa 100644
--- a/sysutils/webmin/pkg-message
+++ b/sysutils/webmin/pkg-message
@@ -1,8 +1,7 @@
===================================
-To configure webmin for the first
-time you should run the following
-command as root:
+To reconfigure webmin you should
+run the following command as root:
${LOCALBASE}/lib/webmin/setup.sh
diff --git a/sysutils/webmin/pkg-plist b/sysutils/webmin/pkg-plist
index dc96b7779ab3..f46cba126412 100644
--- a/sysutils/webmin/pkg-plist
+++ b/sysutils/webmin/pkg-plist
@@ -1,2 +1,8 @@
etc/rc.d/webmin.sh
-@comment lib/webmin content list is automatically generated
+@comment Insert PLIST.lib-webmin here
+@comment -=[ begin PLIST.lib-webmin ]=-
+@comment -=[ end PLIST.lib-webmin ]=-
+@comment upgrade configuration if etc/webmin exists
+@exec [ ! -d %D/etc/webmin ] || echo | nostart=Y %D/lib/webmin/setup.sh
+@comment run interactive setup if not in BATCH mode and no configuration exists
+@exec [ -n "$BATCH" ] || ([ -d %D/etc/webmin ] || nostart=Y %D/lib/webmin/setup.sh)