aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-10 17:17:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-10 17:17:12 +0000
commitf1e25b8d3c91f46620df0510d0e090e47d0c3c5a (patch)
treec93ada0ee85da88eb2242849f0f16dbad4e955a3 /sysutils
parentf1cae17194a5d8883aee86bb5c8f8beaea0e759d (diff)
downloadports-f1e25b8d3c91f46620df0510d0e090e47d0c3c5a.tar.gz
ports-f1e25b8d3c91f46620df0510d0e090e47d0c3c5a.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/uptimec/Makefile33
-rw-r--r--sysutils/uptimec/distinfo4
-rw-r--r--sysutils/uptimec/files/pkg-message.in (renamed from sysutils/uptimec/pkg-message)0
-rw-r--r--sysutils/uptimec/files/uptimec.sh.in (renamed from sysutils/uptimec/files/uptimec.sh)0
4 files changed, 17 insertions, 20 deletions
diff --git a/sysutils/uptimec/Makefile b/sysutils/uptimec/Makefile
index c13a2f76880f..6633e4a00d12 100644
--- a/sysutils/uptimec/Makefile
+++ b/sysutils/uptimec/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= uptimec
-PORTVERSION= 0.2p2
+PORTVERSION= 0.2p5
CATEGORIES= sysutils
MASTER_SITES= http://www.mrEriksson.net/downloads/ \
ftp://ftp.mrEriksson.net/pub/uptimec/
@@ -14,32 +14,29 @@ MASTER_SITES= http://www.mrEriksson.net/downloads/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Client for Uptime Project
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_GMAKE= yes
USE_RC_SUBR= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PLIST_FILES= sbin/uptimec etc/uptimecrc.sample etc/rc.d/uptimec.sh
-PORTDOCS= README COPYING ChangeLog INSTALL protocol.txt
+PORTDOCS= README ChangeLog INSTALL protocol.txt
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+SUB_FILES= pkg-message uptimec.sh
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g' ${WRKSRC}/configure
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/uptimec ${PREFIX}/sbin
- ${INSTALL_DATA} ${MASTERDIR}/files/uptimecrc.sample ${PREFIX}/etc
- ${INSTALL_SCRIPT} ${WRKSRC}/uptimec.sh ${PREFIX}/etc/rc.d
+ ${INSTALL_PROGRAM} ${WRKSRC}/uptimec ${PREFIX}/sbin
+ ${INSTALL_DATA} ${FILESDIR}/uptimecrc.sample ${PREFIX}/etc
+ ${INSTALL_SCRIPT} ${WRKDIR}/uptimec.sh ${PREFIX}/etc/rc.d
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
-post-extract:
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/uptimec.sh > ${WRKSRC}/uptimec.sh
-
-post-install:
- @${SED} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/sysutils/uptimec/distinfo b/sysutils/uptimec/distinfo
index 8eeffa576dd5..301e6fd2c153 100644
--- a/sysutils/uptimec/distinfo
+++ b/sysutils/uptimec/distinfo
@@ -1,2 +1,2 @@
-MD5 (uptimec-0.2p2.tar.gz) = 944d05c4c227c3cd2d1eae4d6e4d532a
-SIZE (uptimec-0.2p2.tar.gz) = 81879
+MD5 (uptimec-0.2p5.tar.gz) = 621b5c4c421d5d1ce892cb730ca3d359
+SIZE (uptimec-0.2p5.tar.gz) = 82940
diff --git a/sysutils/uptimec/pkg-message b/sysutils/uptimec/files/pkg-message.in
index 54e40abd258b..54e40abd258b 100644
--- a/sysutils/uptimec/pkg-message
+++ b/sysutils/uptimec/files/pkg-message.in
diff --git a/sysutils/uptimec/files/uptimec.sh b/sysutils/uptimec/files/uptimec.sh.in
index 82a1b92a135b..82a1b92a135b 100644
--- a/sysutils/uptimec/files/uptimec.sh
+++ b/sysutils/uptimec/files/uptimec.sh.in