aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-11-22 18:54:49 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2010-11-22 18:54:49 +0000
commit048d322f5c01d03d14a21a12987867172a14dbd1 (patch)
treed5d17293759d1a7c5d6231f36c7715cd1a12ca31 /sysutils
parent73c6f32947d7af96dc6d1f4fa50bcd179bed2919 (diff)
downloadports-048d322f5c01d03d14a21a12987867172a14dbd1.tar.gz
ports-048d322f5c01d03d14a21a12987867172a14dbd1.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/py-supervisor/Makefile6
-rw-r--r--sysutils/py-supervisor/distinfo5
-rw-r--r--sysutils/py-supervisor/files/patch-src-supervisor-options.py13
3 files changed, 13 insertions, 11 deletions
diff --git a/sysutils/py-supervisor/Makefile b/sysutils/py-supervisor/Makefile
index bdf2dab61450..c21ead61e029 100644
--- a/sysutils/py-supervisor/Makefile
+++ b/sysutils/py-supervisor/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= supervisor
-PORTVERSION= 3.0a8
+PORTVERSION= 3.0a9
CATEGORIES= sysutils python
-MASTER_SITES= http://dist.supervisord.org/\
- CHEESESHOP
+MASTER_SITES= http://dist.supervisord.org/ \
+ CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= hizel@vyborg.ru
diff --git a/sysutils/py-supervisor/distinfo b/sysutils/py-supervisor/distinfo
index c4bfe0e8efe3..b04aae8f2913 100644
--- a/sysutils/py-supervisor/distinfo
+++ b/sysutils/py-supervisor/distinfo
@@ -1,3 +1,2 @@
-MD5 (supervisor-3.0a8.tar.gz) = 7a775455f3a53c2ea375d18dcfe9e522
-SHA256 (supervisor-3.0a8.tar.gz) = ce61afd01780ffba3e40ec244205b6db309da3b84ef27b5c5b179456050e5b8b
-SIZE (supervisor-3.0a8.tar.gz) = 287705
+SHA256 (supervisor-3.0a9.tar.gz) = 619f90b739ed3dff2fd991fe110b7bd4408975661baf7e9a8e2a685d05e63ea9
+SIZE (supervisor-3.0a9.tar.gz) = 408235
diff --git a/sysutils/py-supervisor/files/patch-src-supervisor-options.py b/sysutils/py-supervisor/files/patch-src-supervisor-options.py
index 46c7f1737f4a..bdee95882019 100644
--- a/sysutils/py-supervisor/files/patch-src-supervisor-options.py
+++ b/sysutils/py-supervisor/files/patch-src-supervisor-options.py
@@ -1,11 +1,14 @@
---- src/supervisor/options.py.orig 2010-02-11 13:25:24.000000000 +0300
-+++ src/supervisor/options.py 2010-02-11 13:25:55.000000000 +0300
-@@ -105,7 +105,7 @@
+--- src/supervisor/options.py.orig 2010-08-14 02:34:50.000000000 +0800
++++ src/supervisor/options.py 2010-11-23 02:33:20.000000000 +0800
+@@ -105,10 +105,7 @@
def default_configfile(self):
"""Return the name of the found config file or raise. """
- paths = ['supervisord.conf', 'etc/supervisord.conf',
+ here = os.path.dirname(os.path.dirname(sys.argv[0]))
+- paths = [os.path.join(here, 'etc', 'supervisord.conf'),
+- os.path.join(here, 'supervisord.conf'),
+- 'supervisord.conf', 'etc/supervisord.conf',
- '/etc/supervisord.conf']
-+ '/etc/supervisord.conf', '%%PREFIX%%/etc/supervisord.conf']
++ paths = [ '%%PREFIX%%/etc/supervisord.conf' ]
config = None
for path in paths:
if os.path.exists(path):