aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-11-19 15:27:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-11-19 15:27:29 +0000
commit9ecab89d6b703bb68ffdb62b6fcce0eca8f5b406 (patch)
tree832e78a85d6526cc015fdd48d27e90b781867013 /sysutils
parentcf48f823443d836854e062216b34a8407a6d768e (diff)
downloadports-9ecab89d6b703bb68ffdb62b6fcce0eca8f5b406.tar.gz
ports-9ecab89d6b703bb68ffdb62b6fcce0eca8f5b406.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/lineakd/Makefile35
-rw-r--r--sysutils/lineakd/distinfo2
-rw-r--r--sysutils/lineakd/files/extra-patch-lineakd.c-468
-rw-r--r--sysutils/lineakd/files/extra-patch-lineakd.c-569
-rw-r--r--sysutils/lineakd/files/patch-aa26
-rw-r--r--sysutils/lineakd/files/patch-cc16
-rw-r--r--sysutils/lineakd/files/patch-dd11
-rw-r--r--sysutils/lineakd/files/patch-ee28
-rw-r--r--sysutils/lineakd/pkg-plist13
9 files changed, 37 insertions, 231 deletions
diff --git a/sysutils/lineakd/Makefile b/sysutils/lineakd/Makefile
index 3bb56f99078a..614416d7c791 100644
--- a/sysutils/lineakd/Makefile
+++ b/sysutils/lineakd/Makefile
@@ -6,30 +6,41 @@
#
PORTNAME= lineakd
-PORTVERSION= 0.4.p3
+PORTVERSION= 0.7.2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=lineak
-DISTNAME= ${PORTNAME}-0.4pre3
MAINTAINER= kay_lehmann@web.de
COMMENT= Lineakd is a daemon which enables special keys on internet keyboards
-LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
-
-USE_BISON= yes
USE_GMAKE= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${X11BASE}/lib ${PTHREAD_LIBS}"
+USE_REINPLACE= yes
+
+.if defined(WITHOUT_XOSD)
+CONFIGURE_ARGS+= --with-xosd=no
+.else
+LIB_DEPENDS+= xosd.4:${PORTSDIR}/misc/xosd
+.endif
-CFLAGS+= -I${X11BASE}/include
-
-.include <bsd.port.pre.mk>
+PORTDOCS= README TODO AUTHORS
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-lineakd.c-4
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread||' ${WRKSRC}/lineakd/Makefile.in
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
-.if ${OSVERSION} >= 500000
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-lineakd.c-5
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
.endif
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/lineakd.conf.example ${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/lineakd/distinfo b/sysutils/lineakd/distinfo
index 9ca2366bb0bc..2c5fbd6adeef 100644
--- a/sysutils/lineakd/distinfo
+++ b/sysutils/lineakd/distinfo
@@ -1 +1 @@
-MD5 (lineakd-0.4pre3.tar.gz) = 4606ec63a8af63aa9086395f9be42cba
+MD5 (lineakd-0.7.2.tar.gz) = 547692808f03f87c247b9e156ac95c29
diff --git a/sysutils/lineakd/files/extra-patch-lineakd.c-4 b/sysutils/lineakd/files/extra-patch-lineakd.c-4
deleted file mode 100644
index 98745f46c7a8..000000000000
--- a/sysutils/lineakd/files/extra-patch-lineakd.c-4
+++ /dev/null
@@ -1,68 +0,0 @@
---- src/lineakd.c.orig Fri Sep 6 02:50:29 2002
-+++ src/lineakd.c Tue May 13 10:53:21 2003
-@@ -57,18 +57,19 @@
- #endif
- #include <fcntl.h>
- #include <sys/ioctl.h>
--#include <linux/cdrom.h> /* linux specific?!! */
-
- extern int mkdir(); /* in linux/fs.h ... other platforms!? */
-
- #if defined (__FreeBSD__)
- # include <machine/soundcard.h>
-+# include <sys/cdio.h>
- #else
- # if defined (__NetBSD__) || defined (__OpenBSD__)
- # include <soundcard.h> /* OSS emulation */
- # undef ioctl
- # else
- /* BSDI, Linux, Solaris */
-+# include <linux/cdrom.h> /* linux specific?!! */
- # include <sys/soundcard.h>
- # endif
- #endif
-@@ -100,7 +101,7 @@
- signal(SIGABRT, signalexit);
- signal(SIGINT, signalexit);
- /* and one so we won't have to wait() for child processes ;) */
-- signal(SIGCLD, SIG_IGN);
-+ signal(SIGCHLD, SIG_IGN);
- /* and for a rehash when we catch SIGHUP */
- signal(SIGHUP,signalHUP);
-
-@@ -598,12 +599,12 @@
- /* try to open the device .. */
- if ( (fp = open(cdromdev, O_RDONLY | O_NONBLOCK)) != -1 ) {
- /* tell the drive to diable auto-eject */
-- if ( (ioctl(fp, CDROMEJECT_SW, 0)) == -1 )
-- printf("... oops! error during CD-ROM init\n");
-- close(fp);
-- } else {
-+ if ( (ioctl(fp, CDIOCPREVENT)) == -1 )
-+ printf("... oops! error during CD-ROM init\n");
-+ close(fp);
-+ } else {
- printf("... oops! unable to open the CD-ROM device \"%s\" (CD-ROM init)\n",cdromdev);
-- }
-+ }
- } else {
- printf("no CD-ROM device configured! (CD-ROM init)\n");
- }
-@@ -618,7 +619,7 @@
- if ( (fp = open(cdromdev, O_RDONLY | O_NONBLOCK)) != -1 ) {
- if (!cdromstatus) { /* assumed closed */
- /* enable the drives software eject */
-- if ( (ioctl(fp, CDROMEJECT_SW, 1)) == -1 )
-+ if ( (ioctl(fp, CDIOCALLOW)) == -1 )
- printf("... oops! error enabling CD-ROM SW eject\n");
- /* eject the cdrom tray */
- if (verbosemode) printf("... ejecting the CD-ROM tray\n");
-@@ -628,7 +629,7 @@
- cdromstatus = !cdromstatus;
- } else { /* assumed open */
- /* disable the drives software eject again.. */
-- if ( (ioctl(fp, CDROMEJECT_SW, 0)) == -1 )
-+ if ( (ioctl(fp, CDIOCPREVENT)) == -1 )
- printf("... oops! error disabling CD-ROM SW eject\n");
- /* close the cdrom tray */
- if (verbosemode) printf("... closing the CD-ROM tray\n");
diff --git a/sysutils/lineakd/files/extra-patch-lineakd.c-5 b/sysutils/lineakd/files/extra-patch-lineakd.c-5
deleted file mode 100644
index 5112f45b8564..000000000000
--- a/sysutils/lineakd/files/extra-patch-lineakd.c-5
+++ /dev/null
@@ -1,69 +0,0 @@
---- src/lineakd.c.orig Fri Sep 6 02:50:29 2002
-+++ src/lineakd.c Sat May 24 18:01:00 2003
-@@ -57,18 +57,19 @@
- #endif
- #include <fcntl.h>
- #include <sys/ioctl.h>
--#include <linux/cdrom.h> /* linux specific?!! */
-
- extern int mkdir(); /* in linux/fs.h ... other platforms!? */
-
- #if defined (__FreeBSD__)
--# include <machine/soundcard.h>
-+# include <sys/soundcard.h>
-+# include <sys/cdio.h>
- #else
- # if defined (__NetBSD__) || defined (__OpenBSD__)
- # include <soundcard.h> /* OSS emulation */
- # undef ioctl
- # else
- /* BSDI, Linux, Solaris */
-+# include <linux/cdrom.h> /* linux specific?!! */
- # include <sys/soundcard.h>
- # endif
- #endif
-@@ -100,7 +101,7 @@
- signal(SIGABRT, signalexit);
- signal(SIGINT, signalexit);
- /* and one so we won't have to wait() for child processes ;) */
-- signal(SIGCLD, SIG_IGN);
-+ signal(SIGCHLD, SIG_IGN);
- /* and for a rehash when we catch SIGHUP */
- signal(SIGHUP,signalHUP);
-
-@@ -598,12 +599,12 @@
- /* try to open the device .. */
- if ( (fp = open(cdromdev, O_RDONLY | O_NONBLOCK)) != -1 ) {
- /* tell the drive to diable auto-eject */
-- if ( (ioctl(fp, CDROMEJECT_SW, 0)) == -1 )
-- printf("... oops! error during CD-ROM init\n");
-- close(fp);
-- } else {
-+ if ( (ioctl(fp, CDIOCPREVENT)) == -1 )
-+ printf("... oops! error during CD-ROM init\n");
-+ close(fp);
-+ } else {
- printf("... oops! unable to open the CD-ROM device \"%s\" (CD-ROM init)\n",cdromdev);
-- }
-+ }
- } else {
- printf("no CD-ROM device configured! (CD-ROM init)\n");
- }
-@@ -618,7 +619,7 @@
- if ( (fp = open(cdromdev, O_RDONLY | O_NONBLOCK)) != -1 ) {
- if (!cdromstatus) { /* assumed closed */
- /* enable the drives software eject */
-- if ( (ioctl(fp, CDROMEJECT_SW, 1)) == -1 )
-+ if ( (ioctl(fp, CDIOCALLOW)) == -1 )
- printf("... oops! error enabling CD-ROM SW eject\n");
- /* eject the cdrom tray */
- if (verbosemode) printf("... ejecting the CD-ROM tray\n");
-@@ -628,7 +629,7 @@
- cdromstatus = !cdromstatus;
- } else { /* assumed open */
- /* disable the drives software eject again.. */
-- if ( (ioctl(fp, CDROMEJECT_SW, 0)) == -1 )
-+ if ( (ioctl(fp, CDIOCPREVENT)) == -1 )
- printf("... oops! error disabling CD-ROM SW eject\n");
- /* close the cdrom tray */
- if (verbosemode) printf("... closing the CD-ROM tray\n");
diff --git a/sysutils/lineakd/files/patch-aa b/sysutils/lineakd/files/patch-aa
index ec1521013de3..5f18faacfc8d 100644
--- a/sysutils/lineakd/files/patch-aa
+++ b/sysutils/lineakd/files/patch-aa
@@ -1,15 +1,11 @@
---- src/lineakd.h.orig Wed Aug 28 04:43:19 2002
-+++ src/lineakd.h Tue May 13 10:56:23 2003
-@@ -127,6 +127,12 @@
- #define VOLMUTE_VALUE 0
- #define MAX_VOLUME 100
-
-+/* we need this for freebsd */
-+#if defined (__FreeBSD__)
-+#define CDROMEJECT CDIOCEJECT /*_IO('c', 107)*/
-+#define CDROMCLOSETRAY CDIOCCLOSE
-+#endif
-+
- /* we might need this .. oss emulation under BSD */
- #if defined (__NetBSD__) || defined (__OpenBSD__)
- #define SOUND_IOCTL(a,b,c) _oss_ioctl(a,b,c)
+--- lineakd/cdromctrl.cpp.orig Wed Nov 19 13:45:39 2003
++++ lineakd/cdromctrl.cpp Wed Nov 19 13:46:41 2003
+@@ -23,7 +23,7 @@
+ #include <sys/ioctl.h>
+ #if defined (__FreeBSD__)
+ # include <sys/cdio.h>
+- #define CDROMEJECT CDIOEJECT /*_IO('c',107)*/
++ #define CDROMEJECT CDIOCEJECT /*_IO('c',107)*/
+ #define CDROMCLOSETRAY CDIOCCLOSE
+ #else
+ #include <linux/cdrom.h> /* linux specific?!! */
diff --git a/sysutils/lineakd/files/patch-cc b/sysutils/lineakd/files/patch-cc
deleted file mode 100644
index 908309e2f87c..000000000000
--- a/sysutils/lineakd/files/patch-cc
+++ /dev/null
@@ -1,16 +0,0 @@
---- intl/dcigettext.c.orig Sat Jun 8 21:56:27 2002
-+++ intl/dcigettext.c Tue May 13 10:56:23 2003
-@@ -58,11 +58,11 @@
- #include <stdlib.h>
-
- #include <string.h>
--#if !HAVE_STRCHR && !defined _LIBC
-+/*#if !HAVE_STRCHR && !defined _LIBC
- # ifndef strchr
- # define strchr index
- # endif
--#endif
-+#endif*/
-
- #if defined HAVE_UNISTD_H || defined _LIBC
- # include <unistd.h>
diff --git a/sysutils/lineakd/files/patch-dd b/sysutils/lineakd/files/patch-dd
deleted file mode 100644
index dc044922f821..000000000000
--- a/sysutils/lineakd/files/patch-dd
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Thu May 15 16:05:33 2003
-+++ Makefile.in Thu May 15 16:06:13 2003
-@@ -112,7 +112,7 @@
-
- SUBDIRS = intl po src
-
--lineakddocdir = ${prefix}/doc/lineakd
-+lineakddocdir = ${prefix}/share/doc/lineakd
- lineakddoc_DATA = \
- README\
- COPYING\
diff --git a/sysutils/lineakd/files/patch-ee b/sysutils/lineakd/files/patch-ee
deleted file mode 100644
index 8e00c6c5e369..000000000000
--- a/sysutils/lineakd/files/patch-ee
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.orig Thu May 15 16:09:02 2003
-+++ Makefile Thu May 15 16:10:10 2003
-@@ -83,14 +83,14 @@
- LTLIBINTL =
- MKINSTALLDIRS = ./mkinstalldirs
- NO_PREFIX_PACKAGE_DATA_DIR = share/lineakd
--NO_PREFIX_PACKAGE_DOC_DIR = doc/lineakd
-+NO_PREFIX_PACKAGE_DOC_DIR = share/doc/lineakd
- NO_PREFIX_PACKAGE_HELP_DIR = share/lineakd/help
- NO_PREFIX_PACKAGE_MENU_DIR = share/lineakd
- NO_PREFIX_PACKAGE_PIXMAPS_DIR = share/lineakd/pixmaps
- OBJEXT = o
- PACKAGE = lineakd
- PACKAGE_DATA_DIR = /usr/local/share/lineakd
--PACKAGE_DOC_DIR = /usr/local/doc/lineakd
-+PACKAGE_DOC_DIR = /usr/local/share/doc/lineakd
- PACKAGE_HELP_DIR = /usr/local/share/lineakd/help
- PACKAGE_MENU_DIR = /usr/local/share/lineakd
- PACKAGE_PIXMAPS_DIR = /usr/local/share/lineakd/pixmaps
-@@ -112,7 +112,7 @@
-
- SUBDIRS = intl po src
-
--lineakddocdir = ${prefix}/doc/lineakd
-+lineakddocdir = ${prefix}/share/doc/lineakd
- lineakddoc_DATA = \
- README\
- COPYING\
diff --git a/sysutils/lineakd/pkg-plist b/sysutils/lineakd/pkg-plist
index 849234e77366..7b742bee690a 100644
--- a/sysutils/lineakd/pkg-plist
+++ b/sysutils/lineakd/pkg-plist
@@ -1,13 +1,4 @@
bin/lineakd
etc/lineakkb.def
-lib/charset.alias
-share/locale/locale.alias
-share/doc/lineakd/README
-share/doc/lineakd/COPYING
-share/doc/lineakd/AUTHORS
-share/doc/lineakd/ChangeLog
-share/doc/lineakd/INSTALL
-share/doc/lineakd/NEWS
-share/doc/lineakd/TODO
-share/doc/lineakd/ABOUT-NLS
-@dirrm share/doc/lineakd
+%%EXAMPLESDIR%%/lineakd.conf.example
+@dirrm %%EXAMPLESDIR%%