aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-05-14 11:36:45 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-05-14 11:36:45 +0000
commita3fb4e865fe86f63cfb2adf4138dd3cbbd177e44 (patch)
tree523268b82dde58a20ae54658c41716c9e7a9af00 /sysutils
parent05fa8ffc864b25abeac31ae0a166a4cdb51ebeb1 (diff)
downloadports-a3fb4e865fe86f63cfb2adf4138dd3cbbd177e44.tar.gz
ports-a3fb4e865fe86f63cfb2adf4138dd3cbbd177e44.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/xloadface/Makefile4
-rw-r--r--sysutils/xloadface/files/patch-widgets.c46
2 files changed, 46 insertions, 4 deletions
diff --git a/sysutils/xloadface/Makefile b/sysutils/xloadface/Makefile
index 95fc12cf6107..46187e731fb7 100644
--- a/sysutils/xloadface/Makefile
+++ b/sysutils/xloadface/Makefile
@@ -25,10 +25,6 @@ MANLANG= ja
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
-.endif
-
pre-build:
${LOCALBASE}/bin/nkf -e ${WRKSRC}/xloadface.1 > ${WRKSRC}/xloadface.man
diff --git a/sysutils/xloadface/files/patch-widgets.c b/sysutils/xloadface/files/patch-widgets.c
new file mode 100644
index 000000000000..68611d9afed5
--- /dev/null
+++ b/sysutils/xloadface/files/patch-widgets.c
@@ -0,0 +1,46 @@
+
+------------------------ start of patch ------------------------
+--- widgets.c.orig Fri Apr 29 16:37:58 2005
++++ widgets.c Fri Apr 29 16:39:09 2005
+@@ -18,7 +18,7 @@
+ #include "LoadFace.h"
+ #include "ArrangeBox.h"
+ #include "MachineInfo.h"
+-#include <varargs.h>
++#include <stdarg.h>
+ #include "version.h"
+ #include <math.h>
+ #include <X11/Xresource.h>
+@@ -49,7 +49,7 @@
+
+ static void exitDisplay(),popdown(),showHelp(),popdownHelp();
+
+-Widget mkWidget();
++Widget mkWidget(char* name, ...);
+
+ static XrmOptionDescRec optionTable[] = {
+ {"-interval", "*interval", XrmoptionSepArg,(caddr_t)NULL},
+@@ -571,11 +571,9 @@
+ * resource-name, resource, ... , NULL);
+ */
+ Widget
+-mkWidget(va_alist)
+-va_dcl
++mkWidget(char* name, ...)
+ {
+ va_list arg;
+- char *name;
+ WidgetClass class;
+ Widget parent;
+ String argname;
+@@ -583,8 +581,7 @@
+ int n = 0;
+ Arg args[20];
+
+- va_start(arg);
+- name = va_arg(arg,char*);
++ va_start(arg, name);
+ class = va_arg(arg,WidgetClass);
+ parent = va_arg(arg,Widget);
+
+------------------------ end of patch ------------------------