aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2007-07-25 01:25:03 +0000
committerKevin Lo <kevlo@FreeBSD.org>2007-07-25 01:25:03 +0000
commitdd66eb13d36d0b070c8640ff308a63ec98557773 (patch)
tree6785ca3599b104142c4ae4b03caf6f115b65e1a2 /sysutils
parent67f7a2644f33be93d75650f4a89d66daab77a13c (diff)
downloadports-dd66eb13d36d0b070c8640ff308a63ec98557773.tar.gz
ports-dd66eb13d36d0b070c8640ff308a63ec98557773.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/synergy/Makefile2
-rw-r--r--sysutils/synergy/files/patch-lib__server__CClientProxy1_0.cpp28
-rw-r--r--sysutils/synergy/files/patch-lib__server__CServer.cpp30
3 files changed, 59 insertions, 1 deletions
diff --git a/sysutils/synergy/Makefile b/sysutils/synergy/Makefile
index 10d5b50ca5be..20e485d30789 100644
--- a/sysutils/synergy/Makefile
+++ b/sysutils/synergy/Makefile
@@ -7,7 +7,7 @@
PORTNAME= synergy
PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}2
diff --git a/sysutils/synergy/files/patch-lib__server__CClientProxy1_0.cpp b/sysutils/synergy/files/patch-lib__server__CClientProxy1_0.cpp
new file mode 100644
index 000000000000..115b9fc5a485
--- /dev/null
+++ b/sysutils/synergy/files/patch-lib__server__CClientProxy1_0.cpp
@@ -0,0 +1,28 @@
+--- ./lib/server/CClientProxy1_0.cpp.orig 2006-04-02 03:47:03.000000000 +0200
++++ ./lib/server/CClientProxy1_0.cpp 2007-07-24 16:59:59.000000000 +0200
+@@ -401,7 +401,7 @@
+ &x, &y, &w, &h, &dummy1, &mx, &my)) {
+ return false;
+ }
+- LOG((CLOG_DEBUG "received client \"%s\" info shape=%d,%d %dx%d", getName().c_str(), x, y, w, h));
++ LOG((CLOG_DEBUG "received client \"%s\" info shape=%d,%d %dx%d mouse=%d,%d", getName().c_str(), x, y, w, h, mx, my));
+
+ // validate
+ if (w <= 0 || h <= 0) {
+@@ -413,8 +413,14 @@
+ m_info.m_y = y;
+ m_info.m_w = w;
+ m_info.m_h = h;
+- m_info.m_mx = mx;
+- m_info.m_my = my;
++
++ if(mx >= x && mx < x+w && my >= y && my < y+h) {
++ m_info.m_mx = mx;
++ m_info.m_my = my;
++ } else {
++ m_info.m_mx = x + w/2;
++ m_info.m_my = y + h/2;
++ }
+
+ // acknowledge receipt
+ LOG((CLOG_DEBUG1 "send info ack to \"%s\"", getName().c_str()));
diff --git a/sysutils/synergy/files/patch-lib__server__CServer.cpp b/sysutils/synergy/files/patch-lib__server__CServer.cpp
new file mode 100644
index 000000000000..34a27a5aa3d5
--- /dev/null
+++ b/sysutils/synergy/files/patch-lib__server__CServer.cpp
@@ -0,0 +1,30 @@
+--- ./lib/server/CServer.cpp.orig 2006-04-02 03:47:04.000000000 +0200
++++ ./lib/server/CServer.cpp 2007-07-24 16:59:59.000000000 +0200
+@@ -434,16 +434,23 @@
+ SInt32 x, SInt32 y, bool forScreensaver)
+ {
+ assert(dst != NULL);
++ assert(m_active != NULL);
++
++ LOG((CLOG_INFO "switch from \"%s\" to \"%s\" at %d,%d", getName(m_active).c_str(), getName(dst).c_str(), x, y));
++
+ #ifndef NDEBUG
+ {
+ SInt32 dx, dy, dw, dh;
+ dst->getShape(dx, dy, dw, dh);
+- assert(x >= dx && y >= dy && x < dx + dw && y < dy + dh);
++
++ if(!(x >= dx && y >= dy && x < dx + dw && y < dy + dh)) {
++ LOG((CLOG_ERR "debug check failed"));
++ LOG((CLOG_ERR "x=%d dx=%d dw=%d", x, dx, dw));
++ LOG((CLOG_ERR "y=%d dy=%d dh=%d", y, dy, dh));
++ assert(0);
++ }
+ }
+ #endif
+- assert(m_active != NULL);
+-
+- LOG((CLOG_INFO "switch from \"%s\" to \"%s\" at %d,%d", getName(m_active).c_str(), getName(dst).c_str(), x, y));
+
+ // stop waiting to switch
+ stopSwitch();