aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2005-05-16 12:43:10 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2005-05-16 12:43:10 +0000
commitfd2482c9d5f13d026e53014a5cdf668c6aaa4510 (patch)
treed7e982f6e242d737f962c10fad3c6ae5a4f781ea /sysutils
parent4cff37e49667c9a5eb91b4fd527a10c918bd4584 (diff)
downloadports-fd2482c9d5f13d026e53014a5cdf668c6aaa4510.tar.gz
ports-fd2482c9d5f13d026e53014a5cdf668c6aaa4510.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/gkrellm2/Makefile30
-rw-r--r--sysutils/gkrellm2/distinfo4
-rw-r--r--sysutils/gkrellm2/files/patch-Makefile13
-rw-r--r--sysutils/gkrellm2/files/patch-src::configure26
-rw-r--r--sysutils/gkrellm2/files/patch-src:Makefile25
-rw-r--r--sysutils/gkrellm2/pkg-descr41
-rw-r--r--sysutils/gkrellm2/pkg-plist24
7 files changed, 105 insertions, 58 deletions
diff --git a/sysutils/gkrellm2/Makefile b/sysutils/gkrellm2/Makefile
index 67a149af15dd..971673f318d2 100644
--- a/sysutils/gkrellm2/Makefile
+++ b/sysutils/gkrellm2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gkrellm
-PORTVERSION= 2.2.5
+PORTVERSION= 2.2.6
#PORTREVISION= 0
CATEGORIES= sysutils ipv6
MASTER_SITES= http://members.dslextreme.com/users/billw/gkrellm/ \
@@ -26,15 +26,36 @@ USE_RC_SUBR= gkrellmd.sh
WRKSRC= ${WRKDIR}/${DISTNAME:C/[a-z]$//}
+.if defined(WITH_GNUTLS) && defined(WITH_OPENSSL)
+BROKEN= "GnuTLS and OpenSSL is mutually exclusive."
+.endif
+
+.if !defined(WITH_OPENSSL) && !defined(WITH_GNUTLS) && !defined(WITHOUT_GNUTLS)
+WITH_GNUTLS= yes
+.endif
+
.if defined(GKRELLM_SERVER_ONLY)
BUILD_WRKSRC= ${WRKSRC}/server
INSTALL_WRKSRC= ${WRKSRC}/server
USE_GNOME= glib12
.else
USE_GNOME= gtk20
+.if defined(WITHOUT_NLS)
+MAKE_ENV+= enable_nls=0
+.else
USE_GETTEXT= yes
+.endif
USE_XLIB= yes
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls-openssl.12:${PORTSDIR}/security/gnutls
+MAKE_ENV+= GNUTLSINC=${LOCALBASE}/include GNUTLSLIB=${LOCALBASE}/lib \
+ without-ssl=1
+.elif defined(WITH_OPENSSL)
USE_OPENSSL= yes
+MAKE_ENV+= without-gnutls=1
+.else
+MAKE_ENV+= without-gnutls=1 without-ssl=1
+.endif
.endif
USE_BZIP2= yes
@@ -42,9 +63,14 @@ USE_GMAKE= yes
PLIST_SUB= PREFIX=${PREFIX}
.if defined(GKRELLM_SERVER_ONLY)
-PLIST_SUB+= CLIENT="@comment "
+PLIST_SUB+= CLIENT="@comment " NLS="@comment "
.else
PLIST_SUB+= CLIENT=""
+.if defined(WITHOUT_NLS)
+PLIST_SUB+= NLS="@comment "
+.else
+PLIST_SUB+= NLS=""
+.endif
#MAN1= gkrellm.1
.endif
MAN8= gkrellmd.8
diff --git a/sysutils/gkrellm2/distinfo b/sysutils/gkrellm2/distinfo
index 5cd948b3812e..358ececaac21 100644
--- a/sysutils/gkrellm2/distinfo
+++ b/sysutils/gkrellm2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gkrellm-2.2.5.tar.bz2) = 24e611ba74d0bfb6aad4e4c6153c859f
-SIZE (gkrellm-2.2.5.tar.bz2) = 668581
+MD5 (gkrellm-2.2.6.tar.bz2) = eda0bd5e71e9e09d58043f47cfdab566
+SIZE (gkrellm-2.2.6.tar.bz2) = 672074
diff --git a/sysutils/gkrellm2/files/patch-Makefile b/sysutils/gkrellm2/files/patch-Makefile
new file mode 100644
index 000000000000..967ba8562b63
--- /dev/null
+++ b/sysutils/gkrellm2/files/patch-Makefile
@@ -0,0 +1,13 @@
+Index: Makefile
+diff -u Makefile.orig Makefile
+--- Makefile.orig Fri May 13 23:56:35 2005
++++ Makefile Mon May 16 20:26:00 2005
+@@ -116,7 +116,7 @@
+ export MANDIR SMANDIR MANDIRMODE MANMODE
+ export OS_NAME OS_RELEASE
+
+-enable_nls=1
++enable_nls?=1
+ debug=0
+ export enable_nls
+ export debug
diff --git a/sysutils/gkrellm2/files/patch-src::configure b/sysutils/gkrellm2/files/patch-src::configure
new file mode 100644
index 000000000000..9518c7169f7c
--- /dev/null
+++ b/sysutils/gkrellm2/files/patch-src::configure
@@ -0,0 +1,26 @@
+Index: src/configure
+diff -u src/configure.orig src/configure
+--- src/configure.orig Tue May 10 03:54:30 2005
++++ src/configure Mon May 16 18:44:38 2005
+@@ -48,8 +48,8 @@
+ }
+ EOF
+
+-$CC ${PKG_INCLUDE} -c test.c -o test.o 2>& 5
+-$CC test.o -o test ${PKG_LIBS} -lgnutls-openssl 2>& 5
++$CC ${PKG_INCLUDE} -I${GNUTLSINC} -c test.c -o test.o 2>& 5
++$CC test.o -o test ${PKG_LIBS} -L${GNUTLSLIB} -lgnutls-openssl 2>& 5
+
+ if [ -e ./test ] && ./test
+ then
+@@ -88,8 +88,8 @@
+ }
+ EOF
+
+-$CC ${PKG_INCLUDE} -c test.c -o test.o 2>& 5
+-$CC test.o -o test ${PKG_LIBS} -lssl -lcrypto 2>& 5
++$CC ${PKG_INCLUDE} -I${OPENSSLINC} -c test.c -o test.o 2>& 5
++$CC test.o -o test ${PKG_LIBS} -L${OPENSSLLIB} -lssl -lcrypto 2>& 5
+
+ if [ -e ./test ] && ./test
+ then
diff --git a/sysutils/gkrellm2/files/patch-src:Makefile b/sysutils/gkrellm2/files/patch-src:Makefile
index d90a5289645d..80f8580d50f9 100644
--- a/sysutils/gkrellm2/files/patch-src:Makefile
+++ b/sysutils/gkrellm2/files/patch-src:Makefile
@@ -1,17 +1,30 @@
Index: src/Makefile
diff -u src/Makefile.orig src/Makefile
---- src/Makefile.orig Wed Dec 17 01:53:06 2003
-+++ src/Makefile Thu Dec 18 04:30:43 2003
-@@ -31,7 +31,7 @@
+--- src/Makefile.orig Tue May 10 01:54:03 2005
++++ src/Makefile Mon May 16 18:38:15 2005
+@@ -32,16 +32,18 @@
+ CONFIGURE_ARGS += --without-ssl
+ endif
+
+-DUMMY_VAR := $(shell ./configure $(CONFIGURE_ARGS))
++DUMMY_VAR := $(shell env OPENSSLINC=$(OPENSSLINC) OPENSSLLIB=$(OPENSSLLIB) \
++ GNUTLSINC=$(GNUTLSINC) GNUTLSLIB=$(GNUTLSLIB) \
++ ./configure $(CONFIGURE_ARGS))
+
+ HAVE_GNUTLS = $(shell grep -c HAVE_GNUTLS configure.h)
HAVE_SSL = $(shell grep -c HAVE_SSL configure.h)
+ ifeq ($(HAVE_GNUTLS),1)
+- SSL_LIBS ?= -lgnutls-openssl
++ SSL_LIBS ?= -L$(GNUTLSLIB) -lgnutls-openssl
+ else
ifeq ($(HAVE_SSL),1)
- SSL_LIBS ?= -lssl -lcrypto
+ SSL_LIBS ?= -L$(OPENSSLLIB) -lssl -lcrypto
else
EXTRAOBJS ?= md5c.o
endif
-@@ -45,8 +45,12 @@
+@@ -56,8 +58,16 @@
PKG_LIB = `$(PKG_CONFIG) --libs gtk+-2.0 gthread-2.0`
@@ -19,9 +32,13 @@ diff -u src/Makefile.orig src/Makefile
+FLAGS = -I.. $(PKG_INCLUDE) $(GTOP_INCLUDE)
FLAGS+= $(PTHREAD_INC)
+
++ifeq ($(HAVE_GNUTLS),1)
++ FLAGS+= -I$(GNUTLSINC)
++else
+ifeq ($(HAVE_SSL),1)
+ FLAGS+= -I$(OPENSSLINC)
+endif
++endif
LIBS = $(PKG_LIB) $(GTOP_LIBS) $(SMC_LIBS) $(SYS_LIBS) $(SSL_LIBS)
diff --git a/sysutils/gkrellm2/pkg-descr b/sysutils/gkrellm2/pkg-descr
index bff30ad18207..98588b0f55cb 100644
--- a/sysutils/gkrellm2/pkg-descr
+++ b/sysutils/gkrellm2/pkg-descr
@@ -1,46 +1,11 @@
GKrellM - GNU (or Gtk) Krell Monitors (or Meters)
-=======================================================================
-Author: Bill Wilson
-Email: bill@gkrellm.net
-WWW: http://gkrellm.net
-
-Copyright (c) 1999-2002 by Bill Wilson. This program is free software
-which I release under the GNU General Public License.
-Read the COPYRIGHT file for more info.
-
-
-Description
-===========
With a single process, GKrellM manages multiple stacked monitors and supports
applying themes to match the monitors appearance to your window manager,
Gtk, or any other theme.
-
-GKrellM Features
-================
- * SMP CPU, Disk, Proc, and active net interface monitors with LEDs.
- * Internet monitor that displays current and charts historical port hits.
- * Memory and swap space usage meters and a system uptime monitor.
- * File system meters show capacity/free space and can mount/umount.
- * A mbox/maildir/MH/POP3/IMAP mail monitor which can launch a mail reader
- or remote mail fetch program.
- * Clock/calendar and hostname display.
- * APM laptop battery monitor.
- * CPU/motherboard temperature/fan/voltages display if lm_sensors modules
- installed. Warnings and alarms can be set.
-
- * Multiple monitors managed by a single process to reduce system load.
- * A timer button that can execute PPP or ISDN logon/logoff scripts.
- * Charts are autoscaling with configurable grid line resolution, or
- can be set to a fixed scale mode.
- * Separate colors for "in" and "out" data. The in color is used for
- CPU user time, disk read, forks, and net receive data. The out color
- is used for CPU sys time, disk write, load, and net transmit data.
- * Commands can be configured to run when monitor labels are clicked.
- * GKrellM is plugin capable so special interest monitors can be created.
- * Data can be collected from a gkrellmd server running on a remote machine.
- * Many themes are available.
-
+Author: Bill Wilson
+Email: bill@gkrellm.net
+WWW: http://gkrellm.net
- Hajimu UMEMOTO <ume@FreeBSD.org>
diff --git a/sysutils/gkrellm2/pkg-plist b/sysutils/gkrellm2/pkg-plist
index ebb2786dedf7..af2c3563eb44 100644
--- a/sysutils/gkrellm2/pkg-plist
+++ b/sysutils/gkrellm2/pkg-plist
@@ -15,18 +15,18 @@ include/gkrellm2/gkrellmd.h
%%CLIENT%%@unexec rm -f %D/man/cat1/gkrellm.1 %D/man/cat1/gkrellm.1.gz
%%CLIENT%%bin/gkrellm
%%CLIENT%%libdata/pkgconfig/gkrellm.pc
-%%CLIENT%%share/locale/cs/LC_MESSAGES/gkrellm.mo
-%%CLIENT%%share/locale/da/LC_MESSAGES/gkrellm.mo
-%%CLIENT%%share/locale/de/LC_MESSAGES/gkrellm.mo
-%%CLIENT%%share/locale/es/LC_MESSAGES/gkrellm.mo
-%%CLIENT%%share/locale/fr/LC_MESSAGES/gkrellm.mo
-%%CLIENT%%share/locale/it/LC_MESSAGES/gkrellm.mo
-%%CLIENT%%share/locale/ja/LC_MESSAGES/gkrellm.mo
-%%CLIENT%%share/locale/nl/LC_MESSAGES/gkrellm.mo
-%%CLIENT%%share/locale/pl/LC_MESSAGES/gkrellm.mo
-%%CLIENT%%share/locale/ru/LC_MESSAGES/gkrellm.mo
-%%CLIENT%%share/locale/sl/LC_MESSAGES/gkrellm.mo
-%%CLIENT%%share/locale/sv/LC_MESSAGES/gkrellm.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/gkrellm.mo
+%%NLS%%share/locale/da/LC_MESSAGES/gkrellm.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gkrellm.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gkrellm.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gkrellm.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gkrellm.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/gkrellm.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/gkrellm.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gkrellm.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gkrellm.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/gkrellm.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gkrellm.mo
%%CLIENT%%@exec mkdir -p %D/libexec/gkrellm2/plugins
%%CLIENT%%@exec mkdir -p %D/share/gkrellm2/themes
%%CLIENT%%@unexec rmdir %D/libexec/gkrellm2/plugins 2>/dev/null || true