aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-02 20:16:56 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-02 20:16:56 +0000
commit9934e8faa6c48b2f421dfa88ac11fca24f77af07 (patch)
tree328a0f4b8ac074407e9ead12246698b446e1aa5c /sysutils
parent532767070b62938428b8536c0c176861c21c92c1 (diff)
downloadports-9934e8faa6c48b2f421dfa88ac11fca24f77af07.tar.gz
ports-9934e8faa6c48b2f421dfa88ac11fca24f77af07.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/portindex/Makefile47
-rw-r--r--sysutils/portindex/distinfo2
-rw-r--r--sysutils/portindex/pkg-descr15
4 files changed, 65 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 94dccc12814b..b0ae6d36e0f3 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -300,6 +300,7 @@
SUBDIR += port-authoring-tools
SUBDIR += port-maintenance-tools
SUBDIR += portdowngrade
+ SUBDIR += portindex
SUBDIR += portsman
SUBDIR += portupgrade
SUBDIR += powerman
diff --git a/sysutils/portindex/Makefile b/sysutils/portindex/Makefile
new file mode 100644
index 000000000000..2ceb83ba229c
--- /dev/null
+++ b/sysutils/portindex/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: portindex
+# Date created: 1 Jul 2004
+# Whom: Radim Kolar
+#
+# $FreeBSD$
+#
+
+PORTNAME= portindex
+PORTVERSION= 11
+CATEGORIES= sysutils
+MASTER_SITES= http://home.tiscali.cz/~cz210552/distfiles/
+DISTNAME= bsdportsutils-${PORTVERSION}
+
+MAINTAINER= hsn@netmag.cz
+COMMENT= Incremental ports INDEX file builder
+
+USE_PYTHON= yes
+NO_WRKSUBDIR= yes
+USE_REINPLACE= yes
+
+PORTDOCS= *.TXT
+PLIST_FILES= bin/portreadmes bin/portindex
+PLIST_DIRS= share/${PORTNAME}
+
+SOURCES= bsdpkg freebsdports indexer minorupdates updateall updatereadmes
+
+.for i in ${SOURCES}
+PLIST_FILES+= share/${PORTNAME}/${i}.py
+PLIST_FILES+= share/${PORTNAME}/${i}.pyc
+.endfor
+
+do-build:
+ ${REINPLACE_CMD} -e "s,ports.pck,/var/db/portindex.pck," ${WRKSRC}/freebsdports.py
+ ${SED} -e "s,%%DATADIR%%,${DATADIR}," ${FILESDIR}/portindex.sh > ${WRKSRC}/portindex
+ ${SED} -e "s,%%DATADIR%%,${DATADIR}," ${FILESDIR}/portreadmes.sh > ${WRKSRC}/portreadmes
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.py ${DATADIR}
+ ${PYTHON_CMD} -c "import compileall;compileall.compile_dir('${DATADIR}')"
+ ${INSTALL_SCRIPT} ${WRKSRC}/portindex ${WRKSRC}/portreadmes ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.TXT ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/portindex/distinfo b/sysutils/portindex/distinfo
new file mode 100644
index 000000000000..f48a41773f0d
--- /dev/null
+++ b/sysutils/portindex/distinfo
@@ -0,0 +1,2 @@
+MD5 (bsdportsutils-11.tar.gz) = 22545b9a88c04120562a36aa6e60faa5
+SIZE (bsdportsutils-11.tar.gz) = 8320
diff --git a/sysutils/portindex/pkg-descr b/sysutils/portindex/pkg-descr
new file mode 100644
index 000000000000..5d6ce02784df
--- /dev/null
+++ b/sysutils/portindex/pkg-descr
@@ -0,0 +1,15 @@
+Alternative /usr/ports/INDEX file builder.
+
+Features
+
+1. You do not need to wait 1 hour after every cvsup for make index to finish.
+ This program supports incremental index builds.
+2. Supports indexing of incomplete ports trees.
+3. Dependences between ports (including multiple) are correctly tracked.
+ tracking is done by .include hunting
+4. Dependences on /usr/port/Mk/* are tracked
+5. Dependences on /var/db/ports are tracked
+6. Dependences on Makefile.local are tracked
+7. No known difference between make index and this program
+
+WWW: http://home.tiscali.cz/~cz210552/bsdportsutils.html