aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
commit5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /sysutils
parent9c92503171817f96d944009b9ea88d3c083c9a45 (diff)
downloadports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.tar.gz
ports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Notes
Notes: svn path=/head/; revision=444324
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/baloo/Makefile2
-rw-r--r--sysutils/conky/Makefile2
-rw-r--r--sysutils/fluent-bit/Makefile2
-rw-r--r--sysutils/kcm-polkit-kde/Makefile2
-rw-r--r--sysutils/osquery/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/sysutils/baloo/Makefile b/sysutils/baloo/Makefile
index 081273dcd431..4d3b4ce3d9ae 100644
--- a/sysutils/baloo/Makefile
+++ b/sysutils/baloo/Makefile
@@ -14,7 +14,7 @@ CONFLICTS_INSTALL= kde-runtime-4.12.* \
LIB_DEPENDS= libxapian.so:databases/xapian-core \
libqjson.so:devel/qjson
-USES= cmake:outsource gmake kde:4 tar:xz
+USES= cmake:outsource kde:4 tar:xz
USE_KDE= akonadi automoc4 kdelibs kfilemetadata \
pimlibs
USE_QT4= corelib qmake_build moc_build rcc_build uic_build
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index 9b107a0087d4..47dc203ce48b 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= db2x_xsltproc:textproc/docbook2X \
CONFLICTS?= conky-awesome-[0-9]*
SLAVEDIRS= sysutils/conky-awesome
-USES= cpe cmake compiler:c++11-lib gettext-runtime iconv \
+USES= cpe cmake:noninja compiler:c++11-lib gettext-runtime iconv \
localbase lua:51 pkgconfig tar:bzip2
CMAKE_ARGS+= -DBUILD_PORT_MONITORS:BOOL=false \
-DBUILD_IBM:BOOL=false \
diff --git a/sysutils/fluent-bit/Makefile b/sysutils/fluent-bit/Makefile
index 9b99ea9b6bfb..e4fb7dcc30e4 100644
--- a/sysutils/fluent-bit/Makefile
+++ b/sysutils/fluent-bit/Makefile
@@ -17,7 +17,7 @@ BROKEN_mips= fails to build: conflicting types for 'restrict'
BROKEN_mips64= fails to build: conflicting types for 'restrict'
BROKEN_powerpc64= fails to build: cast from pointer to integer of different size
-USES= cmake
+USES= cmake:noninja
USE_RC_SUBR= ${PORTNAME}
diff --git a/sysutils/kcm-polkit-kde/Makefile b/sysutils/kcm-polkit-kde/Makefile
index 1dae28b54cb0..b65cce24bd30 100644
--- a/sysutils/kcm-polkit-kde/Makefile
+++ b/sysutils/kcm-polkit-kde/Makefile
@@ -14,7 +14,7 @@ COMMENT= Polkit-KDE configuration module
LIB_DEPENDS= libpolkit-qt-agent-1.so:sysutils/polkit-qt
RUN_DEPENDS= ${KDE_PREFIX}/lib/kde4/libexec/polkit-kde-authentication-agent-1:sysutils/polkit-kde
-USES= cmake gmake kde:4 pkgconfig tar:bzip2
+USES= cmake kde:4 pkgconfig tar:bzip2
USE_KDE= kdelibs automoc4
USE_QT4= dbus xml moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/sysutils/osquery/Makefile b/sysutils/osquery/Makefile
index e29294f33451..f47671a13823 100644
--- a/sysutils/osquery/Makefile
+++ b/sysutils/osquery/Makefile
@@ -29,7 +29,7 @@ LIB_DEPENDS= libaugeas.so:textproc/augeas \
libzstd.so:archivers/zstd
RUN_DEPENDS= ca_root_nss>0:security/ca_root_nss
-USES= cmake:outsource gmake libtool python:build compiler:c++11-lib \
+USES= cmake:outsource libtool python:build compiler:c++11-lib \
libarchive ssl
USE_GNOME= libxml2
CONFIGURE_ENV+= OSQUERY_BUILD_VERSION="${PORTVERSION}" HOME="${WRKDIR}" \