aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2017-06-25 20:02:56 +0000
committerMark Linimon <linimon@FreeBSD.org>2017-06-25 20:02:56 +0000
commitad1dcffa93bab7aa6eaeb7b3ec7d1db667fcdcb5 (patch)
tree14ba3670b1138651d771f63e510d2abd2e9ea5a0 /sysutils
parenta906c61978a8ca59d25b7b1224fed53b50e78c4f (diff)
downloadports-ad1dcffa93bab7aa6eaeb7b3ec7d1db667fcdcb5.tar.gz
ports-ad1dcffa93bab7aa6eaeb7b3ec7d1db667fcdcb5.zip
This program boots an i.MX or Vybrid system using a copy of U-Boot
transferred to the system over an OTG or UART connection. It can be used to "unbrick" a system which has a corrupted or missing copy of U-Boot in nonvolatile media such as nand flash or eeprom. i.MX systems use the OTG port, Vybrid systems use the UART port. To use this, connect the OTG port of your i.MX board to a USB host port on your computer, power on the board, then run imx_usb <filename> where filename is the board-specific u-boot.imx file to boot with. WWW: https://github.com/boundarydevices/imx_usb_loader PR: 220260 Submitted by: ian
Notes
Notes: svn path=/head/; revision=444322
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/u-boot-imx-serial-loader/Makefile22
-rw-r--r--sysutils/u-boot-imx-serial-loader/distinfo3
-rw-r--r--sysutils/u-boot-imx-serial-loader/pkg-descr11
-rw-r--r--sysutils/u-boot-imx-serial-loader/pkg-plist9
5 files changed, 46 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 5b8278b70517..ab56d5d32363 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1173,6 +1173,7 @@
SUBDIR += u-boot-cubieboard2
SUBDIR += u-boot-cubox-hummingboard
SUBDIR += u-boot-duovero
+ SUBDIR += u-boot-imx-serial-loader
SUBDIR += u-boot-master
SUBDIR += u-boot-olimex-a20-som-evb
SUBDIR += u-boot-olinuxino-lime
diff --git a/sysutils/u-boot-imx-serial-loader/Makefile b/sysutils/u-boot-imx-serial-loader/Makefile
new file mode 100644
index 000000000000..9b168aa059e7
--- /dev/null
+++ b/sysutils/u-boot-imx-serial-loader/Makefile
@@ -0,0 +1,22 @@
+# Created by: Ian Lepore <ian@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= u-boot-imx-serial-loader
+PORTVERSION= 2017.01
+CATEGORIES= sysutils
+
+MAINTAINER= ian@FreeBSD.org
+COMMENT= Load u-boot via USB or UART on i.MX5, i.MX6, i.MX7, and Vybrid
+
+LICENSE= LGPL21
+
+USE_GITHUB= yes
+GH_ACCOUNT= boundarydevices
+GH_PROJECT= imx_usb_loader
+GH_TAGNAME= ba6b31c
+
+USES= gmake pkgconfig
+
+MAKE_ARGS+= prefix=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/sysutils/u-boot-imx-serial-loader/distinfo b/sysutils/u-boot-imx-serial-loader/distinfo
new file mode 100644
index 000000000000..1c14413126f0
--- /dev/null
+++ b/sysutils/u-boot-imx-serial-loader/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1498334706
+SHA256 (boundarydevices-imx_usb_loader-2017.01-ba6b31c_GH0.tar.gz) = a4bc518e4ddcb6e63ec6267d7e936d4099ded0af911c96f249060d208b14fa11
+SIZE (boundarydevices-imx_usb_loader-2017.01-ba6b31c_GH0.tar.gz) = 37621
diff --git a/sysutils/u-boot-imx-serial-loader/pkg-descr b/sysutils/u-boot-imx-serial-loader/pkg-descr
new file mode 100644
index 000000000000..12658a59df92
--- /dev/null
+++ b/sysutils/u-boot-imx-serial-loader/pkg-descr
@@ -0,0 +1,11 @@
+This program boots an i.MX or Vybrid system using a copy of U-Boot
+transferred to the system over an OTG or UART connection. It can be
+used to "unbrick" a system which has a corrupted or missing copy of
+U-Boot in nonvolatile media such as nand flash or eeprom. i.MX systems
+use the OTG port, Vybrid systems use the UART port.
+
+To use this, connect the OTG port of your i.MX board to a USB host
+port on your computer, power on the board, then run imx_usb <filename>
+where filename is the board-specific u-boot.imx file to boot with.
+
+WWW: https://github.com/boundarydevices/imx_usb_loader
diff --git a/sysutils/u-boot-imx-serial-loader/pkg-plist b/sysutils/u-boot-imx-serial-loader/pkg-plist
new file mode 100644
index 000000000000..e8e229e78183
--- /dev/null
+++ b/sysutils/u-boot-imx-serial-loader/pkg-plist
@@ -0,0 +1,9 @@
+bin/imx_uart
+bin/imx_usb
+etc/imx-loader.d/imx_usb.conf
+etc/imx-loader.d/mx50_usb_work.conf
+etc/imx-loader.d/mx51_usb_work.conf
+etc/imx-loader.d/mx53_usb_work.conf
+etc/imx-loader.d/mx6_usb_work.conf
+etc/imx-loader.d/mx7_usb_work.conf
+etc/imx-loader.d/vybrid_usb_work.conf