aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-07-01 14:14:22 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-07-01 14:14:22 +0000
commit425d0841bbbe9000a2e034a2621aec80f8745545 (patch)
tree50f7b396ab46973b5abff69840bcfac563f48e4f /sysutils
parent9a64c214d0741524430c072a6b24079f60cfa0ff (diff)
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/munin-master/Makefile38
-rw-r--r--sysutils/munin-node/Makefile20
-rw-r--r--sysutils/userneu-devel/Makefile4
3 files changed, 31 insertions, 31 deletions
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index 1021f74878f8..5e70e0f06394 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -15,25 +15,25 @@ PKGNAMESUFFIX= -master
MAINTAINER= flo@FreeBSD.org
COMMENT= Collector part of Munin
-BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
- ${SITE_PERL}/Munin/Common/Defaults.pm:${PORTSDIR}/sysutils/munin-common \
- ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
- ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
- ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/DateTime/HiRes.pm:${PORTSDIR}/devel/p5-DateTime-HiRes \
- ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
- ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
- ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl \
- ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced
-RUN_DEPENDS= ${SITE_PERL}/Munin/Common/Defaults.pm:${PORTSDIR}/sysutils/munin-common \
- ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/databases/rrdtool \
- ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
- ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/DateTime/HiRes.pm:${PORTSDIR}/devel/p5-DateTime-HiRes \
- ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
- ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
- ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl \
- ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced
+BUILD_DEPENDS= p5-Module-Build>=0:${PORTSDIR}/devel/p5-Module-Build \
+ munin-common>=0:${PORTSDIR}/sysutils/munin-common \
+ p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
+ rrdtool>=0:${PORTSDIR}/databases/rrdtool \
+ p5-Storable>=0:${PORTSDIR}/devel/p5-Storable \
+ p5-DateTime-HiRes>=0:${PORTSDIR}/devel/p5-DateTime-HiRes \
+ p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long \
+ p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Text-Balanced>=0:${PORTSDIR}/textproc/p5-Text-Balanced
+RUN_DEPENDS= munin-common>=0:${PORTSDIR}/sysutils/munin-common \
+ rrdtool>=0:${PORTSDIR}/databases/rrdtool \
+ p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
+ p5-Storable>=0:${PORTSDIR}/devel/p5-Storable \
+ p5-DateTime-HiRes>=0:${PORTSDIR}/devel/p5-DateTime-HiRes \
+ p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long \
+ p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Text-Balanced>=0:${PORTSDIR}/textproc/p5-Text-Balanced
USE_PERL5= yes
USE_GMAKE= yes
diff --git a/sysutils/munin-node/Makefile b/sysutils/munin-node/Makefile
index 06f139231ab0..d52d58514f81 100644
--- a/sysutils/munin-node/Makefile
+++ b/sysutils/munin-node/Makefile
@@ -14,17 +14,17 @@ PKGNAMESUFFIX= -node
MAINTAINER= flo@FreeBSD.org
COMMENT= Node-specific part of Munin
-BUILD_DEPENDS= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build \
- ${SITE_PERL}/DateTime/HiRes.pm:${PORTSDIR}/devel/p5-DateTime-HiRes \
- ${SITE_PERL}/Munin/Common/Defaults.pm:${PORTSDIR}/sysutils/munin-common \
- ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
- ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
+BUILD_DEPENDS= p5-Module-Build>=0:${PORTSDIR}/devel/p5-Module-Build \
+ p5-DateTime-HiRes>=0:${PORTSDIR}/devel/p5-DateTime-HiRes \
+ munin-common>=0:${PORTSDIR}/sysutils/munin-common \
+ p5-Net-Server>=0:${PORTSDIR}/net/p5-Net-Server \
+ p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
bash:${PORTSDIR}/shells/bash
-RUN_DEPENDS= ${SITE_PERL}/Cache/Cache.pm:${PORTSDIR}/devel/p5-Cache-Cache \
- ${SITE_PERL}/DateTime/HiRes.pm:${PORTSDIR}/devel/p5-DateTime-HiRes \
- ${SITE_PERL}/Munin/Common/Defaults.pm:${PORTSDIR}/sysutils/munin-common \
- ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
- ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
+RUN_DEPENDS= p5-Cache-Cache>=0:${PORTSDIR}/devel/p5-Cache-Cache \
+ p5-DateTime-HiRes>=0:${PORTSDIR}/devel/p5-DateTime-HiRes \
+ munin-common>=0:${PORTSDIR}/sysutils/munin-common \
+ p5-Net-Server>=0:${PORTSDIR}/net/p5-Net-Server \
+ p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
bash:${PORTSDIR}/shells/bash
USE_PERL5= yes
diff --git a/sysutils/userneu-devel/Makefile b/sysutils/userneu-devel/Makefile
index e497d7627ec6..725729d8cd5a 100644
--- a/sysutils/userneu-devel/Makefile
+++ b/sysutils/userneu-devel/Makefile
@@ -19,8 +19,8 @@ MAINTAINER= fehlner@gmx.de
COMMENT= Account management and creation tool
RUN_DEPENDS= \
- ${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5/ \
- ${SITE_PERL}/Crypt/RandPasswd.pm:${PORTSDIR}/security/p5-Crypt-RandPasswd/
+ p5-Crypt-PasswdMD5>=0:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
+ p5-Crypt-RandPasswd>=0:${PORTSDIR}/security/p5-Crypt-RandPasswd
USE_PERL5_RUN= yes
NO_BUILD= yes