aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-01-13 15:42:55 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-01-13 15:42:55 +0000
commit56a22e7a5698df5c030943565a0fb11d45acef76 (patch)
tree45eb166e08c478cc8fd678bb4bf31c894b73bb45 /sysutils
parentdd78d99ddfcbda37d7fcd8a0b3fcf479f7be19df (diff)
downloadports-56a22e7a5698df5c030943565a0fb11d45acef76.tar.gz
ports-56a22e7a5698df5c030943565a0fb11d45acef76.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/dupmerge/Makefile33
-rw-r--r--sysutils/dupmerge/distinfo3
-rw-r--r--sysutils/dupmerge/files/patch-dupmerge.c10
-rw-r--r--sysutils/dupmerge/pkg-descr6
5 files changed, 53 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 37ecc096abb9..549e3c7de9b3 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -161,6 +161,7 @@
SUBDIR += dump9660
SUBDIR += dupfind
SUBDIR += duplicity
+ SUBDIR += dupmerge
SUBDIR += durep
SUBDIR += dvd+rw-tools
SUBDIR += dvdbackup
diff --git a/sysutils/dupmerge/Makefile b/sysutils/dupmerge/Makefile
new file mode 100644
index 000000000000..db86565159e9
--- /dev/null
+++ b/sysutils/dupmerge/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: dupmerge
+# Date created: 12 Jan 2009
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= dupmerge
+PORTVERSION= 1.73
+CATEGORIES= sysutils
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Searches for files with equal content
+
+USE_ZIP= yes
+MAKE_FLAGS=
+MAKEFILE=
+LDFLAGS+= -lroken -lcrypt
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+ALL_TARGET= dupmerge
+PLIST_FILES= bin/dupmerge
+PORTDOCS= readme.txt
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dupmerge ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/dupmerge/distinfo b/sysutils/dupmerge/distinfo
new file mode 100644
index 000000000000..63c3ce6c8da9
--- /dev/null
+++ b/sysutils/dupmerge/distinfo
@@ -0,0 +1,3 @@
+MD5 (dupmerge_1.73.zip) = 0c50ce2877be34ced391ec32b30324a6
+SHA256 (dupmerge_1.73.zip) = c8bea34351b12f9aa053298c3b6555f89aa7d4a2f6ad97ac8782a16ffeea4386
+SIZE (dupmerge_1.73.zip) = 25107
diff --git a/sysutils/dupmerge/files/patch-dupmerge.c b/sysutils/dupmerge/files/patch-dupmerge.c
new file mode 100644
index 000000000000..8c226c5f4de1
--- /dev/null
+++ b/sysutils/dupmerge/files/patch-dupmerge.c
@@ -0,0 +1,10 @@
+--- dupmerge.c.orig 2008-03-01 17:46:41.000000000 +0100
++++ dupmerge.c 2009-01-13 15:15:07.000000000 +0100
+@@ -125,6 +125,7 @@
+ #include <sys/wait.h> // vfork
+ #include <time.h> // localtime
+
++#include <roken.h>
+
+ #define mc_MIN(a, b) ((a) < (b) ? (a) : (b))
+ #define mc_MAX(a, b) ((a) > (b) ? (a) : (b))
diff --git a/sysutils/dupmerge/pkg-descr b/sysutils/dupmerge/pkg-descr
new file mode 100644
index 000000000000..97c221edca04
--- /dev/null
+++ b/sysutils/dupmerge/pkg-descr
@@ -0,0 +1,6 @@
+Dupmerge reads a list of files from standard input (eg., as produced by
+"find . -print") and looks securely for identical files. When it finds
+two or more identical files, all but one are unlinked to reclaim the
+disk space and recreated as hard links to the remaining copy.
+
+WWW: http://sourceforge.net/projects/dupmerge