aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorJeremy Chadwick <koitsu@FreeBSD.org>2008-08-28 12:06:21 +0000
committerJeremy Chadwick <koitsu@FreeBSD.org>2008-08-28 12:06:21 +0000
commit11e7c7e8e8768f191452f04d980281860f66ad55 (patch)
tree413d2f0d92ca433fd5d4bf8589943b3a00b87aa9 /sysutils
parente65a34d9ca72e4cf4f35ab059ce792747a59233d (diff)
downloadports-11e7c7e8e8768f191452f04d980281860f66ad55.tar.gz
ports-11e7c7e8e8768f191452f04d980281860f66ad55.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/coreutils/Makefile8
-rw-r--r--sysutils/coreutils/files/extra-patch-stty.c16
2 files changed, 23 insertions, 1 deletions
diff --git a/sysutils/coreutils/Makefile b/sysutils/coreutils/Makefile
index 5d1bd0397d40..dbee798a8611 100644
--- a/sysutils/coreutils/Makefile
+++ b/sysutils/coreutils/Makefile
@@ -50,6 +50,12 @@ MAN1= gbasename.1 gcat.1 gchgrp.1 gchmod.1 gchown.1 gchroot.1 gcksum.1 \
gwc.1 gwho.1 gwhoami.1 gyes.1 gbase64.1 gsha224sum.1 gsha256sum.1 \
gsha384sum.1 gsha512sum.1 gshuf.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800000
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-stty.c
+.endif
+
post-patch:
.if !defined(WITH_SUID)
@${REINPLACE_CMD} -e "s/u\+s/u\+w/g" ${WRKSRC}/src/Makefile.in
@@ -61,4 +67,4 @@ post-build:
regression-test: build
(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} check)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/coreutils/files/extra-patch-stty.c b/sysutils/coreutils/files/extra-patch-stty.c
new file mode 100644
index 000000000000..8734e33e9665
--- /dev/null
+++ b/sysutils/coreutils/files/extra-patch-stty.c
@@ -0,0 +1,16 @@
+--- src/stty.c.orig 2007-03-18 14:36:43.000000000 -0700
++++ src/stty.c 2008-08-28 04:43:28.000000000 -0700
+@@ -45,6 +45,13 @@
+ #endif
+ #ifdef HAVE_SYS_IOCTL_H
+ # include <sys/ioctl.h>
++/*
++ * XXX - Workaround for missing TAB1 and TAB2 bits on 8.0-CURRENT;
++ * available in src/ioctl_compat.h, only when _KERNEL is defined.
++ */
++# define _KERNEL
++# include <sys/ioctl_compat.h>
++# undef _KERNEL
+ #endif
+
+ #ifdef WINSIZE_IN_PTEM