aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2016-09-24 16:46:14 +0000
committerRene Ladan <rene@FreeBSD.org>2016-09-24 16:46:14 +0000
commit1def5973eae49272de0737590acdfc1217dcaada (patch)
tree574a210812133c38109f89669edbc552cd77fa4c /sysutils
parentffb03aad02949f64b64e0a3c106d3a7d81c68c22 (diff)
downloadports-1def5973eae49272de0737590acdfc1217dcaada.tar.gz
ports-1def5973eae49272de0737590acdfc1217dcaada.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-scandir/Makefile24
-rw-r--r--sysutils/py-scandir/distinfo3
-rw-r--r--sysutils/py-scandir/pkg-descr14
4 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 9bf519d4fcfd..fe9a2eececcb 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -859,6 +859,7 @@
SUBDIR += py-queuelib
SUBDIR += py-ranger
SUBDIR += py-salt
+ SUBDIR += py-scandir
SUBDIR += py-shutilwhich
SUBDIR += py-stdiff
SUBDIR += py-supervisor
diff --git a/sysutils/py-scandir/Makefile b/sysutils/py-scandir/Makefile
new file mode 100644
index 000000000000..fe3572e5d587
--- /dev/null
+++ b/sysutils/py-scandir/Makefile
@@ -0,0 +1,24 @@
+# Created by: René Ladan <rene@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= scandir
+PORTVERSION= 1.2
+DISTVERSIONPREFIX= v
+CATEGORIES= sysutils python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rene@FreeBSD.org
+COMMENT= Fast and featureful directory iterator
+
+LICENSE= BSD3CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= benhoyt
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+do-test:
+ ${PYTHON_CMD} ${WRKSRC}/test/run_tests.py
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-scandir/distinfo b/sysutils/py-scandir/distinfo
new file mode 100644
index 000000000000..8efcbf583eec
--- /dev/null
+++ b/sysutils/py-scandir/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474734547
+SHA256 (benhoyt-scandir-v1.2_GH0.tar.gz) = 993b8a04092b2c528e50a62d6ec7f099f7d91a92c00fafc0b74897009e0169c3
+SIZE (benhoyt-scandir-v1.2_GH0.tar.gz) = 27869
diff --git a/sysutils/py-scandir/pkg-descr b/sysutils/py-scandir/pkg-descr
new file mode 100644
index 000000000000..3d3fea41ebfc
--- /dev/null
+++ b/sysutils/py-scandir/pkg-descr
@@ -0,0 +1,14 @@
+scandir, a better directory iterator and faster os.walk()
+
+scandir() is a generator version of os.listdir() that returns an iterator
+over files in a directory, and also exposes the extra information most
+operating systems provide while iterating files in a directory (such as
+type and stat information).
+
+This module also includes a version of os.walk() that uses scandir()
+to speed it up significantly.
+
+NOTE: If you're using Python version 3.5+, os.scandir() and the speed
+improvements to os.walk() are already available in the standard library.
+
+WWW: https://github.com/benhoyt/scandir