aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-11 21:19:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-11 21:19:35 +0000
commit2d0160e922c9a559e29c7ae40d54e3b62cf39cb5 (patch)
tree02b8a33dc4b8f3fcbcab48bc0839fa56c940e2b9 /sysutils
parent481dd0dd7bf7eea0eb1851a4c62baa927c43c9a1 (diff)
downloadports-2d0160e922c9a559e29c7ae40d54e3b62cf39cb5.tar.gz
ports-2d0160e922c9a559e29c7ae40d54e3b62cf39cb5.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/xfce4-battery-plugin/Makefile2
-rw-r--r--sysutils/xfce4-battery-plugin/files/patch-panel-plug-battery.c22
2 files changed, 17 insertions, 7 deletions
diff --git a/sysutils/xfce4-battery-plugin/Makefile b/sysutils/xfce4-battery-plugin/Makefile
index 98b79d45908f..d902a90f2841 100644
--- a/sysutils/xfce4-battery-plugin/Makefile
+++ b/sysutils/xfce4-battery-plugin/Makefile
@@ -14,7 +14,7 @@ DIST_SUBDIR= xfce4
MAINTAINER= miwi@FreeBSD.org
COMMENT= Battery monitor panel plugin for XFce4
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
GNU_CONFIGURE= yes
USE_BZIP2= yes
diff --git a/sysutils/xfce4-battery-plugin/files/patch-panel-plug-battery.c b/sysutils/xfce4-battery-plugin/files/patch-panel-plug-battery.c
index 21b41948ca42..e3b9a4b423ee 100644
--- a/sysutils/xfce4-battery-plugin/files/patch-panel-plug-battery.c
+++ b/sysutils/xfce4-battery-plugin/files/patch-panel-plug-battery.c
@@ -1,6 +1,16 @@
---- panel-plugin/battery.c.orgi 2008-09-04 22:53:40.000000000 +0200
-+++ panel-plugin/battery.c 2008-09-05 10:02:08.000000000 +0200
-@@ -163,7 +163,9 @@
+--- panel-plugin/battery.c.orig 2008-09-04 17:53:40.000000000 -0300
++++ panel-plugin/battery.c 2008-09-10 21:53:56.000000000 -0300
+@@ -26,7 +26,9 @@
+ #endif
+
+ #if defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
++#if defined(__i386___)
+ #include <machine/apm_bios.h>
++#endif
+ #elif __OpenBSD__
+ #include <sys/param.h>
+ #include <machine/apmvar.h>
+@@ -163,7 +165,9 @@
except that is does not work on FreeBSD
*/
@@ -10,7 +20,7 @@
int fd;
/* First check to see if ACPI is available */
-@@ -310,7 +312,9 @@
+@@ -310,7 +314,9 @@
acline = apm.ac_state ? TRUE : FALSE;
#else
@@ -21,7 +31,7 @@
DBG ("Updating battery status...");
if(battmon->method == BM_BROKEN) {
-@@ -382,6 +386,7 @@
+@@ -382,6 +388,7 @@
rate = last_rate;
}
@@ -29,7 +39,7 @@
charge = (((float)ccapacity)/((float)lcapacity))*100;
if ( last_acline )
-@@ -394,6 +399,17 @@
+@@ -394,6 +401,17 @@
last_acline = acline;