aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorCraig Rodrigues <rodrigc@FreeBSD.org>2006-07-10 02:05:51 +0000
committerCraig Rodrigues <rodrigc@FreeBSD.org>2006-07-10 02:05:51 +0000
commit5301980440194d119d187371ae8a73c50e18b9b3 (patch)
tree9b1208d5bb06cbcdaa1aaa1a96e0733ced9ec28f /sysutils
parent4089794160605cf6d03574e0e27ddac5416dd246 (diff)
downloadports-5301980440194d119d187371ae8a73c50e18b9b3.tar.gz
ports-5301980440194d119d187371ae8a73c50e18b9b3.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/xfsprogs/Makefile11
-rw-r--r--sysutils/xfsprogs/distinfo6
-rw-r--r--sysutils/xfsprogs/files/patch-freebsd.h51
-rw-r--r--sysutils/xfsprogs/files/patch-log_misc.c20
-rw-r--r--sysutils/xfsprogs/files/patch-report.c10
-rw-r--r--sysutils/xfsprogs/pkg-plist2
6 files changed, 32 insertions, 68 deletions
diff --git a/sysutils/xfsprogs/Makefile b/sysutils/xfsprogs/Makefile
index e557f79645cf..47456505d9ff 100644
--- a/sysutils/xfsprogs/Makefile
+++ b/sysutils/xfsprogs/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= xfsprogs
-PORTVERSION= 2.7.11
-PORTREVISION= 2
+PORTVERSION= 2.8.4
CATEGORIES= sysutils
MASTER_SITES= ftp://oss.sgi.com/projects/xfs/cmd_tars/
-DISTNAME= ${PORTNAME}-${PORTVERSION}
-EXTRACT_SUFX= .src.tar.gz
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+EXTRACT_SUFX= -1.tar.gz
MAINTAINER= rodrigc@FreeBSD.ORG
COMMENT= A set of utilities and library to manipulate an xfs filesystem
@@ -39,6 +38,10 @@ MAN8= fsck.xfs.8 mkfs.xfs.8 xfs_admin.8 xfs_bmap.8 xfs_check.8 \
BROKEN= "Does not compile on FreeBSD 4.x"
.endif
+post-extract:
+ echo "Blah"
+ ${LN} -sf ${WRKDIR}/${PORTNAME}-${PORTVERSION} ${WRKSRC}
+
pre-configure:
${RM} -f ${WRKSRC}/configure
diff --git a/sysutils/xfsprogs/distinfo b/sysutils/xfsprogs/distinfo
index 00140cce1921..236d1e7a7ef7 100644
--- a/sysutils/xfsprogs/distinfo
+++ b/sysutils/xfsprogs/distinfo
@@ -1,3 +1,3 @@
-MD5 (xfsprogs-2.7.11.src.tar.gz) = d4a78fced98c0f3f32627a473e8e0a59
-SHA256 (xfsprogs-2.7.11.src.tar.gz) = 011740a254dedcaa7109c3337945a4b95296831ef1c98ec48f6eda6d268ed95f
-SIZE (xfsprogs-2.7.11.src.tar.gz) = 878186
+MD5 (xfsprogs_2.8.4-1.tar.gz) = 4699d6e27acc21911b63696bf1df9949
+SHA256 (xfsprogs_2.8.4-1.tar.gz) = bb72f2174e75d3643a833b12d0a08357c4203bea9f44dda16ece8663d170863d
+SIZE (xfsprogs_2.8.4-1.tar.gz) = 948848
diff --git a/sysutils/xfsprogs/files/patch-freebsd.h b/sysutils/xfsprogs/files/patch-freebsd.h
deleted file mode 100644
index 963f5074602c..000000000000
--- a/sysutils/xfsprogs/files/patch-freebsd.h
+++ /dev/null
@@ -1,51 +0,0 @@
---- include/freebsd.h.orig Mon Jan 16 22:46:48 2006
-+++ include/freebsd.h Sat May 27 08:57:20 2006
-@@ -27,7 +27,13 @@
- #include <paths.h>
- #include <uuid.h>
-
--#include <machine/endian.h>
-+#include <sys/endian.h>
-+#define __BYTE_ORDER BYTE_ORDER
-+#define __BIG_ENDIAN BIG_ENDIAN
-+#define __LITTLE_ENDIAN LITTLE_ENDIAN
-+#define __swab16(x) bswap16(x)
-+#define __swab32(x) bswap32(x)
-+#define __swab64(x) bswap64(x)
-
- /* FreeBSD file API is 64-bit aware */
- #define fstat64 fstat
-@@ -39,15 +45,6 @@
- #define fdatasync fsync
- #define memalign(a,size) valloc(size)
-
--typedef u_int8_t __u8;
--typedef int8_t __s8;
--typedef u_int16_t __u16;
--typedef int16_t __s16;
--typedef u_int32_t __u32;
--typedef int32_t __s32;
--typedef u_int64_t __u64;
--typedef int64_t __s64;
--
- #define constpp char * const *
-
- #define EFSCORRUPTED 990 /* Filesystem is corrupted */
-@@ -84,7 +81,7 @@
- struct statfs buf;
- if (fstatfs(fd, &buf) < 0)
- return 0;
-- return strcpy(buf.f_fstypename, "xfs") == 0;
-+ return strncmp(buf.f_fstypename, "xfs", 4) == 0;
- }
-
- static __inline__ int platform_test_xfs_path(const char *path)
-@@ -92,7 +89,7 @@
- struct statfs buf;
- if (statfs(path, &buf) < 0)
- return 0;
-- return strcpy(buf.f_fstypename, "xfs") == 0;
-+ return strncmp(buf.f_fstypename, "xfs", 4) == 0;
- }
-
- static __inline__ int platform_fstatfs(int fd, struct statfs *buf)
diff --git a/sysutils/xfsprogs/files/patch-log_misc.c b/sysutils/xfsprogs/files/patch-log_misc.c
new file mode 100644
index 000000000000..a6f3fb9ec043
--- /dev/null
+++ b/sysutils/xfsprogs/files/patch-log_misc.c
@@ -0,0 +1,20 @@
+--- logprint/log_misc.c.orig Fri Jul 7 12:34:53 2006
++++ logprint/log_misc.c Fri Jul 7 12:35:26 2006
+@@ -1530,7 +1530,7 @@
+ in_f->ilf_dsize = in_f32->ilf_dsize;
+ in_f->ilf_ino = in_f32->ilf_ino;
+ /* copy biggest */
+- memcpy(in_f->ilf_u.ilfu_uuid, in_f32->ilf_u.ilfu_uuid, sizeof(uuid_t));
++ memcpy(&in_f->ilf_u.ilfu_uuid, &in_f32->ilf_u.ilfu_uuid, sizeof(uuid_t));
+ in_f->ilf_blkno = in_f32->ilf_blkno;
+ in_f->ilf_len = in_f32->ilf_len;
+ in_f->ilf_boffset = in_f32->ilf_boffset;
+@@ -1546,7 +1546,7 @@
+ in_f->ilf_dsize = in_f64->ilf_dsize;
+ in_f->ilf_ino = in_f64->ilf_ino;
+ /* copy biggest */
+- memcpy(in_f->ilf_u.ilfu_uuid, in_f64->ilf_u.ilfu_uuid, sizeof(uuid_t));
++ memcpy(&in_f->ilf_u.ilfu_uuid, &in_f64->ilf_u.ilfu_uuid, sizeof(uuid_t));
+ in_f->ilf_blkno = in_f64->ilf_blkno;
+ in_f->ilf_len = in_f64->ilf_len;
+ in_f->ilf_boffset = in_f64->ilf_boffset;
diff --git a/sysutils/xfsprogs/files/patch-report.c b/sysutils/xfsprogs/files/patch-report.c
deleted file mode 100644
index 2d05d189724f..000000000000
--- a/sysutils/xfsprogs/files/patch-report.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- quota/report.c.orig Tue Feb 7 21:24:32 2006
-+++ quota/report.c Tue Feb 7 21:25:12 2006
-@@ -17,6 +17,7 @@
- */
-
- #include <xfs/command.h>
-+#include <sys/types.h>
- #include <pwd.h>
- #include <grp.h>
- #include <utmp.h>
diff --git a/sysutils/xfsprogs/pkg-plist b/sysutils/xfsprogs/pkg-plist
index 78ece166006d..015273a71a50 100644
--- a/sysutils/xfsprogs/pkg-plist
+++ b/sysutils/xfsprogs/pkg-plist
@@ -14,6 +14,8 @@ bin/xfs_rtcp
sbin/fsck.xfs
sbin/mkfs.xfs
sbin/xfs_repair
+share/locale/pl/LC_MESSAGES/xfsprogs.mo
+@dirrmtry share/locale/pl/LC_MESSAGES
%%PORTDOCS%%%%DOCSDIR%%/PORTING
%%PORTDOCS%%%%DOCSDIR%%/CHANGES.gz
%%PORTDOCS%%%%DOCSDIR%%/CREDITS