aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-10-05 14:52:51 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-10-05 14:52:51 +0000
commit5acc115897b33077e2164648e79d94a983931596 (patch)
treed8513d89fe92e0c643c66c449a95adcdef92af57 /sysutils
parentfd959c7d6e612fba1dbc6276e192e436099ff1ba (diff)
downloadports-5acc115897b33077e2164648e79d94a983931596.tar.gz
ports-5acc115897b33077e2164648e79d94a983931596.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cronolog/Makefile16
-rw-r--r--sysutils/grub2/Makefile9
-rw-r--r--sysutils/klaptopdaemon/Makefile19
-rw-r--r--sysutils/nitrogen/Makefile13
-rw-r--r--sysutils/nut22/Makefile41
-rw-r--r--sysutils/reed/Makefile3
6 files changed, 44 insertions, 57 deletions
diff --git a/sysutils/cronolog/Makefile b/sysutils/cronolog/Makefile
index 24c6128caf19..6b78e28f5477 100644
--- a/sysutils/cronolog/Makefile
+++ b/sysutils/cronolog/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cronolog
-# Date created: 20 January 2000
-# Whom: Mark Blackman <tmb_ports@maddog.u-net.com>
-#
+# Created by: Mark Blackman <tmb_ports@maddog.u-net.com>
# $FreeBSD$
-#
PORTNAME= cronolog
PORTVERSION= 1.6.2
@@ -21,14 +17,16 @@ MAN1= cronolog.1m cronosplit.1m
GNU_CONFIGURE= yes
-OPTIONS= SETUID_PATCH "Build with setuid functionality" On
+OPTIONS_DEFINE= SETUID_PATCH
+OPTIONS_DEFAULT= SETUID_PATCH
+SETUID_PATCH_DESC= Build with setuid functionality
EXTRA_PATCHES= ${FILESDIR}/extrapatch-src_cronoutils.c
PATCH_STRIP= -p1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_SETUID_PATCH)
+.if ${PORT_OPTIONS:MSETUID_PATCH}
MASTER_SITES+= http://cronolog.org/patches/:patches
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} cronolog-setugid-patch.txt:patches
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -40,4 +38,4 @@ post-extract:
@cd ${WRKSRC} && ${TOUCH} aclocal.m4 Makefile.in */Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/grub2/Makefile b/sysutils/grub2/Makefile
index 084774f6be15..b9f3988d0a0b 100644
--- a/sysutils/grub2/Makefile
+++ b/sysutils/grub2/Makefile
@@ -21,11 +21,12 @@ ONLY_FOR_ARCHS= i386 amd64
INFO= grub
-OPTIONS= MKFONT "Build grub-mkfont (require freetype2)" off
+OPTIONS_DEFINE= MKFONT
+MKFONT_DESC= Build grub-mkfont (require freetype2)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MKFONT)
+.if ${PORT_OPTIONS:MMKFONT}
LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
.else
MKFONT= "@comment "
@@ -36,4 +37,4 @@ PLIST_SUB+= MKFONT=${MKFONT}
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/klaptopdaemon/Makefile b/sysutils/klaptopdaemon/Makefile
index b6619679c5cb..c27d275e52a4 100644
--- a/sysutils/klaptopdaemon/Makefile
+++ b/sysutils/klaptopdaemon/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: klaptopdaemon
-# Date created: July 08 2004
-# Whom: Michael Nottebrock <lofi@FreeBSD.org>
-#
+# Created by: Michael Nottebrock <lofi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= klaptopdaemon
PORTVERSION= ${KDE_VERSION}
@@ -18,7 +14,8 @@ DIST_SUBDIR= KDE
MAINTAINER= ports@FreeBSD.org
COMMENT= APM monitor for KDE
-OPTIONS= #no options for amd64
+OPTIONS_DEFINE_i386= ACPI
+ACPI_DESC= Contributed ACPI support patch
USE_KDELIBS_VER=3
@@ -33,15 +30,7 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
-OPTIONS= ACPI "Contributed ACPI support patch" off
-.endif
-
-.if ${ARCH} == "amd64"
-WITH_ACPI= yes
-.endif
-
-.if defined(WITH_ACPI)
+.if ${PORT_OPTIONS:MACPI} || ${ARCH} == "amd64"
EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-acpi-support
ONLY_FOR_ARCHS+=amd64
.endif
diff --git a/sysutils/nitrogen/Makefile b/sysutils/nitrogen/Makefile
index f1ca9dcbbca7..142decb936a7 100644
--- a/sysutils/nitrogen/Makefile
+++ b/sysutils/nitrogen/Makefile
@@ -23,21 +23,22 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-inotify
CXXFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-OPTIONS= XINERAMA "Xinerama support" on
+OPTIONS_DEFINE= XINERAMA
+OPTIONS_DEFAULT= XINERAMA
MAN1= nitrogen.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_XINERAMA)
-CONFIGURE_ARGS+=--disable-xinerama
-.else
+.if ${PORT_OPTIONS:MXINERAMA}
CONFIGURE_ARGS+=--enable-xinerama
USE_XORG+= xinerama
+.else
+CONFIGURE_ARGS+=--disable-xinerama
.endif
post-patch:
@${REINPLACE_CMD} -e 's,#!/bin/bash,#!${LOCALBASE}/bin/bash,' \
${WRKSRC}/data/icon-theme-installer
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/nut22/Makefile b/sysutils/nut22/Makefile
index 52342e9bb8b0..cae0333a09c6 100644
--- a/sysutils/nut22/Makefile
+++ b/sysutils/nut22/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nut
-# Date created: 08 Jan 2000
-# Whom: Boris Popov <bp@freebsd.org>
-#
+# Created by: Boris Popov <bp@freebsd.org>
# $FreeBSD$
-#
PORTNAME= nut
PORTVERSION= 2.2.2
@@ -28,14 +24,13 @@ NUT_USER?= uucp
NUT_GROUP?= uucp
STATEDIR?= /var/db/nut
-OPTIONS= SERIAL "SERIAL support" on \
- USB "USB support" on \
- SNMP "SNMP support" on \
- NEON "NEON XML/HTTP support" on \
- HAL "HAL support" off \
- IPV6 "IPV6 support" on \
- DEVEL "Install header files" off \
- CGI "Web CGI interface" off \
+OPTIONS_DEFINE= SERIAL USB SNMP NEON HAL IPV6 DEVEL CGI DOCS
+OPTIONS_DEFAULT= SERIAL USB SNMP NEON IPV6
+SERIAL_DESC= SERIAL support
+USB_DESC= USB support
+NEON_DESC= NEON XML/HTTP support
+DEVEL_DESC= Install header files
+CGI_DESC= Web CGI interface
USE_RC_SUBR= nut nut_upsmon nut_upslog
SUB_LIST+= STATEDIR=${STATEDIR}
@@ -64,7 +59,7 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/nut \
--with-user=${NUT_USER} \
--with-group=${NUT_GROUP}
-.if defined(WITH_CGI)
+.if ${PORT_OPTIONS:MCGI}
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
MAN5+= hosts.conf.5 upsset.conf.5 upsstats.html.5
MAN8+= upsset.cgi.8 upsstats.cgi.8 upsimage.cgi.8
@@ -82,7 +77,7 @@ CONFIGURE_ARGS+= --without-cgi
PLIST_SUB+= NUT_CGI="@comment "
.endif
-.if !defined(WITHOUT_SERIAL)
+.if ${PORT_OPTIONS:MSERIAL}
CONFIGURE_ARGS+= --with-serial
MAN8+= al175.8 apcsmart.8 bcmxcp.8 belkin.8 belkinunv.8 \
bestuferrups.8 bestups.8 bestfcom.8 cpsups.8 cyberpower.8 \
@@ -97,7 +92,7 @@ CONFIGURE_ARGS+= --without-serial
PLIST_SUB+= NUT_SERIAL="@comment "
.endif
-.if !defined(WITHOUT_USB)
+.if ${PORT_OPTIONS:MUS}
. if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
. else
@@ -111,7 +106,7 @@ CONFIGURE_ARGS+= --without-usb
PLIST_SUB+= NUT_USB="@comment "
.endif
-.if !defined(WITHOUT_SNMP)
+.if ${PORT_OPTIONS:MSNMP}
LIB_DEPENDS+= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
CONFIGURE_ARGS+= --with-snmp
MAN8+= snmp-ups.8
@@ -121,7 +116,7 @@ CONFIGURE_ARGS+= --without-snmp
PLIST_SUB+= NUT_SNMP="@comment "
.endif
-.if !defined(WITHOUT_NEON)
+.if ${PORT_OPTIONS:MNEON}
LIB_DEPENDS+= neon.27:${PORTSDIR}/www/neon29
CONFIGURE_ARGS+= --with-neonxml
MAN8+= netxml-ups.8
@@ -131,8 +126,8 @@ CONFIGURE_ARGS+= --without-neonxml
PLIST_SUB+= NUT_NEON="@comment "
.endif
-.if defined(WITH_HAL)
-. if defined(WITHOUT_USB)
+.if ${PORT_OPTIONS:MHAL}
+. if empty(PORT_OPTIONS:MUSB}
BROKEN= HAL is only usable with USB support enabled. Run 'make config' again!
. endif
LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
@@ -144,13 +139,13 @@ CONFIGURE_ARGS+= --without-hal
PLIST_SUB+= NUT_HAL="@comment "
.endif
-.if !defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --with-ipv6
.else
CONFIGURE_ARGS+= --without-ipv6
.endif
-.if defined(WITH_DEVEL)
+.if ${PORT_OPTIONS:MDEVEL}
CONFIGURE_ARGS+= --with-dev
MAN3+= upscli_connect.3 upscli_disconnect.3 upscli_fd.3 \
upscli_get.3 upscli_list_next.3 upscli_list_start.3 \
@@ -170,7 +165,7 @@ pre-install:
@${CHOWN} ${NUT_USER}:${NUT_GROUP} ${STATEDIR}
@${CHMOD} 0750 ${STATEDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}/cables
${INSTALL_DATA} ${WRKSRC}/docs/cables/*.txt ${DOCSDIR}/cables
diff --git a/sysutils/reed/Makefile b/sysutils/reed/Makefile
index 4734a5d17829..f5c29649703d 100644
--- a/sysutils/reed/Makefile
+++ b/sysutils/reed/Makefile
@@ -14,6 +14,9 @@ MASTER_SITES= http://www.sacredchao.net/~piman/archive/
MAINTAINER= ports@FreeBSD.org
COMMENT= A text pager with autoscrolling and more
+DEPRECATED= No more public distfiles
+EXPIRATION_DATE= 2012-10-20
+
USE_PERL5= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configures