aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2010-11-12 21:23:23 +0000
committerCy Schubert <cy@FreeBSD.org>2010-11-12 21:23:23 +0000
commit74e115d713a632df528d0aae85d87aadbfaf9b4b (patch)
treeb0826ace316eea7a164b5b1396627eb567015ace /sysutils
parente5a5ab22313b8e94eb0d1d846971331e46e4cfe1 (diff)
downloadports-74e115d713a632df528d0aae85d87aadbfaf9b4b.tar.gz
ports-74e115d713a632df528d0aae85d87aadbfaf9b4b.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/syslog-ng3/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/sysutils/syslog-ng3/Makefile b/sysutils/syslog-ng3/Makefile
index 23fd039c11c2..967ba2fbb013 100644
--- a/sysutils/syslog-ng3/Makefile
+++ b/sysutils/syslog-ng3/Makefile
@@ -21,15 +21,13 @@ CONFLICTS?= syslog-ng-[0-9]* syslog-ng[0124-9]-[0-9]* \
OPTIONS= SSL "Build with OpenSSL support (from ports)" off \
TCP_WRAPPERS "Build with TCP Wrappers" off \
- SQL "Build with SQL support" off \
+ SQL "Build with database (libdbi) support" off \
SPOOF "Build with spoof source support" on \
IPV6 "Build with IPV6 support" on \
- PCRE "Build with PCRE support" on \
- SQL "Build with database (libdbi) support" off
+ PCRE "Build with PCRE support" on
.include <bsd.port.options.mk>
-BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
LIB_DEPENDS= evtlog.0:${PORTSDIR}/sysutils/eventlog
MAN1= pdbtool.1
@@ -41,8 +39,6 @@ GNU_CONFIGURE= yes
USE_GNOME= glib20
SUB_FILES= pkg-message
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-
CONFIGURE_ARGS= --sysconfdir=${LOCALBASE}/etc --localstatedir=/var/db \
--enable-dynamic-linking --with-libnet=${LOCALBASE}/bin
CONFIGURE_ENV= CFLAGS="`${LIBNET_CONFIG} --cflags` -I${LOCALBASE}/include ${CFLAGS}" \
@@ -65,6 +61,11 @@ CONFIGURE_ARGS+= --disable-tcp-wrapper
.endif
.if defined(WITH_SPOOF)
+.if ${ARCH} == "amd64"
+BROKEN= Does not compile: relocation R_X86_64_32 can not be used when making a shared object
+.endif
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
CONFIGURE_ARGS+= --enable-spoof-source
.else
CONFIGURE_ARGS+= --disable-spoof-source