aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2010-12-23 16:41:19 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2010-12-23 16:41:19 +0000
commit56a0c1308f8c4b428dea3e84c4a809addfc0e70e (patch)
treef75e7832172ecb5d8ee9f2ea634ea5bb22708c1a /sysutils
parent2659c5800f21a98c508e2145aabb7e4b36f43d0e (diff)
downloadports-56a0c1308f8c4b428dea3e84c4a809addfc0e70e.tar.gz
ports-56a0c1308f8c4b428dea3e84c4a809addfc0e70e.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/downtimed/Makefile30
-rw-r--r--sysutils/downtimed/distinfo2
-rw-r--r--sysutils/downtimed/files/downtimed.in36
-rw-r--r--sysutils/downtimed/pkg-descr15
-rw-r--r--sysutils/downtimed/pkg-message13
-rw-r--r--sysutils/downtimed/pkg-plist4
7 files changed, 101 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index b947f317948f..ce45d9014fd3 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -171,6 +171,7 @@
SUBDIR += dolly
SUBDIR += dolly+
SUBDIR += downtime
+ SUBDIR += downtimed
SUBDIR += dt
SUBDIR += dtc
SUBDIR += dtpstree
diff --git a/sysutils/downtimed/Makefile b/sysutils/downtimed/Makefile
new file mode 100644
index 000000000000..ca2f5b46cd12
--- /dev/null
+++ b/sysutils/downtimed/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: downtimed
+# Date created: 2010-09-06
+# Whom: Janne Snabb <snabb@epipe.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= downtimed
+PORTVERSION= 0.2
+CATEGORIES= sysutils
+MASTER_SITES= http://dist.epipe.com/${PORTNAME}/ \
+ http://launchpadlibrarian.net/58217312/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= snabb@epipe.com
+COMMENT= System downtime monitoring and reporting tool
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_XZ= yes
+MAN1= downtimes.1
+MAN8= downtimed.8
+USE_RC_SUBR= ${PORTNAME}
+GNU_CONFIGURE= yes
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/sysutils/downtimed/distinfo b/sysutils/downtimed/distinfo
new file mode 100644
index 000000000000..8199f1e448ef
--- /dev/null
+++ b/sysutils/downtimed/distinfo
@@ -0,0 +1,2 @@
+SHA256 (downtimed-0.2.tar.xz) = 4ffd52e9b0dcc4513687ce0d9cfcd139732692001ba246a2552087ac80404e07
+SIZE (downtimed-0.2.tar.xz) = 73608
diff --git a/sysutils/downtimed/files/downtimed.in b/sysutils/downtimed/files/downtimed.in
new file mode 100644
index 000000000000..1c2a691922c1
--- /dev/null
+++ b/sysutils/downtimed/files/downtimed.in
@@ -0,0 +1,36 @@
+#!/bin/sh
+# $FreeBSD$
+
+# PROVIDE: downtimed
+# REQUIRE: LOGIN syslogd
+# KEYWORD: shutdown
+
+# This file should be installed as %%PREFIX%%/etc/rc.d/downtimed
+#
+# Define downtimed_* variables in one of these files:
+# /etc/rc.conf
+# /etc/rc.conf.local
+# /etc/rc.conf.d/downtimed
+#
+# Add the following line to enable:
+# downtimed_enable="YES"
+#
+# Add the following line to change the default options, see downtimed(8):
+# downtimed_flags="<set as needed>"
+#
+# DO NOT CHANGE THE DEFAULT VALUES BELOW
+
+. /etc/rc.subr
+
+name="downtimed"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/sbin/${name}"
+pidfile="/var/run/${name}.pid"
+
+load_rc_config "$name"
+
+: ${downtimed_enable="NO"}
+: ${downtimed_flags=""}
+
+run_rc_command "$1"
diff --git a/sysutils/downtimed/pkg-descr b/sysutils/downtimed/pkg-descr
new file mode 100644
index 000000000000..4dd7a0a8fc5a
--- /dev/null
+++ b/sysutils/downtimed/pkg-descr
@@ -0,0 +1,15 @@
+downtimed is a program that monitors operating system downtime, uptime,
+shutdowns and crashes and keeps records of those events.
+
+downtimed(8) is a daemon process which is intended to be started
+automatically from system boot scripts every time when the operating
+system of a server starts. First the daemon logs its findings about the
+previous downtime to a specified logging destination as well as in a
+database file which can be displayed with downtimes(1). After that the
+daemon just keeps waiting in the background and periodically updates
+a time stamp file on the disk.
+
+downtimes(1) is a command-line tool which can be used to inspect previous
+downtime records.
+
+WWW: http://dist.epipe.com/downtimed/
diff --git a/sysutils/downtimed/pkg-message b/sysutils/downtimed/pkg-message
new file mode 100644
index 000000000000..d4d726da55a7
--- /dev/null
+++ b/sysutils/downtimed/pkg-message
@@ -0,0 +1,13 @@
+===> IMPORTANT NOTE:
+
+ To set up downtimed, you need to edit one of the following
+ files:
+ /etc/rc.conf
+ /etc/rc.conf.local
+ /etc/rc.conf.d/downtimed
+
+ Add the following line to enable:
+ downtimed_enable="YES"
+
+ Add the following line to change the default options, see downtimed(8):
+ downtimed_flags="<set as needed>"
diff --git a/sysutils/downtimed/pkg-plist b/sysutils/downtimed/pkg-plist
new file mode 100644
index 000000000000..08d7a8fabca6
--- /dev/null
+++ b/sysutils/downtimed/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+bin/downtimes
+sbin/downtimed
+@unexec /bin/rmdir /var/db/downtimed 2>/dev/null || true