aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-07-02 14:33:11 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-07-02 14:33:11 +0000
commitdb02d8029714eab5aa2489abdb3c34967251bf03 (patch)
tree3ca95106d8e926f99f21cd9c6cd7d36858453f25 /sysutils
parent655a007d9a253c2a350537124c7156c0449754d5 (diff)
downloadports-db02d8029714eab5aa2489abdb3c34967251bf03.tar.gz
ports-db02d8029714eab5aa2489abdb3c34967251bf03.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/dcfldd/Makefile20
-rw-r--r--sysutils/dcfldd/distinfo4
-rw-r--r--sysutils/dcfldd/files/extra-patch-dcfldd.h11
-rw-r--r--sysutils/dcfldd/files/extra-patch-human.c10
-rw-r--r--sysutils/dcfldd/files/extra-patch-xstrtol.h7
-rw-r--r--sysutils/dcfldd/files/patch-doc:Makefile.in20
-rw-r--r--sysutils/dcfldd/files/patch-lib:Makefile.in11
-rw-r--r--sysutils/dcfldd/files/patch-man:dcfldd.118
-rw-r--r--sysutils/dcfldd/files/patch-po:Makefile.in.in14
-rw-r--r--sysutils/dcfldd/files/patch-src:dcfldd.c11
-rw-r--r--sysutils/dcfldd/pkg-plist20
11 files changed, 39 insertions, 107 deletions
diff --git a/sysutils/dcfldd/Makefile b/sysutils/dcfldd/Makefile
index 2dbe00d4adad..a243eee4b859 100644
--- a/sysutils/dcfldd/Makefile
+++ b/sysutils/dcfldd/Makefile
@@ -6,25 +6,23 @@
#
PORTNAME= dcfldd
-PORTVERSION= 1.0
+PORTVERSION= 1.2.4
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= biatchux
+MASTER_SITE_SUBDIR= dcfldd
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= An enhanced dd tool with MD5 hashing capability
+USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LIBS=-L${LOCALBASE}/lib
-
MAN1= dcfldd.1
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-dcfldd.h ${PATCHDIR}/extra-patch-human.c \
+ ${PATCHDIR}/extra-patch-xstrtol.h
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/dcfldd/distinfo b/sysutils/dcfldd/distinfo
index 50915b5fb582..9a4ebc7f6af3 100644
--- a/sysutils/dcfldd/distinfo
+++ b/sysutils/dcfldd/distinfo
@@ -1,2 +1,2 @@
-MD5 (dcfldd-1.0.tar.gz) = ef62d2a26c266df6151ae35447bfd2ad
-SIZE (dcfldd-1.0.tar.gz) = 1384650
+MD5 (dcfldd-1.2.4.tar.gz) = 429a0df4d6a6bf35b8be3f3204b98f0c
+SIZE (dcfldd-1.2.4.tar.gz) = 163087
diff --git a/sysutils/dcfldd/files/extra-patch-dcfldd.h b/sysutils/dcfldd/files/extra-patch-dcfldd.h
new file mode 100644
index 000000000000..a46b414e19e9
--- /dev/null
+++ b/sysutils/dcfldd/files/extra-patch-dcfldd.h
@@ -0,0 +1,11 @@
+--- dcfldd.h.orig Sun May 15 08:06:08 2005
++++ dcfldd.h Sat Jul 2 23:09:19 2005
+@@ -92,6 +92,8 @@
+ /* Use separate input and output buffers, and combine partial input blocks. */
+ #define C_TWOBUFS 04000
+
++#define uintmax_t uint64_t
++
+ extern char *program_name;
+
+ extern char *input_file;
diff --git a/sysutils/dcfldd/files/extra-patch-human.c b/sysutils/dcfldd/files/extra-patch-human.c
new file mode 100644
index 000000000000..20150d64eab9
--- /dev/null
+++ b/sysutils/dcfldd/files/extra-patch-human.c
@@ -0,0 +1,10 @@
+--- human.c.orig Sat Jul 2 23:12:17 2005
++++ human.c Sat Jul 2 23:12:31 2005
+@@ -19,6 +19,7 @@
+ --si, output block size selection, and large file support
+ added by eggert@twinsun.com. */
+
++#include "dcfldd.h"
+ #if HAVE_CONFIG_H
+ # include <config.h>
+ #endif
diff --git a/sysutils/dcfldd/files/extra-patch-xstrtol.h b/sysutils/dcfldd/files/extra-patch-xstrtol.h
new file mode 100644
index 000000000000..d5982c5dddfb
--- /dev/null
+++ b/sysutils/dcfldd/files/extra-patch-xstrtol.h
@@ -0,0 +1,7 @@
+--- xstrtol.h.orig Sat Jul 2 23:18:21 2005
++++ xstrtol.h Sat Jul 2 23:18:47 2005
+@@ -1,3 +1,4 @@
++#include "dcfldd.h"
+ #ifndef XSTRTOL_H_
+ # define XSTRTOL_H_ 1
+
diff --git a/sysutils/dcfldd/files/patch-doc:Makefile.in b/sysutils/dcfldd/files/patch-doc:Makefile.in
deleted file mode 100644
index dc3b41df0053..000000000000
--- a/sysutils/dcfldd/files/patch-doc:Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- doc/Makefile.in.orig Fri Oct 19 01:33:03 2001
-+++ doc/Makefile.in Mon Jan 10 01:06:44 2005
-@@ -136,7 +136,7 @@
- TEXINFOS = fileutils.texi
- DIST_COMMON = Makefile.am Makefile.in mdate-sh stamp-vti texinfo.tex \
- version.texi
--all: all-am
-+all:
-
- .SUFFIXES:
- .SUFFIXES: .dvi .info .ps .texi
-@@ -269,7 +269,7 @@
- installdirs:
- $(mkinstalldirs) $(DESTDIR)$(infodir)
-
--install: install-am
-+install:
- install-exec: install-exec-am
- install-data: install-data-am
- uninstall: uninstall-am
diff --git a/sysutils/dcfldd/files/patch-lib:Makefile.in b/sysutils/dcfldd/files/patch-lib:Makefile.in
deleted file mode 100644
index 0f274bbde3ef..000000000000
--- a/sysutils/dcfldd/files/patch-lib:Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Makefile.in.orig Mon Jan 10 01:54:04 2005
-+++ lib/Makefile.in Mon Jan 10 01:56:47 2005
-@@ -830,7 +830,7 @@
-
- install-data-am:
-
--install-exec-am: install-exec-local
-+install-exec-am:
-
- install-info: install-info-am
-
diff --git a/sysutils/dcfldd/files/patch-man:dcfldd.1 b/sysutils/dcfldd/files/patch-man:dcfldd.1
deleted file mode 100644
index b3b4881f0178..000000000000
--- a/sysutils/dcfldd/files/patch-man:dcfldd.1
+++ /dev/null
@@ -1,18 +0,0 @@
---- man/dcfldd.1.orig Mon Jan 10 01:46:24 2005
-+++ man/dcfldd.1 Mon Jan 10 01:47:17 2005
-@@ -120,15 +120,3 @@
- .br
- This is free software; see the source for copying conditions. There is NO
- warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
--.SH "SEE ALSO"
--The full documentation for
--.B dcfldd
--is maintained as a Texinfo manual. If the
--.B info
--and
--.B dcfldd
--programs are properly installed at your site, the command
--.IP
--.B info dcfldd
--.PP
--should give you access to the complete manual.
diff --git a/sysutils/dcfldd/files/patch-po:Makefile.in.in b/sysutils/dcfldd/files/patch-po:Makefile.in.in
deleted file mode 100644
index 6d94793fd5ed..000000000000
--- a/sysutils/dcfldd/files/patch-po:Makefile.in.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- po/Makefile.in.in.orig Mon Jan 10 00:47:34 2005
-+++ po/Makefile.in.in Mon Jan 10 00:47:55 2005
-@@ -150,11 +150,6 @@
- true; \
- fi; \
- fi; \
-- timedir=$$destdir/$$lang/LC_TIME; \
-- rm -fr $$timedir; \
-- ln -s LC_MESSAGES $$timedir \
-- || (mkdir $$timedir && ln $$dir/* $$timedir); \
-- echo "installing $$timedir as an alias for $$dir"; \
- done
- if test "$(PACKAGE)" = "gettext"; then \
- if test -x "$(MKINSTALLDIRS)"; then \
diff --git a/sysutils/dcfldd/files/patch-src:dcfldd.c b/sysutils/dcfldd/files/patch-src:dcfldd.c
deleted file mode 100644
index 756e1386d626..000000000000
--- a/sysutils/dcfldd/files/patch-src:dcfldd.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/dcfldd.c.orig Mon Jan 10 00:36:19 2005
-+++ src/dcfldd.c Mon Jan 10 00:36:45 2005
-@@ -342,7 +342,7 @@
- hashlog=FILE send MD5 hash output to FILE instead of stderr\n\
- status=[on|off] display a continual status message on stderr\n\
- default state is \"on\"\n\
-- sizeprobe=[if|of] determine the size of the input or output file
-+ sizeprobe=[if|of] determine the size of the input or output file\n\
- for use with status messages. (this option\n\
- gives you a percentage indicator)\n\
- WARNING: Read the manual before using this\n\
diff --git a/sysutils/dcfldd/pkg-plist b/sysutils/dcfldd/pkg-plist
index 374f2fbb1b8f..35f2d7b86925 100644
--- a/sysutils/dcfldd/pkg-plist
+++ b/sysutils/dcfldd/pkg-plist
@@ -1,21 +1 @@
bin/dcfldd
-%%NLS%%share/locale/cs/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/da/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/de/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/el/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/es/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/gl/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/it/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/ko/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/no/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/pt/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/sk/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/sl/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/dcfldd.mo
-%%NLS%%share/locale/zh/LC_MESSAGES/dcfldd.mo