aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-06-07 23:00:46 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-06-07 23:00:46 +0000
commit077b4b53b0d0814df73a850dfa8625101c7b8404 (patch)
tree1635d75a5b1ebd11d644c2d01607580c9063de35 /sysutils
parent95cfdcc8b6a9c07b40477662aa446e3bdd99525b (diff)
downloadports-077b4b53b0d0814df73a850dfa8625101c7b8404.tar.gz
ports-077b4b53b0d0814df73a850dfa8625101c7b8404.zip
Notes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/pear-File/Makefile24
-rw-r--r--sysutils/pear-File/pkg-deinstall13
-rw-r--r--sysutils/pear-File/pkg-descr2
-rw-r--r--sysutils/pear-File/pkg-plist5
-rw-r--r--sysutils/pear-Log/Makefile26
-rw-r--r--sysutils/pear-Log/distinfo2
-rw-r--r--sysutils/pear-Log/pkg-deinstall13
-rw-r--r--sysutils/pear-Log/pkg-descr2
-rw-r--r--sysutils/pear-Log/pkg-plist2
9 files changed, 15 insertions, 74 deletions
diff --git a/sysutils/pear-File/Makefile b/sysutils/pear-File/Makefile
index 7f0e07660c73..21bf85234c0e 100644
--- a/sysutils/pear-File/Makefile
+++ b/sysutils/pear-File/Makefile
@@ -7,39 +7,21 @@
PORTNAME= File
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= sysutils www
-MASTER_SITES= http://pear.php.net/get/
-PKGNAMEPREFIX= pear-
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR common file and directory routines
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php.dist:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
-NO_BUILD= yes
-
.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/bin/php-config)
-PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
-.else
-PHP_BASE= ${LOCALBASE}
-.endif
-PEAR= ${LOCALBASE}/bin/pear
-LPHP_LIB= lib/php
-PEARDIR= ${PHP_BASE}/${LPHP_LIB}
-PLIST_SUB= PEARDIR=${LPHP_LIB}
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
do-install:
@${CP} -Rp ${WRKSRC}/* ${PEARDIR}
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/${PORTNAME}*
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/tests
-post-install:
-# Register a new package
- @${PEAR} install -r -f ${WRKDIR}/package.xml
-
.include <bsd.port.post.mk>
diff --git a/sysutils/pear-File/pkg-deinstall b/sysutils/pear-File/pkg-deinstall
deleted file mode 100644
index c17e9d19ced0..000000000000
--- a/sysutils/pear-File/pkg-deinstall
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# Remove package declaration from PEAR's registry.
-
-if [ x$2 != xDEINSTALL ]; then
- exit
-fi
-PKG_NAME=${1%%-[0-9._]*}
-PACKAGE=$(echo $PKG_NAME | sed 's/pear-//')
-
-${PKG_PREFIX}/bin/pear uninstall -r ${PACKAGE} || true
diff --git a/sysutils/pear-File/pkg-descr b/sysutils/pear-File/pkg-descr
index 7dbaaff3f463..d3826c5d81e8 100644
--- a/sysutils/pear-File/pkg-descr
+++ b/sysutils/pear-File/pkg-descr
@@ -2,4 +2,4 @@ PEAR classes providing easy access to read/write to files along with
some common routines to deal with paths. Also provides interface for
handling CSV files.
-WWW: http://pear.php.net/manual/en/packages.file.php
+WWW: http://pear.php.net/package-info.php?package=File
diff --git a/sysutils/pear-File/pkg-plist b/sysutils/pear-File/pkg-plist
index 82e769dda347..9d55bdae8898 100644
--- a/sysutils/pear-File/pkg-plist
+++ b/sysutils/pear-File/pkg-plist
@@ -1,5 +1,8 @@
%%PEARDIR%%/File/CSV.php
%%PEARDIR%%/File.php
+%%PKGREGDIR%%/package.xml
%%PEARDIR%%/tests/parser.php
%%PEARDIR%%/tests/test.csv
-@dirrm %%PEARDIR%%/File
+@dirrm %%PKGREGDIR%%
+@unexec rmdir %D/share/pear/tests 2> /dev/null || true
+@unexec rmdir %D/share/pear/File 2> /dev/null || true
diff --git a/sysutils/pear-Log/Makefile b/sysutils/pear-Log/Makefile
index 00a71d279362..fc1ae83ab98c 100644
--- a/sysutils/pear-Log/Makefile
+++ b/sysutils/pear-Log/Makefile
@@ -6,40 +6,20 @@
#
PORTNAME= Log
-PORTVERSION= 1.6.1
+PORTVERSION= 1.6.5
CATEGORIES= sysutils www
-MASTER_SITES= http://pear.php.net/get/
-PKGNAMEPREFIX= pear-
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR logging utilities
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php.dist:${PORTSDIR}/devel/pear-PEAR
-# ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
RUN_DEPENDS= ${BUILD_DEPENDS}
-NO_BUILD= yes
-
.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/bin/php-config)
-PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
-.else
-PHP_BASE= ${LOCALBASE}
-.endif
-PEAR= ${LOCALBASE}/bin/pear
-LPHP_LIB= lib/php
-PEARDIR= ${PHP_BASE}/${LPHP_LIB}
-PLIST_SUB= PEARDIR=${LPHP_LIB}
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
do-install:
@${CP} -Rp ${WRKSRC}/* ${PEARDIR}
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/${PORTNAME}*
-post-install:
-# Register a new package
- @${PEAR} install -r -f ${WRKDIR}/package.xml
-
.include <bsd.port.post.mk>
diff --git a/sysutils/pear-Log/distinfo b/sysutils/pear-Log/distinfo
index 4724ce743a73..011d3476e321 100644
--- a/sysutils/pear-Log/distinfo
+++ b/sysutils/pear-Log/distinfo
@@ -1 +1 @@
-MD5 (PEAR/Log-1.6.1.tgz) = bf033aebb99ed060e73cd1c89280e2b6
+MD5 (PEAR/Log-1.6.5.tgz) = db17ef03564929c77838d17993be33b9
diff --git a/sysutils/pear-Log/pkg-deinstall b/sysutils/pear-Log/pkg-deinstall
deleted file mode 100644
index c17e9d19ced0..000000000000
--- a/sysutils/pear-Log/pkg-deinstall
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# Remove package declaration from PEAR's registry.
-
-if [ x$2 != xDEINSTALL ]; then
- exit
-fi
-PKG_NAME=${1%%-[0-9._]*}
-PACKAGE=$(echo $PKG_NAME | sed 's/pear-//')
-
-${PKG_PREFIX}/bin/pear uninstall -r ${PACKAGE} || true
diff --git a/sysutils/pear-Log/pkg-descr b/sysutils/pear-Log/pkg-descr
index d15b0ddefb82..41e2b0d6f90d 100644
--- a/sysutils/pear-Log/pkg-descr
+++ b/sysutils/pear-Log/pkg-descr
@@ -3,4 +3,4 @@ PEAR Log framework providing an abstracted logging system.
It supports logging to console, file, syslog, SQL, mail, and mcal targets.
It also provides a subject - observer mechanism.
-WWW: http://pear.php.net/manual/en/packages.log.php
+WWW: http://pear.php.net/package-info.php?package=Log
diff --git a/sysutils/pear-Log/pkg-plist b/sysutils/pear-Log/pkg-plist
index 51c492c0b71a..da695bc9ace1 100644
--- a/sysutils/pear-Log/pkg-plist
+++ b/sysutils/pear-Log/pkg-plist
@@ -7,4 +7,6 @@
%%PEARDIR%%/Log/sql.php
%%PEARDIR%%/Log/syslog.php
%%PEARDIR%%/Log.php
+%%PKGREGDIR%%/package.xml
@dirrm %%PEARDIR%%/Log
+@dirrm %%PKGREGDIR%%