aboutsummaryrefslogtreecommitdiff
path: root/textproc/UCD/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2016-11-26 21:48:54 +0000
committerThierry Thomas <thierry@FreeBSD.org>2016-11-26 21:48:54 +0000
commitf334a7c6fa06f00541ac25486de9ddf61e6109b3 (patch)
treeb533e6abd1618fc79f10390eb1afd38b49565e7b /textproc/UCD/Makefile
parent8bd98823ec0b8fa3a5d86e4f9f55e23b31c37ece (diff)
downloadports-f334a7c6fa06f00541ac25486de9ddf61e6109b3.tar.gz
ports-f334a7c6fa06f00541ac25486de9ddf61e6109b3.zip
Notes
Diffstat (limited to 'textproc/UCD/Makefile')
-rw-r--r--textproc/UCD/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/textproc/UCD/Makefile b/textproc/UCD/Makefile
new file mode 100644
index 000000000000..89e37dae24e9
--- /dev/null
+++ b/textproc/UCD/Makefile
@@ -0,0 +1,33 @@
+# Created by: Thierry Thomas <thierry@pompo.net>
+# $FreeBSD$
+
+PORTNAME= UCD
+PORTVERSION= 9.0.0
+CATEGORIES= textproc
+MASTER_SITES= http://www.unicode.org/Public/zipped/${PORTVERSION}/:src\
+ ftp://www.unicode.org/Public/zipped/${PORTVERSION}/:src \
+ http://www.unicode.org/:lic
+DISTFILES= ${PORTNAME}.zip:src \
+ copyright.html:lic
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+EXTRACT_ONLY=
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Unicode Character Database
+
+LICENSE= Unicode_License_Agreement
+LICENSE_NAME= Unicode License Agreement
+LICENSE_FILE= ${_DISTDIR}/copyright.html
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+DATADIR= ${PREFIX}/share/unicode/ucd
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${STAGEDIR}${DATADIR} && \
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${PORTNAME}.zip ${EXTRACT_AFTER_ARGS})
+
+.include <bsd.port.mk>