aboutsummaryrefslogtreecommitdiff
path: root/textproc/ack/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-01-07 17:28:31 +0000
committerChris Rees <crees@FreeBSD.org>2013-01-07 17:28:31 +0000
commit054cd49885e7561062f88cefdb507addcc4b6833 (patch)
tree887462cb7b25d3c5b86f81ff077ee7374af45f96 /textproc/ack/Makefile
parentfdb71e16b0654f375aca478e4249a6ea0293ab9b (diff)
Notes
Diffstat (limited to 'textproc/ack/Makefile')
-rw-r--r--textproc/ack/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/textproc/ack/Makefile b/textproc/ack/Makefile
new file mode 100644
index 000000000000..8cac3814c517
--- /dev/null
+++ b/textproc/ack/Makefile
@@ -0,0 +1,38 @@
+# Created by: chinsan <chinsan.tw@gmail.com>
+# $FreeBSD$
+
+PORTNAME= ack
+PORTVERSION= 1.96
+PORTREVISION= 1
+CATEGORIES= textproc perl5 sysutils
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= App
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A grep-like text finder for large trees of text
+
+BUILD_DEPENDS= p5-File-Next>=0.40:${PORTSDIR}/sysutils/p5-File-Next
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+CONFLICTS_INSTALL= ja-ack-[0-9]*
+
+MAN1= ack.1
+
+OPTIONS_DEFINE= BASH_COMPLETE
+BASH_COMPLETE_DESC= install bash completion files
+
+.include <bsd.port.options.mk>
+
+COMPLETION_DIR= ${PREFIX}/etc/bash_completion.d
+.if ${PORT_OPTIONS:MBASH_COMPLETE}
+RUN_DEPENDS+= ${COMPLETION_DIR}:${PORTSDIR}/shells/bash-completion
+PLIST_SUB+= BASH=""
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/etc/ack.bash_completion.sh ${COMPLETION_DIR}
+.else
+PLIST_SUB+= BASH="@comment "
+.endif
+
+.include <bsd.port.mk>