aboutsummaryrefslogtreecommitdiff
path: root/textproc/ant-xinclude-task
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-04-20 19:35:58 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-04-20 19:35:58 +0000
commit672b6d91dad2c0a52db00d4828772c685bd43c4b (patch)
tree53a8d2a40ad826e6ff69d4e969266a16bae4993c /textproc/ant-xinclude-task
parent8827b1b717bdcca88ca3797188a66f312a4bf3ed (diff)
Notes
Diffstat (limited to 'textproc/ant-xinclude-task')
-rw-r--r--textproc/ant-xinclude-task/Makefile9
-rw-r--r--textproc/ant-xinclude-task/pkg-plist22
2 files changed, 4 insertions, 27 deletions
diff --git a/textproc/ant-xinclude-task/Makefile b/textproc/ant-xinclude-task/Makefile
index 068d296b0c23..6b8e8dfbb45a 100644
--- a/textproc/ant-xinclude-task/Makefile
+++ b/textproc/ant-xinclude-task/Makefile
@@ -24,17 +24,16 @@ ANT?= ${LOCALBASE}/bin/ant
ANT_TARGET= jar
.else
ANT_TARGET= jar apidocs
+PORTDOCS= *
.endif
-JAVASHAREDIR= ${PREFIX}/share/java
-JARDIR= ${JAVASHAREDIR}/classes
do-build:
- @cd ${WRKSRC} && ${ANT} ${ANT_TARGET}
+ cd ${WRKSRC} && ${SETENV} ANT_INCLUDE_SHARED_JARS=YES ${ANT} ${ANT_TARGET}
do-install:
- @${ECHO} -n ">> Installing JAR as ${JARDIR}/${PORTNAME}.jar..."
- @${CP} ${WRKSRC}/build/${PORTNAME}.jar ${JARDIR}/
+ @${ECHO} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${CP} ${WRKSRC}/build/${PORTNAME}.jar ${JAVAJARDIR}/
@${ECHO} " [ DONE ]"
.if !defined(NOPORTDOCS)
diff --git a/textproc/ant-xinclude-task/pkg-plist b/textproc/ant-xinclude-task/pkg-plist
index 5c209699f14c..9012ce15c843 100644
--- a/textproc/ant-xinclude-task/pkg-plist
+++ b/textproc/ant-xinclude-task/pkg-plist
@@ -1,23 +1 @@
-doc/xinclude-task/org/znerd/xincludetask/class-use/XIncludeTask.html
-doc/xinclude-task/org/znerd/xincludetask/package-use.html
-doc/xinclude-task/org/znerd/xincludetask/package-summary.html
-doc/xinclude-task/org/znerd/xincludetask/package-tree.html
-doc/xinclude-task/org/znerd/xincludetask/package-frame.html
-doc/xinclude-task/org/znerd/xincludetask/XIncludeTask.html
-doc/xinclude-task/serialized-form.html
-doc/xinclude-task/packages.html
-doc/xinclude-task/package-list
-doc/xinclude-task/overview-tree.html
-doc/xinclude-task/index.html
-doc/xinclude-task/index-all.html
-doc/xinclude-task/help-doc.html
-doc/xinclude-task/deprecated-list.html
-doc/xinclude-task/stylesheet.css
-doc/xinclude-task/allclasses-frame.html
share/java/classes/xinclude-task.jar
-@dirrm doc/xinclude-task/org/znerd/xincludetask/class-use
-@dirrm doc/xinclude-task/org/znerd/xincludetask
-@dirrm doc/xinclude-task/org/znerd
-@dirrm doc/xinclude-task/org
-@dirrm doc/xinclude-task
-@dirrm doc