aboutsummaryrefslogtreecommitdiff
path: root/textproc/archmage/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-02-22 20:06:53 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-02-22 20:06:53 +0000
commita38bbc1bbfb89d5339ce834908148f9bc9bd18fa (patch)
tree0aab0637fe326de8eca8764dfe15bea6050e570a /textproc/archmage/Makefile
parentc89e0c4437788b964b89b17237605900842c768f (diff)
downloadports-a38bbc1bbfb89d5339ce834908148f9bc9bd18fa.tar.gz
ports-a38bbc1bbfb89d5339ce834908148f9bc9bd18fa.zip
Notes
Diffstat (limited to 'textproc/archmage/Makefile')
-rw-r--r--textproc/archmage/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/textproc/archmage/Makefile b/textproc/archmage/Makefile
new file mode 100644
index 000000000000..cfbb38321768
--- /dev/null
+++ b/textproc/archmage/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: archmage
+# Date created: 22 February 2005
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= archmage
+PORTVERSION= 0.0.6
+CATEGORIES= textproc python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= archmage
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= Extensible reader/decompiler of files in CHM format
+
+RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/chm/_chmlib.so:${PORTSDIR}/textproc/pychm
+
+NO_BUILD= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_INSTALLARGS= build_ext -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ install -c -O1 --prefix=${PREFIX}
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/usr/share,${PREFIX}/share," ${WRKSRC}/arch.conf
+ @${REINPLACE_CMD} -e "s,/etc/arch\.conf,${PREFIX}/etc/arch\.conf," ${WRKSRC}/CHM.py
+
+.include <bsd.port.mk>