aboutsummaryrefslogtreecommitdiff
path: root/textproc/archmage
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-04-03 16:14:02 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-04-03 16:14:02 +0000
commitf55193f7f767223778ef13e4400a7432288bd353 (patch)
treef3d763c376771a8770a34a378051f51822ab0a60 /textproc/archmage
parent3ada00cdc32a4fce947f69aab0bfc008fa67d03f (diff)
downloadports-f55193f7f767223778ef13e4400a7432288bd353.tar.gz
ports-f55193f7f767223778ef13e4400a7432288bd353.zip
Notes
Diffstat (limited to 'textproc/archmage')
-rw-r--r--textproc/archmage/Makefile8
-rw-r--r--textproc/archmage/files/patch-ab29
2 files changed, 30 insertions, 7 deletions
diff --git a/textproc/archmage/Makefile b/textproc/archmage/Makefile
index 0348bf6099e7..8d5d7ae2d234 100644
--- a/textproc/archmage/Makefile
+++ b/textproc/archmage/Makefile
@@ -24,12 +24,6 @@ PYDISTUTILS_INSTALLARGS= build_ext -I${LOCALBASE}/include -L${LOCALBASE}/lib \
install -c -O1 --prefix=${PREFIX}
USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s,/usr/share,${PREFIX}/share," ${WRKSRC}/arch.conf
@${REINPLACE_CMD} -e "s,/etc/arch\.conf,${PREFIX}/etc/arch\.conf," ${WRKSRC}/CHM.py
@@ -43,4 +37,4 @@ post-patch:
post-install:
@${ECHO} "archmage" > ${PYTHON_SITELIBDIR}/archmage.pth
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/archmage/files/patch-ab b/textproc/archmage/files/patch-ab
new file mode 100644
index 000000000000..660c9dd57dc7
--- /dev/null
+++ b/textproc/archmage/files/patch-ab
@@ -0,0 +1,29 @@
+--- chmlib/chm_lib.h.orig Sun Apr 3 19:53:57 2005
++++ chmlib/chm_lib.h Sun Apr 3 19:54:41 2005
+@@ -139,18 +139,15 @@
+ /* I386, 32-bit, non-Windows */
+ /* Sparc */
+ /* MIPS */
+-#elif __i386__ || __sun || __sgi
+-typedef unsigned char UChar;
+-typedef short Int16;
+-typedef unsigned short UInt16;
+-typedef long Int32;
+-typedef unsigned long UInt32;
+-typedef long long Int64;
+-typedef unsigned long long UInt64;
+ #else
+-
+-/* yielding an error is preferable to yielding incorrect behavior */
+-#error "Please define the sized types for your platform in chm_lib.c"
++/* In Unix we have fixed size types in sys/types.h */
++typedef unsigned char UChar;
++typedef int16_t Int16;
++typedef uint16_t UInt16;
++typedef int32_t Int32;
++typedef uint32_t UInt32;
++typedef int64_t Int64;
++typedef uint64_t UInt64;
+ #endif
+
+